Bug 615921 - gnome-session does remember running applications when it should not
Summary: gnome-session does remember running applications when it should not
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-session   
(Show other bugs)
Version: 6.1
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Ray Strode [halfline]
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-19 09:33 UTC by Radek Lat
Modified: 2010-07-20 14:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-20 14:17:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Radek Lat 2010-07-19 09:33:09 UTC
Description of problem:
In gnome-session-properties after checking "Automatically remember running applications" then logging out, logging in again and unchecking the same checkbox, it still remembers last running applications when it should not.

Version-Release number of selected component (if applicable):
gnome-session-2.28.0-14.el6.x86_64

How reproducible:
Running following test cases:
1. https://tcms.engineering.redhat.com/case/43562/?from_plan=2145
2. https://tcms.engineering.redhat.com/case/43563/?from_plan=2145
  
Actual results:
Session applications remembered in case 1 will still start after case 2.

Expected results:
None of the session applications remembered in case 1 should start after case 2.

Comment 1 Ray Strode [halfline] 2010-07-19 15:05:43 UTC
is it remembing the running applications from this logout? or the running applications from the last logout that the box was checked?

Comment 2 Radek Lat 2010-07-20 12:22:31 UTC
(In reply to comment #1)
> is it remembing the running applications from this logout? or the running
> applications from the last logout that the box was checked?    

It is remembering running applications from the last logout that the box was checked.

Comment 3 Ray Strode [halfline] 2010-07-20 14:17:09 UTC
Okay, that's actually "by design".  

We could potentially add a "Forget Previously Saved Applications" button next to "Remember Currently Running Applications", but not without customer demand.


Note You need to log in before you can comment on or make changes to this bug.