Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 615987 - SAN install fails with error Device /dev/mapper/mpathep1 not found (or ignored by filtering
SAN install fails with error Device /dev/mapper/mpathep1 not found (or ignore...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity high
: rc
: ---
Assigned To: Ales Kozumplik
Release Test Team
:
: 595866 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-19 08:45 EDT by Barry Donahue
Modified: 2014-09-30 19:39 EDT (History)
7 users (show)

See Also:
Fixed In Version: anaconda-13.21.69-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 14:51:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda log (7.56 KB, text/plain)
2010-07-19 08:47 EDT, Barry Donahue
no flags Details
Console log (52.86 KB, text/plain)
2010-07-19 08:48 EDT, Barry Donahue
no flags Details
storage log (329.47 KB, text/plain)
2010-07-19 08:48 EDT, Barry Donahue
no flags Details
system log (79.81 KB, text/plain)
2010-07-19 08:49 EDT, Barry Donahue
no flags Details
program log (22.53 KB, text/plain)
2010-07-27 13:03 EDT, Barry Donahue
no flags Details

  None (edit)
Description Barry Donahue 2010-07-19 08:45:48 EDT
Description of problem:   I'm trying to do an install to SAN disks. The install works fine if there are 4 or less disks configured but fails if there is a fifth disk


Version-Release number of selected component (if applicable):
anaconda version 13.21.56
RHEL6.0-20100715.2

How reproducible:always


Running anaconda 13.21.56, the Red Hat Enterprise Linux system installer - please wait.
Examining storage devices
Creating device /dev/mapper/mpathap1
Creating ext4 filesystem on /dev/mapper/mpathap1
In progress

Creating device /dev/mapper/mpathap2
Creating physical volume (LVM) on /dev/mapper/mpathap2
In progress

Creating device /dev/mapper/mpathbp1
Creating physical volume (LVM) on /dev/mapper/mpathbp1
In progress

Creating device /dev/mapper/mpathcp1
Creating physical volume (LVM) on /dev/mapper/mpathcp1
In progress

Creating device /dev/mapper/mpathdp1
Creating physical volume (LVM) on /dev/mapper/mpathdp1
In progress

Creating device /dev/mapper/mpathep1
Creating physical volume (LVM) on /dev/mapper/mpathep1
In progress

Command line mode requires all choices to be specified in a kickstart configuration file.
Storage Activation Failed
An error was encountered while activating your storage configuration.

pvcreate failed for /dev/mapper/mpathep1: 15:57:42,423 ERROR   :   Device /dev/mapper/mpathep1 not found (or ignored by filtering).
('custom', ['_File Bug', '_Exit installer'])
Comment 1 Barry Donahue 2010-07-19 08:47:52 EDT
Created attachment 432855 [details]
anaconda log
Comment 2 Barry Donahue 2010-07-19 08:48:22 EDT
Created attachment 432856 [details]
Console log
Comment 3 Barry Donahue 2010-07-19 08:48:46 EDT
Created attachment 432857 [details]
storage log
Comment 4 Barry Donahue 2010-07-19 08:49:07 EDT
Created attachment 432858 [details]
system log
Comment 6 RHEL Product and Program Management 2010-07-19 09:18:01 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 7 Chris Lumens 2010-07-19 09:58:46 EDT
Does /dev/mapper/mpathep1 even exist?
Comment 8 Barry Donahue 2010-07-19 10:02:12 EDT
  Yes it does. I've experimented with this and discovered that if I have 4 SAN disks the install will succeed but the fifth will make it fail. mpathe is the 5th disk.
Comment 9 David Cantrell 2010-07-22 15:28:00 EDT
Where are we on this one?  Is it still happening as of snapshot 8?
Comment 10 Barry Donahue 2010-07-22 15:35:14 EDT
I'll try snap 8 tomorrow, 7/23.
Comment 11 Barry Donahue 2010-07-22 16:09:13 EDT
I Hit the bug on what will be snap-8 RHEL6.0-20100722.0.
Comment 12 David Cantrell 2010-07-26 20:36:06 EDT
Can you attach /tmp/program.log as well?
Comment 13 Barry Donahue 2010-07-27 13:03:16 EDT
Created attachment 434752 [details]
program log

here it is.
Comment 18 Ales Kozumplik 2010-08-03 11:29:27 EDT
Hi,

can you please test with the latest storage code and upload a fresh traceback
in case you encounter an exception?

http://akozumpl.fedorapeople.org/lstorage_0803.img

Thank you.
Ale.
Comment 19 Barry Donahue 2010-08-03 16:09:50 EDT
I tried this with RHEL6.0-20100730.5 and got the following traceback.

Looking for installation images on CD device /dev/sr0Running anaconda 13.21.66, the Red Hat Enterprise Linux system installer - please wait.
Examining storage devices
anaconda 13.21.66 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicetree.py", line 2029, in populate
    mp_info = udev_get_block_device(mp.sysfs_path)
  File "/usr/lib/anaconda/storage/__init__.py", line 385, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 103, in storageInitialize
    storage.reset()
  File "/usr/bin/anaconda", line 1097, in <module>
    storage.storageInitialize(anaconda)
AttributeError: 'MultipathDevice' object has no attribute 'sysfs_path'

install exited abnormally [1/1] 
The system will be rebooted when you press Ctrl-C or Ctrl-Alt-Delete.
Comment 20 Ales Kozumplik 2010-08-04 11:00:25 EDT
Hi Barry,

that's a separate and known issue, please retest with an updates image
containing a fix for that:
http://akozumpl.fedorapeople.org/lstorage_0803_fp.img

If you get an error please upload the traceback file.

Thank you.
Ales
Comment 21 Ales Kozumplik 2010-08-04 14:46:02 EDT
Hi,

patch fixing the issue sent to anaconda-devel-list.

I verified it is working against the RHEL6.0-20100804.n.0 tree.
Comment 23 Ales Kozumplik 2010-08-05 06:37:58 EDT
*** Bug 595866 has been marked as a duplicate of this bug. ***
Comment 25 Ales Kozumplik 2010-08-05 11:58:39 EDT
fixed by fb1d5c5d803eca156fb47ad83f66a6cfc149c0ca, will make it into anaconda-13.21.69-1.
Comment 26 Barry Donahue 2010-08-10 10:49:40 EDT
Verified on RHEL6.0-20100809.0
Comment 27 Issue Tracker 2010-08-23 15:12:27 EDT
Event posted on 08-23-2010 02:14pm EDT by Glen Johnson

------- Comment From maknayak@in.ibm.com 2010-08-23 13:57 EDT-------
Verified this bug on RHEL6 Snap11 x86_64 on x3850 M2 system and issue did
not get reproduced.
Looks like anaconda version 13.21.78-1.el6 has fix for this issue.

[root@elm17d51 ~]# uname -a
Linux elm17d51.beaverton.ibm.com 2.6.32-63.el6.x86_64 #1 SMP Wed Aug 11
00:38:12 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux

Thanks...
Manas


This event sent from IssueTracker by jkachuck 
 issue 935583
Comment 28 releng-rhel@redhat.com 2010-11-10 14:51:18 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.