Bug 61617 - Invalid line in /proc/partitions
Invalid line in /proc/partitions
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks: 61901
  Show dependency treegraph
 
Reported: 2002-03-22 00:41 EST by Ulrich Drepper
Modified: 2014-03-16 22:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-04 12:47:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulrich Drepper 2002-03-22 00:41:20 EST
Description of Problem:

Similar to bug #56815 (which is against 7.2, therefore a separate bug for the
beta).  The message I see is

  Updating /etc/fstab invalid line in /proc/partitions: '0'   [FAILED]

That's a zero in the quotes.  It happens after a completely install on a brand
new harddrive on a laptop.  The harddrive had some M$ filesystems on it
(probably from testing in the factory).  I just removed the partitions but left
the other structures in place.  This is the content of /proc/partitions:

major minor  #blocks  name     rio rmerge rsect ruse wio wmerge wsect wuse
running use aveq

   3     0    9820440 hda 10347 37911 155550 58940 2163 3718 19148 124060 -2
789350 -1416760
   3     1     309928 hda1 7009 30425 74868 21100 561 1900 4972 74360 0 27320 95460
   3     2    4097520 hda2 3092 6834 78826 34260 429 784 9704 20740 0 32540 55000
   3     3     514080 hda3 163 499 1324 2520 1102 840 3884 17110 0 7980 19630
   3     4          1 hda4 0 0 0 0 0 0 0 0 0 0 0
   3     5     204088 hda5 54 55 218 710 63 190 516 11830 0 2990 12540
   3     6     128488 hda6 4 3 32 40 0 0 0 0 0 40 40
   3     7    4566208 hda7 21 83 250 260 8 4 72 20 0 280 280



Version-Release number of selected component (if applicable):


How Reproducible:

It only showed up during the first boot sequence after the installation.

Steps to Reproduce:
1. Get a new laptop harddrive
2. remove all partitions
3. install with several new partitions


Additional Information:
Comment 1 Bill Nottingham 2002-04-04 12:47:39 EST
OK, this is probably because /proc/partitions is changing (due to the io
accounting patches) while it's being parsed with fgets/sscanf. The parser needs to
be rewritten, it looks like...
Comment 2 Bill Nottingham 2002-04-07 22:39:13 EDT
Should be fixed in kudzu-0.99.50-1.

Note You need to log in before you can comment on or make changes to this bug.