Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 616202 - ERROR with rpm_check_debug vs depsolve: plexus-resources >= 1.0-alpha-6 is needed by maven-checkstyle-plugin-2.5-1.fc14.noarch
ERROR with rpm_check_debug vs depsolve: plexus-resources >= 1.0-alpha-6 is ne...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-19 16:15 EDT by James Laska
Modified: 2014-01-21 18:16 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-19 17:28:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (70.23 KB, text/plain)
2010-07-19 16:15 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2010-07-19 16:15:13 EDT
Created attachment 432988 [details]
build.log

Description of problem:

While attempting a fedora-rawhide-x86_64 mock --rebuild of a new package for Fedora, 

Version-Release number of selected component (if applicable):
 * yum-3.2.27-4.fc13.noarch
 * rpm-4.8.1-2.fc13.x86_64
 * mock-1.1.1-1.fc13.noarch

How reproducible:
 * I'm sure this depends on the nature of what is available in the rawhide repo, but this seems to be fairly easy to trigger at the moment.

Steps to Reproduce (Fedora 13/x86_64):
1. yum install mock
2. wget http://jlaska.fedorapeople.org/autoqa/rpms/htmlunit/htmlunit-2.7-0.1.fc14.src.rpm
3. mock -r fedora-devel-x86_64 --verbose --rebuild ~/public_html/autoqa/rpms/htmlunit/htmlunit-2.7-0.1.fc14.src.rpm
  
Actual results:

Please report this error in http://yum.baseurl.org/report
ERROR with rpm_check_debug vs depsolve:
plexus-resources >= 1.0-alpha-6 is needed by maven-checkstyle-plugin-2.5-1.fc14.noarch
You could try running: rpm -Va --nofiles --nodigest

Expected results:

 * Ideally deps would resolve, but I'm uncertain whether some of the %BuildRequires packages have faulty %{version}-%{release} strings that are making comparison difficult

Additional info:

 * maven-checkstyle-plugin-2.5-1.fc14.noarch is asking for plexus-resources >= 1.0-alpha-6.  Plexus-resources-1.0-0.2.a4.fc12 is available in rawhide.
Comment 1 James Laska 2010-07-19 16:17:37 EDT
Description of problem:

While attempting a fedora-rawhide-x86_64 mock --rebuild of a new package for
Fedora, the mock build fails indicating a discrepancy between rpm_check_debug and depsolve algorithms.
Comment 2 James Antill 2010-07-19 17:04:56 EDT
 The error from rpm is:

plexus-resources >= 1.0-alpha-6 is needed by maven-checkstyle-plugin-2.5-1.fc14.noarch

...but from the transaction list:

 plexus-resources                 noarch 1.0-0.2.a4.fc12           fedora  17 k

...and:

% rpmdev-vercmp 1.0-alpha-6 1.0-0.2.a4.fc12
0:1.0-0.2.a4.fc12 is newer

...so this seems like it must be an rpm bug, I'm just really surprised about it. Did I miss anything?
Comment 3 Spike 2010-07-19 17:17:37 EDT
This is actually a faulty BuildRequire. Could you please install it manually with rpm --nodeps and try to run it, since I don't really know if it works correctly with plexus alpha4. If you see any LifecycleExecutionException (or other errors), please open another bug.
Comment 4 Spike 2010-07-19 17:28:45 EDT
Should be fixed in rawhide.

koji build: https://koji.fedoraproject.org/koji/taskinfo?taskID=2329805
Comment 5 Spike 2010-07-19 17:48:07 EDT
Guess I was a little to quick. Committed without actually fixing anything.

New koji build: https://koji.fedoraproject.org/koji/taskinfo?taskID=2329821

Note You need to log in before you can comment on or make changes to this bug.