Bug 61624 - inputting multibytes characters is broken
inputting multibytes characters is broken
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnumeric (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks: 61901
  Show dependency treegraph
 
Reported: 2002-03-22 04:24 EST by Akira TAGOH
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-27 00:14:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (77.83 KB, image/jpeg)
2002-03-22 04:25 EST, Akira TAGOH
no flags Details
fix patch (654 bytes, patch)
2002-03-22 04:26 EST, Akira TAGOH
no flags Details | Diff
Oops... please use this instead of. (723 bytes, patch)
2002-03-24 10:02 EST, Akira TAGOH
no flags Details | Diff

  None (edit)
Description Akira TAGOH 2002-03-22 04:24:37 EST
From Bugzilla Helper:  
User-Agent: Mozilla/5.0 (compatible; Konqueror/2.99 (3.0 rc3);  
Linux)  
  
Description of problem: 
current gnumeric is handling with 1char == 1byte. so that inputting  
the characters on cell is broken because multibytes character is 
also counted as 1byte. 
  
Version-Release number of selected component (if applicable):  
  
  
How reproducible:  
Always  
  
Steps to Reproduce:  
1.Choose Japanese font like 'Kochi Gothic'  
2.input Japanese characters via XIM on input box.  
3.  
   
  
Actual Results:  the characters only on cell is broken.  
  
Expected Results:  cell and input box should be shown similar.  
  
Additional info:
Comment 1 Akira TAGOH 2002-03-22 04:25:46 EST
Created attachment 49624 [details]
screenshot
Comment 2 Akira TAGOH 2002-03-22 04:26:48 EST
Created attachment 49625 [details]
fix patch
Comment 3 Akira TAGOH 2002-03-22 04:29:56 EST
This problem is already reported to upstream. 
See also http://bugzilla.gnome.org/show_bug.cgi?id=67073 
 
This patch is included in that.
Comment 4 Havoc Pennington 2002-03-22 07:58:31 EST
The patch leaks the return value of gtk_editable_get_chars()
Comment 5 Akira TAGOH 2002-03-24 10:02:38 EST
Created attachment 49966 [details]
Oops... please use this instead of.
Comment 6 Havoc Pennington 2002-03-26 16:47:13 EST
Jody says this patch (the second version) and Nakai's input method 
patch on bugzilla.gnome.org are probably safe, if you guys tested them
in both C/japanese/Latin-1 locales.
Comment 7 Havoc Pennington 2002-03-26 16:49:11 EST
Jody also says that Gnumeric is NOT going to be usable in multibyte locales, 
even with these patches - bunches of other things will still be broken, 
though.
Comment 8 Nakai 2002-03-27 00:14:38 EST
Gnumeric 1.0.x will be usable in CJK locale with this patch.
It will not as usable as it in English, but the patch will improve it so much.
And XIM update position patch will not break other single byte locale.
You and Jody don't know how XIM support is important for CJK users.
Imagine the sadness that you cannot input your mother language with your
keyboard. Oops, sad...
Comment 9 Havoc Pennington 2002-03-27 16:38:26 EST
Patch applied, 1.0.5-2

Note You need to log in before you can comment on or make changes to this bug.