Bug 616281 - "Automatic Download Printer Driver" not works.
"Automatic Download Printer Driver" not works.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
: 616293 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-19 22:36 EDT by kota SEKI
Modified: 2010-09-02 06:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-22 06:15:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kota SEKI 2010-07-19 22:36:30 EDT
Description of problem:
 I knew that Fedora is supported "Automatic Download Printer Driver".
 (When Printer USB cable plugs to the PC,  then printer driver is downloaded from internet and installed it)  But when I try the above, printer driver was not downloaded.

Version-Release number of selected component (if applicable):
 system-config-printer 1.2.1

How reproducible:
 - Regist Printer Driver repository and gpg key below.
 - Power on the Printer, then USB cable plugs to PC.

Steps to Reproduce:
1. Edit the yum repository setting file.
   # vi /etc/yum.repos.d/lsb.repo

   [lsb-drivers]
   baseurl=http://linux.avasys.jp/drivers/lsb/Epson-inkjet/stable/RPMS
   enabled=1
   gpgchecnk=1

2. Get and register the gpg key.
   # wget https://linux.avasys.jp/drivers/lsb/epson-inkjet/key/pubkey.asc
   # rpm --import pubkey.asc

3. Turn on the Printer and Plugs the Printer's USB cable to the PC.
  
Actual results:
 Printer Driver was not downloaded and installed.

Expected results:
 When printer is plugged, it should be download the driver.
 Then it will install.

Additional info: 
 I tried to see system-config-printer's log.

  # system-config-printer --setup-printer='file:/tmp/printout' --devid='MFG:Epson;MDL:Stylus Photo TX800FW' --debug

 When I type this, then I found logs about "jockey".

 ...
 Asking Jockey to install drivers
 Got Jockey error: org.freedesktop.DBUS.Error.ServiceUnknown: The name com.ubuntu.DeviceDriver was not provided by any .service files  ...
Comment 1 Tim Waugh 2010-07-20 09:08:21 EDT
Automatic printer driver installation requires several things to be in place.  In particular:
* the RPMs must be in a configured yum repository
* the RPMs must contain appropriate tags

Firstly, this URL:
  http://linux.avasys.jp/drivers/lsb/Epson-inkjet/stable/RPMS
doesn't look like a yum repository to me.  There is no repodata directory.

Secondly, do your RPMs contain the appropriate tags?  In order for them to do so, your driver must declare a Device ID for each printer model that it supports, and you must build the RPM packages using a version of 'rpm' that supports printer Device ID tagging.

'Jockey' is not relevant to the Automatic Printer Driver Download feature in Fedora.

See https://fedoraproject.org/wiki/Features/AutomaticPrintDriverInstallation for more information on requirements for this feature.
Comment 3 kota SEKI 2010-07-21 01:32:59 EDT
> Firstly, this URL:
>   http://linux.avasys.jp/drivers/lsb/Epson-inkjet/stable/RPMS
> doesn't look like a yum repository to me.  There is no repodata directory.

 Sorry. the correct URL is below.
  http://linux.avasys.jp/drivers/lsb/epson-inkjet/stable/RPMS/

> Secondly, do your RPMs contain the appropriate tags?  In order for them to do
> so, your driver must declare a Device ID for each printer model that it
> supports, and you must build the RPM packages using a version of 'rpm' that
> supports printer Device ID tagging.

 I'm checking my RPMs files now.
 May I have time? Because I'm not good at English.

> See https://fedoraproject.org/wiki/Features/AutomaticPrintDriverInstallation
> for more information on requirements for this feature.
 
 Thank you.
Comment 4 kota SEKI 2010-07-22 03:48:51 EDT
Now, I've checked my RPMs and the web page.
https://fedoraproject.org/wiki/Features/AutomaticPrintDriverInstallation

Fedora13's Automatic printer driver installation mechanism use "PROVIDES" tag of RPM package. And It seems defferent from OpenPrinting mechanism.

My RPMs does not have "PROVIDES" tags. So I can't realize Automatic printer driver installation on Fedora13.

But I think the mechanism has a probrem.
It is different from OpenPrinting mechanis, this means End-User must register repository each vender. How does End-User know the repository?
Comment 5 Tim Waugh 2010-07-22 06:15:11 EDT
(In reply to comment #4)
> Fedora13's Automatic printer driver installation mechanism use "PROVIDES" tag
> of RPM package. And It seems defferent from OpenPrinting mechanism.

There is no "OpenPrinting" mechanism.  There are packages hosted at OpenPrinting, and there is Jockey, and that's all.

Jockey is an add-on installer.  It can only deal with 3rd party packages, and not with packages provided as part of the operating system (as I understand it).  It is also not cross-platform, again as I understand it.

PackageKit *is* cross-platform, and works with all major packaging formats.  Fedora uses PackageKit to install fonts, MIME-type handlers, AV codecs, etc... and now printer drivers.  It is a natural extension of an existing mechanism that already works well.

The constraints placed upon drivers are minimal really: they just need to declare the IEEE 1284 Device IDs for printers that they support, using the existing mechanisms for doing so, e.g. a *1284DeviceID: attribute in a PPD file.  Additionally, when they are packaged they need to have the relevant tags added to the packages.  When building the packages on Fedora this is just a case of making sure that the Device IDs can be obtained at build time.

Till Kamppeter has expressed interest in using this process for building the OpenPrinting packages.

> My RPMs does not have "PROVIDES" tags. So I can't realize Automatic printer
> driver installation on Fedora13.

Well, unless you add them. :-)

> But I think the mechanism has a probrem.
> It is different from OpenPrinting mechanis, this means End-User must register
> repository each vender. How does End-User know the repository?    

I think that's a problem for each vendor to think about.  Perhaps by including instructions in the box telling the user to visit a particular web site before connecting the printer, for instance.

Of course, for free drivers that can be shipped as part of Fedora that step won't be necessary.

I'm closing this bug now.  I'm happy to answer more of your questions about this mechanism but I think email is better suited to that, perhaps on the system-config-printer-devel mailing list.
Comment 6 Tim Waugh 2010-09-02 06:55:38 EDT
*** Bug 616293 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.