Bug 616355 - [RFE] Add configurable grab key sequences for VMM
[RFE] Add configurable grab key sequences for VMM
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Michal Novotny
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-20 05:04 EDT by Michal Novotny
Modified: 2014-02-02 17:37 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-23 10:57:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add configurable grab key combination to VMM (11.20 KB, patch)
2010-08-09 14:37 EDT, Michal Novotny
no flags Details | Diff
New version of my patch including the exception handling for older version of Gtk-VNC (13.03 KB, patch)
2010-08-10 08:04 EDT, Michal Novotny
no flags Details | Diff
Support GTK-VNC configurable grab key combination (14.16 KB, patch)
2010-08-24 10:47 EDT, Michal Novotny
no flags Details | Diff

  None (edit)
Description Michal Novotny 2010-07-20 05:04:15 EDT
Description of problem:
Since Gtk-Vnc release 0.4.0 (since git commit 378721ec1) the new API for configurable key grab sequences has been added. Users of virt-manager may want to change their grab key sequence since they may be using the default key combination for some other purpose, e.g. set to switching the window manager windows.

Version-Release number of selected component (if applicable):
-

How reproducible:
-

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Grab keys are not configurable at the moment and they're pre-set to default Ctrl + Alt key combination.

Expected results:
When adding this feature user will be able to configure grab keys in the virt-manager preferences box. This should be saved in the plain text form (as it's show in window title when you have the grabbing active) somewhere in GConf configuration to make virt-manager remember it for the next run.

Additional info:
-
Comment 1 Michal Novotny 2010-08-09 14:37:53 EDT
Created attachment 437674 [details]
Patch to add configurable grab key combination to VMM

Hi,
this is the patch to add configurable grab keys combination I did in my spare time (originally for my own purposes). It requires at least GtkVNC 0.4.0 with the support for configuring the grab keys.

Michal
Comment 2 Michal Novotny 2010-08-10 08:04:35 EDT
Created attachment 437855 [details]
New version of my patch including the exception handling for older version of Gtk-VNC

Hi,
this is the new version of the patch including the exception handling when used with the old version of Gtk-VNC (pre-commit 378721ec1) that doesn't support the configurable grab keys.

Michal
Comment 3 Michal Novotny 2010-08-24 10:47:59 EDT
Created attachment 440678 [details]
Support GTK-VNC configurable grab key combination

This is the new version of the patch with some improvements and changes.

Differences between version 1 and version 2 (this one):
  - Implement the grab_keys_supported() method to check for configurable 
grab keys support in the GTK-VNC version currently installed
  - Grab key sequence is configurable in Prefs-> VM Details and "Change" 
button is disabled when GTK-VNC doesn't support it - tooltip is being shown
  - Exception handling when somebody manually edited the grab-keys in 
GConf has been added to ignore invalid (non-integer) key codes

Michal
Comment 4 Cole Robinson 2011-03-23 10:57:23 EDT
In rawhide now.

Note You need to log in before you can comment on or make changes to this bug.