Bug 616386 - Urlgrabber command line exits with 0 on failure
Urlgrabber command line exits with 0 on failure
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-urlgrabber (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Valentina Mukhamedzhanova
BaseOS QE - Apps
:
Depends On:
Blocks: 918613
  Show dependency treegraph
 
Reported: 2010-07-20 06:32 EDT by Petr Šplíchal
Modified: 2017-12-06 05:36 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 918613 (view as bug list)
Environment:
Last Closed: 2017-12-06 05:36:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Šplíchal 2010-07-20 06:32:59 EDT
Description of problem:

The urlgrabber command line tool does not return non-zero status
when a failure (such as file does not exist) is encountered. Also
an empty file is created.

Version-Release number of selected component (if applicable):
python-urlgrabber-3.9.1-7.el6.noarch

Steps to Reproduce:
# urlgrabber http://www.redhat.com/nothing.html
[Errno 14] HTTP Error 404 : http://www.redhat.com/nothing.html 

Actual results:
# echo $?
0

# ls -l nothing.html
-rw-r--r--. 1 root 1076 0 Jul 20 06:28 nothing.html

Expected results:
non-zero status returned, no file created
Comment 1 RHEL Product and Program Management 2011-01-07 10:54:42 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 6 Suzanne Yeghiayan 2012-02-14 18:01:01 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 7 Zdeněk Pavlas 2013-04-17 08:31:43 EDT
commit 7396230d60ae0ffee99aa3363d77e30f4e3e57d4
Author: Zdenek Pavlas <zpavlas@redhat.com>
Date:   Wed Mar 6 17:36:50 2013 +0100

    exit(1) on /bin/urlgrabber failures.  BZ 918613
Comment 8 RHEL Product and Program Management 2013-10-13 21:18:24 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 11 Jan Kurik 2017-12-06 05:36:46 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.