Bug 616543 - Gnome-volume-control disappeared from system and SPEC file.
Gnome-volume-control disappeared from system and SPEC file.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-20 14:23 EDT by Gene Snider
Modified: 2012-10-04 02:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-04 02:50:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Snider 2010-07-20 14:23:33 EDT
Description of problem:
Running Sound Preferences from the notification area icon, System > Preferences > Sound, or the command line no longer works.  In particular, the terminal attempt results in:

[gene@Mobile-PC ~]$ gnome-volume-control
bash: gnome-volume-control: command not found

Looking at the SPEC files for 2.30.0 and 2.31.5 reveals that gnome-volume-control disappeared from the %files section.  The gnome-volume-control.desktop file did not disappear.

Summary: GNOME media programs
Name: gnome-media
Version: 2.30.0
...
%files
%defattr(-, root, root)
%doc AUTHORS COPYING NEWS README
%{_bindir}/gnome-volume-control    ## This line is NOT in the next version. ##
%{_bindir}/gnome-volume-control-applet
%{_bindir}/gnome-audio-profiles-properties
%{_sysconfdir}/xdg/autostart/gnome-volume-control-applet.desktop
%{_datadir}/applications/gnome-volume-control.desktop
%{_datadir}/icons/hicolor/*/apps/gnome-volume-control*
%{_datadir}/gnome-media
%{_datadir}/sounds/gnome/ 

Summary: GNOME media programs
Name: gnome-media
Version: 2.31.5
...
%files
%defattr(-, root, root)
%doc AUTHORS COPYING NEWS README
%{_bindir}/gnome-volume-control-applet
%{_bindir}/gnome-audio-profiles-properties
%{_libdir}/control-center-1/panels/libsound.so
%{_sysconfdir}/xdg/autostart/gnome-volume-control-applet.desktop
%{_datadir}/applications/gnome-volume-control.desktop
%{_datadir}/icons/hicolor/*/apps/multimedia-volume-control.*
%{_datadir}/icons/hicolor/*/status/audio-input-microphone*
%{_datadir}/gnome-media
%{_datadir}/sounds/gnome/

Running gnome-control-center sound, which is in the new desktop file, doesn't work either.  It results in the following command line output:

[gene@Mobile-PC ~]$ gnome-control-center sound
Gtk-Message: Failed to load module "atk-bridge": libatk-bridge.so: cannot open shared object file: No such file or directory
Gtk-Message: Failed to load module "gail-gnome": libgail-gnome.so: cannot open shared object file: No such file or directory

** (gnome-control-center:13172): WARNING **: Could not load icon 'gnome-volume-control': Icon 'gnome-volume-control' not present in theme

** (gnome-control-center:13172): WARNING **: Could not find settings panel "sound"

** (gnome-control-center:13172): WARNING **: Could not load setting panel "sound": Unknown error


Version-Release number of selected component (if applicable):
2.31.4-1.fc14

How reproducible:
Easily.

Steps to Reproduce:
1. Try to run gnome-volume-control by any method.
2.
3.
  
Actual results:
The executable is not found.

Expected results:
The gui should open.

Additional info:
Comment 1 Bastien Nocera 2010-07-21 10:54:19 EDT
Which versions of gnome-media and control-center do you have?
Comment 2 Gene Snider 2010-07-21 12:22:44 EDT
Hi Bastien,

I have:
Installed Packages
control-center.x86_64        1:2.31.5-1.fc14        @rawhide
gnome-media.x86_64             2.31.5-2.fc14        @rawhide

I see that there's a new control-center in koji.  Should I try it?

Thanks,
Gene
Comment 3 Gene Snider 2010-07-21 12:59:43 EDT
I tried the new koji control-center, control-center-2.31.5-2.fc14.  The problem still persists.

Thanks,
Gene
Comment 4 Bastien Nocera 2010-07-22 09:25:26 EDT
** (gnome-control-center:13172): WARNING **: Could not load icon 'gnome-volume-control': Icon 'gnome-volume-control' not present in theme

I have no idea where it gets that from, but there's no mention of that icon name being used anywhere in gnome-media's panel.

** (gnome-control-center:13172): WARNING **: Could not find settings panel "sound"

That means that control-center could not parse "/usr/share/applications/gnome-volume-control.desktop".

You might want to double-check whether the packages are installed properly.

I cannot reproduce the problem with the same package version numbers.
Comment 5 Gene Snider 2010-07-29 11:38:00 EDT
I was able to fix my initial problem by deleting the gnome-volume-control.desktop file in my home directory.  However, the volume control applet in the notification area is displaying the "missing icon" icon instead of the volume control icon.  From reading the forum thread, this appears to be the case for all rawhide testers.

Thanks,
Gene
Comment 6 Bug Zapper 2010-07-30 08:43:02 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bastien Nocera 2010-08-02 04:44:54 EDT
(In reply to comment #5)
> I was able to fix my initial problem by deleting the
> gnome-volume-control.desktop file in my home directory.  However, the volume
> control applet in the notification area is displaying the "missing icon" icon
> instead of the volume control icon.  From reading the forum thread, this
> appears to be the case for all rawhide testers.

Install gnome-icon-theme-symbolic and let us know whether that still happens.
Comment 8 Gene Snider 2010-08-02 15:08:48 EDT
Bastien,

Installing gnome-icon-theme-symbolic gave me the icon I was missing.  It's a little hard to see in my theme since the icon is black, but at least it's an icon!  :)  Does gnome-icon-theme-symbolic need to be a dependency for gnome-media?  I've never seen a missing dependency, as far as I can remember.

Gene
Comment 9 Matthias Clasen 2010-08-13 14:26:18 EDT
This doesn't affect the version now in f14, moving back to rawhide.
Comment 10 Bastien Nocera 2012-10-04 02:50:23 EDT
This doesn't affect F16 and newer running with GNOME Shell, so closing.

Note You need to log in before you can comment on or make changes to this bug.