Bug 61667 - missing file? up2date-2.7.11-7.x.1 header missing from RHN
missing file? up2date-2.7.11-7.x.1 header missing from RHN
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Channels (Show other bugs)
RHN Stable
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-22 14:41 EST by James Manning
Modified: 2007-04-18 12:41 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-15 10:58:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Manning 2002-03-22 14:41:42 EST
[root@porivoapp01 /tmp]# rpm -q redhat-release
redhat-release-7.1-1
[root@porivoapp01 /tmp]# rpm -q up2date
up2date-2.5.2-1
[root@porivoapp01 /tmp]# up2date up2date

Retrieving list of all available packages...

Removing installed packages from list of updates...
########################################

Removing packages with files not specified from list...

Removing packages marked to skip from list...
########################################

Getting headers for available packages...
There was a fatal error communicating with the server.  The message was:

Error Message:
    Unable to retrieve package header ['up2date', '2.7.11', '7.x.1', '', 233290]Error Class Code: 17
Error Class Info: File not found.
Explanation:
     An error has occurred while processing your request. If this problem
     persists please submit a bug report to rhn-help@redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.
Comment 1 James Manning 2002-03-22 14:42:49 EST
I heard about the errata up2date getting pulled so this is prob. just that, but I'd
imagine the channel needs to refresh so it doesn't barf like this.

Oh, and /dev/null's still on the cc list :)  should i add dkl as a cc?
Comment 2 James Manning 2002-03-22 14:52:37 EST
since it'd required python-popt and upgrading that would need rpm, i tried to go back
to just up2date'ing rpm on that same box:

[root@porivoapp01 /tmp]# up2date rpm

Retrieving list of all available packages...

Removing installed packages from list of updates...
########################################

Removing packages with files not specified from list...

Removing packages marked to skip from list...
########################################

Getting headers for available packages...
########################################

Removing packages with files marked to skip from list...
########################################

Testing package set / solving RPM inter-dependencies...
There was a package dependency problem.  The message was:
Unresolvable chain of dependencies: rpm-build-4.0.2-8 requires librpmbuild.so.0.
Comment 3 James Manning 2002-03-22 15:01:18 EST
maybe there's something broken where RHN doesn't realize that the new rpm
provides librpmio.so.0 and the others, cuz to up2date rpm-python I had to manually
specify ucd-snmp and ucd-snmp-utils as well

but itself:
Testing package set / solving RPM inter-dependencies...
There was a package dependency problem.  The message was:
Unresolvable chain of dependencies: ucd-snmp-4.2-12 requires librpmio.so.0.

just adding ucd-snmp:
Testing package set / solving RPM inter-dependencies...
There was a package dependency problem.  The message was:
Unresolvable chain of dependencies: ucd-snmp-utils-4.2-12 requires librpmio.so.0.

all 3 works fine, and then sucks in lots of others
The following packages were added to your selection to satify dependencies:

Name                                    Version        Release
--------------------------------------------------------------
rpm                                     4.0.4          7x
popt                                    1.6.4          7x
glibc                                   2.2.4          19.3
glibc-common                            2.2.4          19.3
glibc-devel                             2.2.4          19.3

Comment 4 Greg DeKoenigsberg 2002-04-29 20:04:21 EDT
Was this the borked version of up2date that snuck out the door?  We can close
this one?
Comment 5 Adrian Likins 2002-04-30 15:55:18 EDT
It's two differnt bugs, but both can be closed.
Comment 6 Greg DeKoenigsberg 2002-04-30 16:34:50 EDT
dcook, please confirm.
Comment 7 James Manning 2002-05-15 15:30:09 EDT
if dcook hasn't confirmed by now.. :) it looks fine to me

Note You need to log in before you can comment on or make changes to this bug.