Bug 616727 - condor_job_server requires JOB_SERVER_LOG
Summary: condor_job_server requires JOB_SERVER_LOG
Status: CLOSED DUPLICATE of bug 624999
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor (Show other bugs)
(Show other bugs)
Version: 1.3
Hardware: All Linux
medium
medium
Target Milestone: 1.3.2
: ---
Assignee: Matthew Farrellee
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-21 09:40 UTC by Martin Kudlej
Modified: 2010-11-24 12:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-03 16:23:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Martin Kudlej 2010-07-21 09:40:17 UTC
Description of problem: If I install condor-qmf and I don't configure anything, condor_job_server crashes with core dump.

Version-Release number of selected component (if applicable):
condor-7.4.4-0.4.el5
condor-qmf-7.4.4-0.4.el5
glibc-debuginfo-2.5-42.el5_4.4
condor-debuginfo-7.4.4-0.4.el5
glibc-debuginfo-common-2.5-42.el5_4.4

How reproducible:
100%

Steps to Reproduce:
1. install condor_qmf
2. run condor_job_server
  
Actual results:
It crashes.

Expected results:
It will print error message and it will end without coredump.

Additional info:
$ condor_job_server
ERROR "No 'JOB_SERVER_LOG' parameter specified." at line 161 in file dprintf_config.c
Aborted (core dumped)
$ gdb `which condor_job_server` core.1771
GNU gdb (GDB) Red Hat Enterprise Linux (7.0.1-23.el5_5.1)
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/sbin/condor_job_server...Reading symbols from /usr/lib/debug/usr/sbin/condor_job_server.debug...
warning: section .gnu.conflict not found in /usr/lib/debug/usr/sbin/condor_job_server.debug

warning: section .gnu.liblist not found in /usr/lib/debug/usr/sbin/condor_job_server.debug

warning: section .dynbss not found in /usr/lib/debug/usr/sbin/condor_job_server.debug
done.
done.

warning: core file may not match specified executable file.

warning: section .gnu.conflict not found in /usr/lib/debug/usr/sbin/condor_job_server.debug

warning: section .gnu.liblist not found in /usr/lib/debug/usr/sbin/condor_job_server.debug

warning: section .dynbss not found in /usr/lib/debug/usr/sbin/condor_job_server.debug

warning: .dynamic section for "/lib/libcom_err.so.2" is not at the expected address

warning: difference appears to be caused by prelink, adjusting expectations

warning: .dynamic section for "/usr/lib/libk5crypto.so.3" is not at the expected address

warning: difference appears to be caused by prelink, adjusting expectations

warning: .dynamic section for "/lib/libssl.so.6" is not at the expected address

warning: difference appears to be caused by prelink, adjusting expectations

warning: .dynamic section for "/lib/libresolv.so.2" is not at the expected address

warning: difference appears to be caused by prelink, adjusting expectations

warning: .dynamic section for "/usr/lib/libstdc++.so.6" is not at the expected address

warning: difference appears to be caused by prelink, adjusting expectations

warning: .dynamic section for "/lib/libgcc_s.so.1" is not at the expected address

warning: difference appears to be caused by prelink, adjusting expectations

warning: .dynamic section for "/lib/libuuid.so.1" is not at the expected address

warning: difference appears to be caused by prelink, adjusting expectations

warning: .dynamic section for "/lib/librt.so.1" is not at the expected address

warning: difference appears to be caused by prelink, adjusting expectations

warning: .dynamic section for "/usr/lib/libkrb5support.so.0" is not at the expected address

warning: difference appears to be caused by prelink, adjusting expectations

warning: .dynamic section for "/lib/libkeyutils.so.1" is not at the expected address

warning: difference appears to be caused by prelink, adjusting expectations

warning: .dynamic section for "/lib/libcrypt.so.1" is not at the expected address

warning: difference appears to be caused by prelink, adjusting expectations

warning: .dynamic section for "/lib/libselinux.so.1" is not at the expected address

warning: difference appears to be caused by prelink, adjusting expectations
Reading symbols from /usr/lib/libclassad_ns.so.1...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libclassad_ns.so.1
Reading symbols from /lib/libpthread.so.0...
warning: the debug information found in "/usr/lib/debug//lib/libpthread-2.5.so.debug" does not match "/lib/libpthread.so.0" (CRC mismatch).


warning: the debug information found in "/usr/lib/debug/lib/libpthread-2.5.so.debug" does not match "/lib/libpthread.so.0" (CRC mismatch).

(no debugging symbols found)...done.
Loaded symbols for /lib/libpthread.so.0
Reading symbols from /lib/libpcre.so.0...(no debugging symbols found)...done.
Loaded symbols for /lib/libpcre.so.0
Reading symbols from /usr/lib/libqmf.so.2...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libqmf.so.2
Reading symbols from /usr/lib/libqpidclient.so.3...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libqpidclient.so.3
Reading symbols from /usr/lib/libqpidcommon.so.3...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libqpidcommon.so.3
Reading symbols from /lib/libdl.so.2...
warning: the debug information found in "/usr/lib/debug//lib/libdl-2.5.so.debug" does not match "/lib/libdl.so.2" (CRC mismatch).


warning: the debug information found in "/usr/lib/debug/lib/libdl-2.5.so.debug" does not match "/lib/libdl.so.2" (CRC mismatch).

(no debugging symbols found)...done.
Loaded symbols for /lib/libdl.so.2
Reading symbols from /lib/libcom_err.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib/libcom_err.so.2
Reading symbols from /usr/lib/libk5crypto.so.3...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libk5crypto.so.3
Reading symbols from /usr/lib/libkrb5.so.3...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libkrb5.so.3
Reading symbols from /lib/libcrypto.so.6...(no debugging symbols found)...done.
Loaded symbols for /lib/libcrypto.so.6
Reading symbols from /lib/libssl.so.6...(no debugging symbols found)...done.
Loaded symbols for /lib/libssl.so.6
Reading symbols from /lib/libresolv.so.2...
warning: the debug information found in "/usr/lib/debug//lib/libresolv-2.5.so.debug" does not match "/lib/libresolv.so.2" (CRC mismatch).


warning: the debug information found in "/usr/lib/debug/lib/libresolv-2.5.so.debug" does not match "/lib/libresolv.so.2" (CRC mismatch).

(no debugging symbols found)...done.
Loaded symbols for /lib/libresolv.so.2
Reading symbols from /usr/lib/libstdc++.so.6...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libstdc++.so.6
Reading symbols from /lib/libm.so.6...
warning: the debug information found in "/usr/lib/debug//lib/libm-2.5.so.debug" does not match "/lib/libm.so.6" (CRC mismatch).
(no debugging symbols found)...done.
Loaded symbols for /lib/libm.so.6
Reading symbols from /lib/libgcc_s.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib/libgcc_s.so.1
Reading symbols from /lib/libc.so.6...
warning: the debug information found in "/usr/lib/debug//lib/libc-2.5.so.debug" does not match "/lib/libc.so.6" (CRC mismatch).


warning: the debug information found in "/usr/lib/debug/lib/libc-2.5.so.debug" does not match "/lib/libc.so.6" (CRC mismatch).

(no debugging symbols found)...done.
Loaded symbols for /lib/libc.so.6
Reading symbols from /lib/ld-linux.so.2...
warning: the debug information found in "/usr/lib/debug//lib/ld-2.5.so.debug" does not match "/lib/ld-linux.so.2" (CRC mismatch).


warning: the debug information found in "/usr/lib/debug/lib/ld-2.5.so.debug" does not match "/lib/ld-linux.so.2" (CRC mismatch).

(no debugging symbols found)...done.
Loaded symbols for /lib/ld-linux.so.2
Reading symbols from /usr/lib/libqmfengine.so.2...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libqmfengine.so.2
Reading symbols from /lib/libuuid.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib/libuuid.so.1
Reading symbols from /usr/lib/libboost_program_options.so.2...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libboost_program_options.so.2
Reading symbols from /usr/lib/libboost_filesystem.so.2...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libboost_filesystem.so.2
Reading symbols from /lib/librt.so.1...
warning: the debug information found in "/usr/lib/debug//lib/librt-2.5.so.debug" does not match "/lib/librt.so.1" (CRC mismatch).


warning: the debug information found in "/usr/lib/debug/lib/librt-2.5.so.debug" does not match "/lib/librt.so.1" (CRC mismatch).

(no debugging symbols found)...done.
Loaded symbols for /lib/librt.so.1
Reading symbols from /usr/lib/libsasl2.so.2...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libsasl2.so.2
Reading symbols from /usr/lib/libkrb5support.so.0...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libkrb5support.so.0
Reading symbols from /lib/libkeyutils.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib/libkeyutils.so.1
Reading symbols from /usr/lib/libz.so.1...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libz.so.1
Reading symbols from /usr/lib/libgssapi_krb5.so.2...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libgssapi_krb5.so.2
Reading symbols from /lib/libcrypt.so.1...
warning: the debug information found in "/usr/lib/debug//lib/libcrypt-2.5.so.debug" does not match "/lib/libcrypt.so.1" (CRC mismatch).
warning: the debug information found in "/usr/lib/debug/lib/libcrypt-2.5.so.debug" does not match "/lib/libcrypt.so.1" (CRC mismatch).

(no debugging symbols found)...done.
Loaded symbols for /lib/libcrypt.so.1
Reading symbols from /lib/libselinux.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib/libselinux.so.1
Reading symbols from /lib/libsepol.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib/libsepol.so.1
Reading symbols from /lib/libnss_files.so.2...
warning: the debug information found in "/usr/lib/debug//lib/libnss_files-2.5.so.debug" does not match "/lib/libnss_files.so.2" (CRC mismatch).


warning: the debug information found in "/usr/lib/debug/lib/libnss_files-2.5.so.debug" does not match "/lib/libnss_files.so.2" (CRC mismatch).

(no debugging symbols found)...done.
Loaded symbols for /lib/libnss_files.so.2

warning: section .gnu.conflict not found in /usr/lib/debug/usr/sbin/condor_job_server.debug

warning: section .gnu.liblist not found in /usr/lib/debug/usr/sbin/condor_job_server.debug

warning: section .dynbss not found in /usr/lib/debug/usr/sbin/condor_job_server.debug
Core was generated by `condor_job_server'.
Program terminated with signal 6, Aborted.
#0  0x00e63410 in __kernel_vsyscall ()
(gdb) info threads
* 1 Thread 19944  0x00e63410 in __kernel_vsyscall ()
(gdb) thread apply all bt

Thread 1 (Thread 19944):
#0  0x00e63410 in __kernel_vsyscall ()
#1  0x0096bdf0 in raise () from /lib/libc.so.6
#2  0x0096d701 in abort () from /lib/libc.so.6
#3  0x080de193 in _EXCEPT_ (fmt=0x8184b90 "No '%s' parameter specified.") at except.c:89
#4  0x080dffde in dprintf_config (subsys=0xa122370 "JOB_SERVER") at dprintf_config.c:161
#5  0x080d9267 in main (argc=1, argv=0xbfedac34) at daemon_core_main.cpp:1850

Comment 1 Matthew Farrellee 2010-07-21 13:14:00 UTC
See https://condor-wiki.cs.wisc.edu/index.cgi/tktview?tn=61

This is an EXCEPT. You'll find it present in all daemons. You get the core from ABORT_ON_EXCEPTION=TRUE.

Comment 2 Matthew Farrellee 2010-11-03 16:23:43 UTC

*** This bug has been marked as a duplicate of bug 624999 ***


Note You need to log in before you can comment on or make changes to this bug.