Bug 616743 - slow to format qcow2 disk
slow to format qcow2 disk
Status: CLOSED DUPLICATE of bug 615152
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-21 06:20 EDT by Suqin Huang
Modified: 2013-01-09 17:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-22 07:19:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suqin Huang 2010-07-21 06:20:55 EDT
Description of problem:
it takes around 90mins to format 10G qcow2 disk in win08 and win7 guest.

Version-Release number of selected component (if applicable):
qemu-img-0.12.1.2-2.96.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. boot guest
/qemu -name 'vm1' -monitor stdio \
-drive file='images/win2008r2-64.qcow2',if=none,id=drive-ide0-0-1,media=disk,cache=none,format=qcow2 -device ide-drive,bus=ide.0,unit=1,drive=drive-ide0-0-1,id=ide0-0-1 \
-drive file='/storage.qcow2',if=none,id=drive-ide0-1-0,media=disk,cache=none,format=qcow2 \
-device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 \
-net nic,vlan=0,netdev=idQ7kmUl,model=rtl8139,macaddr='02:2D:4B:53:9c:ee' -netdev tap,id=idQ7kmUl,,script='/qemu-ifup-switch',downscript='no' -m 4096 -smp 2 -vnc :0 -rtc base=localtime,clock=host -M rhel6.0.0 -usbdevice tablet -cpu qemu64,+sse2 -no-kvm-pit-reinjectio

2. format 10G disk
format E: /FS:NTFS /V:local /Q /y

3.
  
Actual results:


Expected results:


Additional info:
it takes around 90mins in windows08 ans win7 guests.
and quick in XP and window2003 guests
Comment 2 Suqin Huang 2010-07-21 06:27:32 EDT
format cmd:
format E: /FS:NTFS /V:local /y

format the same disk several times, only the first time is slow.
Comment 3 RHEL Product and Program Management 2010-07-21 06:37:47 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 4 Dor Laor 2010-07-22 07:19:03 EDT

*** This bug has been marked as a duplicate of bug 615152 ***

Note You need to log in before you can comment on or make changes to this bug.