Bug 616871 - cups scheduler do not save classes when adding a printer
cups scheduler do not save classes when adding a printer
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cups (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Tim Waugh
qe-baseos-daemons
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-21 11:31 EDT by Yulia Kopkova
Modified: 2010-07-21 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-21 12:53:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yulia Kopkova 2010-07-21 11:31:47 EDT
Description of problem:
classes.conf is not saved after new printer added

Version-Release number of selected component (if applicable):
cups-1.4.2-26.el6

How reproducible:
Always

Steps to Reproduce:
1. Use empty classes.conf
# cat /etc/cups/classes.conf
# Class configuration file for CUPS v1.4.2
# Written by cupsd on 2010-07-21 17:22
# DO NOT EDIT THIS FILE WHEN CUPSD IS RUNNING

2. Add printer and class
# lpadmin -p testprinter -E -v /dev/null -c testclass

3. classes.conf still empty
# cat /etc/cups/classes.conf
# Class configuration file for CUPS v1.4.2
# Written by cupsd on 2010-07-21 17:22
# DO NOT EDIT THIS FILE WHEN CUPSD IS RUNNING

4. lpstat shows printer and class added
# lpstat -c
members of class testclass:
	testprinter
  
Actual results:
New class and printer are not in classes.conf 

Expected results:
New class and assigned printer should be listed in classes.conf

Additional info:
After restart classes.conf was updated
# service cups restart
Stopping cups:                                             [  OK  ]
Starting cups:                                             [  OK  ]
# cat /etc/cups/classes.conf
# Class configuration file for CUPS v1.4.2
# Written by cupsd on 2010-07-21 17:23
# DO NOT EDIT THIS FILE WHEN CUPSD IS RUNNING
<Class testclass>
Info testclass
State Stopped
StateTime 1279725762
Accepting No
Shared Yes
JobSheets none none
Printer testprinter
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy retry-current-job
</Class>
Comment 2 RHEL Product and Program Management 2010-07-21 11:57:40 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 Yulia Kopkova 2010-07-21 12:53:13 EDT
Close not a bug.
https://bugzilla.redhat.com/show_bug.cgi?id=569903#c7

Note You need to log in before you can comment on or make changes to this bug.