Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 61689 - Need Nvidia Geforce 4 2-D support in Xfree86
Need Nvidia Geforce 4 2-D support in Xfree86
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-22 17:51 EST by John A. Hull
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-23 04:13:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John A. Hull 2002-03-22 17:51:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0; DigExt)

Description of problem:
The 2-D Nvidia nv driver in XFree86 4.2.x does not work with the new Geforce 4 
cards. Need the new driver from Nvidia. 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try to configure X in any Hampton beta on Nvidia NV25 card	

Additional info:
Comment 1 Mike A. Harris 2002-03-23 04:13:45 EST
Correct.  XFree86 4.2.0 does not support any Nvidia Geforce 4.x adaptors.

http://www.xfree86.org/4.2.0/Status22.html#22

Support for these chips is likely to appear in XFree86 4.3.0 when it is
released sometime around June/July.  In the mean time, the vesa driver
is recommended.



Side note, just to document this for others reading the report:

Since many people are going to encounter this, I want to state that I
strongly objected to putting these cards into the hardware database
and pointing them at the "nv" driver as I knew that it was not
supported to begin with, and got confirmation ahead of time from Nvidia
directly that it would not work.  Having it default to the "vesa" driver
by default would have at least made it work by default possibly.

Now, as the result of the Cards database listing these cards, people
are going to expect they will work, and they do not.  A lot of end user
frustration and expectations are going to hit bugzilla now, reporting
that the cards do not work.

Had the default been "vesa" like I suggested, this problem would be
moot.

I am now changing the default to "vesa" for this hardware, so it
at least will display 2D.
Comment 2 Mike A. Harris 2002-03-23 04:17:19 EST
Default for this hardware changed to "vesa" driver, will be in next
hwdata package release.

Note You need to log in before you can comment on or make changes to this bug.