Bug 61696 - rpm-python lacks poptmodule.so, required by up2date
rpm-python lacks poptmodule.so, required by up2date
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-22 22:43 EST by Bishop Clark
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-22 22:43:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bishop Clark 2002-03-22 22:43:49 EST
Description of Problem:

[root@ducky i386]# rpm -qlp rpm-python-4.0.3-1.03.i386.rpm
 /usr/lib/python1.5/site-packages/poptmodule.so 
 /usr/lib/python1.5/site-packages/rpmmodule.so
[root@ducky i386]# rpm -qlp rpm-python-4.0.4-7x.i386.rpm
 /usr/lib/python1.5/site-packages/rpmmodule.so
[root@ducky i386]# rpm -Fvh up2date-2.7.46-7.x.2.i386.rpm 
error: failed dependencies:
        poptmodule.so is needed by up2date-2.7.46-7.x.2
[root@ducky i386]# 

  See the problem?

Version-Release number of selected component (if applicable):
4.0.4-7x.i386.rpm

How Reproducible:
It's out there, baby.  I can reproduce this all day.

Steps to Reproduce:
1. take one otherwise-fully-updated system
2. rpm -Fvh ftp://updates.redhat.com/7.2/en/os/i386/up2date-2.7.46-7.x.2.i386.rpm
3. wail in disbelief and shock until mom bakes cookies.

Actual Results:
error: failed dependencies:
        poptmodule.so is needed by up2date-2.7.46-7.x.2

Expected Results:
Preparing...                ########################################### [100%]
   1:up2date                ########################################### [100%]

Additional Information:

Jeff!  What's this all abooot?
  * Thu Jan 10 2002 Jeff Johnson <jbj@redhat.com>
  - fix: signing multiple times dinna work, discard immutable region.
  - remove poptmodule.so for separate packaging.

Where's the poptmodule *now*?  You're hiding it, aren't you?  Give it back!
Comment 1 Jeff Johnson 2002-03-23 10:03:59 EST
You need to install the python-popt package.
Comment 2 Bishop Clark 2002-03-23 15:52:30 EST
Ohh, yes, that makes sense, now.  Care to drop 'python-popt' into a Requires: on
up2date?

Thanks for the speedy help, jeff.  Most appreciated.
Comment 3 Phil Mayers 2002-03-25 10:59:31 EST
Yes - *please* ship an up2date update (so to speak). We're using a specific bit
of patching software on our beowulf nodes that can't deal with this dependency
failure.

Note You need to log in before you can comment on or make changes to this bug.