This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 617014 - client rpm has some oddities
Summary: client rpm has some oddities
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: Tools (Show other bugs)
(Show other bugs)
Version: 1.1
Hardware: All Linux
low
medium
Target Milestone: ---
: ---
Assignee: Jay Dobies
QA Contact: wes hayutin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-21 22:12 UTC by wes hayutin
Modified: 2012-05-31 12:53 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-31 12:53:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description wes hayutin 2010-07-21 22:12:26 UTC
may not be a bug, but better safe than sorry..

Wondering if we just want to force an overwrite of any old config files????


[root@ip-10-202-197-207 ~]# rpm -Uvh rh-client-config-0.1-1.noarch.rpm 
Preparing...                ########################################### [100%]
	file /etc/pki/entitlement/key.pem from install of rh-client-config-0.1-1.noarch conflicts with file from package rh-cloud-conf-0.36-1.el5.i386
[root@ip-10-202-197-207 ~]#

Comment 1 wes hayutin 2010-07-21 22:14:31 UTC
[root@ip-10-202-197-207 ~]# rpm -Uvh rh-client-config-0.1-1.noarch.rpm 
Preparing...                ########################################### [100%]
   1:rh-client-config       ########################################### [100%]
error reading information on service rh-cloud-firstboot: No such file or directory
error reading information on service rh-cloud-firstboot: No such file or directory
error: %post(rh-client-config-0.1-1.noarch) scriptlet failed, exit status 1
[root@ip-10-202-197-207 ~]# ls



[root@ip-10-202-197-207 ~]# ls /etc/init.d/
acpid           crond      httpd       krb524        netplugd    readahead_early  single     xinetd
anacron         dc_client  ip6tables   kudzu         network     readahead_later  snmpd      yum-updateonboot
atd             dc_server  ipsec       lm_sensors    nfs         restorecond      snmptrapd  yum-updatesd
auditd          exim       iptables    lvm2-monitor  nfslock     rhnsd            sshd
autofs          firstboot  irqbalance  mcstrans      nscd        rpcgssd          tux
avahi-daemon    functions  iscsi       messagebus    ntpd        rpcidmapd        vncserver
avahi-dnsconfd  gpm        iscsid      multipathd    portmap     rpcsvcgssd       vsftpd
conman          haldaemon  kdump       netconsole    rawdevices  rsyslog          winbind
cpuspeed        halt       killall     netfs         rdisc       setroubleshoot   xfs
[root@ip-10-202-197-207 ~]#

Comment 2 Jay Dobies 2010-07-22 12:31:22 UTC
I'd rather not force overwrite anything. In reality, this won't be seen. Cloud providers won't ever have had rh-cloud-conf

That said, the second comment looks like a bug. It might just be a doc thing that we tell them to uninstall/install new versions of rh-client-config. As it is, I'm not sure the ramifications of the fact that they are always hardcoded to version 0.1.

Comment 3 Shveta 2010-07-26 08:46:38 UTC
Tried installing packages following :

https://engineering.redhat.com/trac/mgmt-integrated/wiki/cloude/NimbusDeploymentGuide#install-iso
=================================
Still getting:

[root@domU-12-31-39-10-3D-51 noarch]# rpm -ivh rh-client-config-0.1-1.noarch.rpm 
Preparing...                ########################################### [100%]
   1:rh-client-config       ########################################### [100%]
error reading information on service rh-cloud-firstboot: No such file or directory
error reading information on service rh-cloud-firstboot: No such file or directory
error: %post(rh-client-config-0.1-1.noarch) scriptlet failed, exit status 1


Yum operations work fine though.

Comment 4 Jay Dobies 2010-07-26 18:26:38 UTC
commit	44492ec1bc92d0be3decf2d15f6eb48c4f0dc378
tree	d6956518a7f6f029d87f7e40b4a0e36010d48fea

617014 - Fixed broken firstboot service

rhui/tools/etc/rhui/rh-client-config.spec
rhui/tools/etc/rhui/rh-cloud-firstboot-service


Will be in rh-rhui-tools 0.26.

Comment 5 Jay Dobies 2010-07-26 19:22:55 UTC
I lied, this won't be fixed in 0.26. Will update when the final fix is in.

Comment 6 wes hayutin 2010-08-16 18:30:33 UTC
[root@ip-10-245-186-159 ~]# rpm -Uvh rh-client-config-0.1-1.noarch.rpm
Preparing...                ########################################### [100%]
   1:rh-client-config       ########################################### [100%]
[root@ip-10-245-186-159 ~]#

Comment 7 wes hayutin 2011-08-01 21:39:16 UTC
moving to release pending

Comment 8 wes hayutin 2012-05-31 12:53:42 UTC
closing out, product released


Note You need to log in before you can comment on or make changes to this bug.