Bug 617087 - virt-v2v RHEL6 | network driver isn't converted to e1000 for some guests(rhel3u9-32 bit and 64bit)
virt-v2v RHEL6 | network driver isn't converted to e1000 for some guests(rhel...
Status: CLOSED DUPLICATE of bug 616753
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-v2v (Show other bugs)
6.0
All Linux
medium Severity high
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
: RHELNAK, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-22 03:18 EDT by cshao
Modified: 2010-07-22 06:41 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-22 06:41:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhel3u9convert.log (4.84 KB, application/octet-stream)
2010-07-22 03:36 EDT, cshao
no flags Details
rhel3u9convert.log (4.84 KB, text/plain)
2010-07-22 03:37 EDT, cshao
no flags Details
network pic (122.92 KB, image/jpeg)
2010-07-22 03:42 EDT, cshao
no flags Details

  None (edit)
Description cshao 2010-07-22 03:18:54 EDT
Description of problem:
Network driver isn't converted to e1000 for some guests(rhel3u9-32 bit and 64bit)


root@dhcp-93-235 Desktop]# LIBGUESTFS_TRACE=1 virt-v2v -ic xen+ssh://10.66.91.118 -o rhev -osd 10.66.90.115:/vol/v2vwulinglu/wulingluv2v/fcp_export rhel3u9-32b-hv-raw-intel 2>&1 > ./rhel3u9convert.log

root@10.66.91.118's password:
root@10.66.91.118's password:

virt-v2v: No capability in config matches os='linux' name='virtio' distro='rhel' major='3' minor='9'
virt-v2v: WARNING: No mapping found for bridge interface xenbr0 in config file. The converted guest may not start until its network interface is updated.


Before conversion, 
#cat /etc/module.conf
alias eth0 8139cp
alias sound-slot-0 es1370

#lsmod |grep 8139cp
8139cp                  16808   1
mii                     4516   0  [8139cp]
crc32                   3712   0  [8139cp]

after conversion, 
#cat /etc/module.conf
alias eth0 8139cp
alias sound-slot-0 es1370
#lsmod | grep e1000

Some detailed information please see attachment.

Version-Release number of selected component (if applicable):
libguestfs-1.2.7-1.16.el6.x86_64
virt-v2v-0.6.1-1.el6.x86_64


How reproducible:
100%

Steps to Reproduce:
1.virt-v2v -ic xen+ssh://10.66.91.118 -o rhev -osd 10.66.90.115:/vol/v2vwulinglu/wulingluv2v/fcp_export rhel3u9-32b-hv-raw-intel.
2.Import the guest in RhevM.
3.Check network driver in VM.
  
Actual results:
Network driver isn't converted to e1000.

Expected results:
Network driver can convert to e1000.

Additional info:
Comment 2 cshao 2010-07-22 03:36:16 EDT
Created attachment 433617 [details]
rhel3u9convert.log
Comment 3 cshao 2010-07-22 03:37:29 EDT
Created attachment 433619 [details]
rhel3u9convert.log
Comment 4 RHEL Product and Program Management 2010-07-22 03:38:00 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 5 Rita Wu 2010-07-22 03:41:09 EDT
It causes network unavailable, so set "TestBlocker" as keyword.
Comment 6 cshao 2010-07-22 03:42:09 EDT
Created attachment 433623 [details]
network pic
Comment 8 Matthew Booth 2010-07-22 06:41:01 EDT

*** This bug has been marked as a duplicate of bug 616753 ***

Note You need to log in before you can comment on or make changes to this bug.