Bug 617303 - need to disable the candlepin ca cert verification for QE testing until we have a DEV ca cert
Summary: need to disable the candlepin ca cert verification for QE testing until we ha...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
(Show other bugs)
Version: 6.1
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Bryan Kearney
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 568421
TreeView+ depends on / blocked
 
Reported: 2010-07-22 18:26 UTC by John Sefler
Modified: 2011-05-19 13:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 13:41:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:0611 normal SHIPPED_LIVE new package: subscription-manager 2011-05-18 17:56:21 UTC

Description John Sefler 2010-07-22 18:26:23 UTC
Description of problem:
Recently a new function went into subscription-manager-cli that (by default) does a CA verification with the candlepin server.  This is breaking our automated tests because they do not have a valid CA cert from the candlepin server.
This request is to temporarily disable that functionality until a have an internal DEV CA or whatever setup we 


Version-Release number of selected component (if applicable):
# rpm -q subscription-manager
subscription-manager-0.71-1.el6.i686

How reproducible:


Steps to Reproduce:
1. subscription-manager-cli register --username=admin --passsword=admin
  
Actual results:
certificate verify failed

Expected results:
{UID} {NAME}


Additional info:

Comment 1 Ajay Kumar Nadathur Sreenivasan 2010-07-26 15:15:16 UTC
disabled.

Comment 2 wes hayutin 2010-08-09 21:48:00 UTC
insecure_mode=t

Comment 4 errata-xmlrpc 2011-05-19 13:41:52 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0611.html


Note You need to log in before you can comment on or make changes to this bug.