Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 617371 - Depsolving Issues :: Rebuild Needed
Depsolving Issues :: Rebuild Needed
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: ruby-augeas (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: David Lutterkort
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-22 17:00 EDT by Jonathan Steffan
Modified: 2013-04-30 19:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-17 02:10:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Steffan 2010-07-22 17:00:54 EDT
Description of problem:
Yum transactions failing.

Version-Release number of selected component (if applicable): 
ruby-augeas-0.3.0-1.el5.x86_64

How reproducible:
Always

Steps to Reproduce:
1. yum update
  
Actual results:
Resolving Dependencies
--> Running transaction check
---> Package augeas.x86_64 0:0.7.2-2.el5 set to be updated
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.1.0)(64bit) for package: ruby-augeas
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.8.0)(64bit) for package: ruby-augeas
---> Package augeas-libs.i386 0:0.7.2-2.el5 set to be updated
---> Package augeas-libs.x86_64 0:0.7.2-2.el5 set to be updated
--> Finished Dependency Resolution
ruby-augeas-0.3.0-1.el5.x86_64 from installed has depsolving problems
  --> Missing Dependency: libaugeas.so.0(AUGEAS_0.8.0)(64bit) is needed by package ruby-augeas-0.3.0-1.el5.x86_64 (installed)
ruby-augeas-0.3.0-1.el5.x86_64 from installed has depsolving problems
  --> Missing Dependency: libaugeas.so.0(AUGEAS_0.1.0)(64bit) is needed by package ruby-augeas-0.3.0-1.el5.x86_64 (installed)
Error: Missing Dependency: libaugeas.so.0(AUGEAS_0.8.0)(64bit) is needed by package ruby-augeas-0.3.0-1.el5.x86_64 (installed)
Error: Missing Dependency: libaugeas.so.0(AUGEAS_0.1.0)(64bit) is needed by package ruby-augeas-0.3.0-1.el5.x86_64 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
[root@bpcouchmasterstage001.co1 ~]# rpm -qi ruby-augeas
Name        : ruby-augeas                  Relocations: (not relocatable)
Version     : 0.3.0                             Vendor: Fedora Project
Release     : 1.el5                         Build Date: Wed 12 Aug 2009 04:46:01 PM MDT
Install Date: Thu 03 Dec 2009 11:09:44 PM MST      Build Host: xenbuilder4.fedora.phx.redhat.com
Group       : Development/Languages         Source RPM: ruby-augeas-0.3.0-1.el5.src.rpm
Size        : 42953                            License: LGPLv2+
Signature   : DSA/SHA1, Fri 14 Aug 2009 03:33:21 PM MDT, Key ID 119cc036217521f6
Packager    : Fedora Project
URL         : http://augeas.net
Summary     : Ruby bindings for Augeas
Description :
Ruby bindings for augeas.


Expected results:
Transaction to pass.
Comment 1 Jonathan Steffan 2010-07-23 14:07:06 EDT
This might be a red herring report but something is wrong:

# rpm -qp --provides augeas-libs-0.7.2-2.el5.x86_64.rpm 
libaugeas.so.0()(64bit)  
libaugeas.so.0(AUGEAS_0.1.0)(64bit)  
libaugeas.so.0(AUGEAS_0.10.0)(64bit)  
libaugeas.so.0(AUGEAS_0.11.0)(64bit)  
libaugeas.so.0(AUGEAS_0.8.0)(64bit)  
libfa.so.1()(64bit)  
libfa.so.1(FA_1.0.0)(64bit)  
libfa.so.1(FA_1.2.0)(64bit)  
augeas-libs = 0.7.2-2.el5
Comment 2 David Lutterkort 2010-08-23 19:13:11 EDT
There's something else afoot - it's entirely intended that augeas-libs provides all those versions, since the API is fully backwards compatible.

If a rebuild of ruby-augeas was really needed everytime augeas revs, something would be seriously broken.

Could you track down what causes this ?
Comment 3 Mark Chappell 2010-09-23 12:22:21 EDT
augaes-libs 0.7.3 has hit the repos, could you give this another try Jonathan?

(ruby-augeas just installed fine here...)
Comment 4 Mark Chappell 2010-10-17 02:10:29 EDT
Closing this bug off.  As far as I can tell the issue has been fixed with the latest version.

Reporter has failded to respond to the contrary.

Jonathan if this is still a problem for you feel free to reopen the bug.

Note You need to log in before you can comment on or make changes to this bug.