Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 617411 - Upgrade (using preupgrade) F11->F13 hangs during/after package upgrade
Upgrade (using preupgrade) F11->F13 hangs during/after package upgrade
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-22 20:25 EDT by Jaroslav Šťáva
Modified: 2010-08-06 10:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-06 10:01:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (10.72 KB, text/plain)
2010-07-22 20:26 EDT, Jaroslav Šťáva
no flags Details
anaconda-yum.conf (345 bytes, text/plain)
2010-07-22 20:27 EDT, Jaroslav Šťáva
no flags Details
program.log (17.96 KB, text/plain)
2010-07-22 20:27 EDT, Jaroslav Šťáva
no flags Details
storage.log (63.14 KB, text/plain)
2010-07-22 20:28 EDT, Jaroslav Šťáva
no flags Details
syslog (65.33 KB, text/plain)
2010-07-22 20:28 EDT, Jaroslav Šťáva
no flags Details
upgrade.log (68.05 KB, text/plain)
2010-07-22 20:28 EDT, Jaroslav Šťáva
no flags Details
upgrade.log.syslog (6.42 KB, text/plain)
2010-07-22 20:29 EDT, Jaroslav Šťáva
no flags Details
X.log (64.61 KB, text/plain)
2010-07-22 20:30 EDT, Jaroslav Šťáva
no flags Details
yum.log (41.46 KB, text/plain)
2010-07-22 20:30 EDT, Jaroslav Šťáva
no flags Details
anaconda-tb-NAXZZb (14.27 KB, text/plain)
2010-07-22 21:32 EDT, Jaroslav Šťáva
no flags Details

  None (edit)
Description Jaroslav Šťáva 2010-07-22 20:25:24 EDT
Description of problem:
Preupgrade from F11 to F13 runs fine until the screen freezes at package installation (the last package in log). The system is fine, but nothing else ever happens (after switching to a VT and back to the graph. installer screen is just white). 
There are 2 sleeping anaconda processes. Sending them USR2 produces no traceback.

IIRC the displayed number of packages to upgrade, then the the upgrading may have been over - log says 1584 packages were upgraded. (The progress bar was far from end though)
The upgrading/installing continued for much longer then the timestamps in anaconda.log, (like 22:30+) see upgrade.log.syslog for timestamps.


Additional info:
One usb stick with live F13 image present (accidently).
Disk layout is fedora dafault.
Comment 1 Jaroslav Šťáva 2010-07-22 20:26:47 EDT
Created attachment 433834 [details]
anaconda.log
Comment 2 Jaroslav Šťáva 2010-07-22 20:27:14 EDT
Created attachment 433835 [details]
anaconda-yum.conf
Comment 3 Jaroslav Šťáva 2010-07-22 20:27:37 EDT
Created attachment 433836 [details]
program.log
Comment 4 Jaroslav Šťáva 2010-07-22 20:28:07 EDT
Created attachment 433837 [details]
storage.log
Comment 5 Jaroslav Šťáva 2010-07-22 20:28:36 EDT
Created attachment 433838 [details]
syslog
Comment 6 Jaroslav Šťáva 2010-07-22 20:28:57 EDT
Created attachment 433839 [details]
upgrade.log
Comment 7 Jaroslav Šťáva 2010-07-22 20:29:37 EDT
Created attachment 433840 [details]
upgrade.log.syslog
Comment 8 Jaroslav Šťáva 2010-07-22 20:30:11 EDT
Created attachment 433841 [details]
X.log
Comment 9 Jaroslav Šťáva 2010-07-22 20:30:45 EDT
Created attachment 433842 [details]
yum.log
Comment 10 Jaroslav Šťáva 2010-07-22 21:32:59 EDT
Created attachment 433852 [details]
anaconda-tb-NAXZZb

Found some traceback in the system /tmp after all (after reboot)
Comment 11 Jaroslav Šťáva 2010-07-27 11:58:23 EDT
The system didn't boot at first (missing initramfs).
Then no X.
Looking at the installed packages showed that the F11 pkgs were still installed:
package-cleanup --clean-dupes cleaned 1495 pkgs
yum upgrade upgraded 129 pkgs

This got me a working system, but somehow some important packages got lost in the process, like:
- gdm
- oo-{writer,calc,...} although the oo-{write,calc,...}-core were there
- others.
I did groupinstall "GNOME Desktop Environment" which did get me working gnome.
After that i did only some usual upgrade cleanup, purged remaining old pkgs prom system "package-cleanup --leaves|grep fc11".
The system seems fine now. 

Only remaining task seems to be cleaning up the mess left behind by preupgrade itself (/boot/ + grub, /var/cache/yum/preupgrade*, elsewhere?).
Comment 12 Chris Lumens 2010-08-06 10:01:32 EDT
Sorry, but I'm really unable to tell what might have gone on here.  Thanks for all the logs, but they aren't really enlightening.  The traceback you see is incomplete which is odd and makes debugging even more difficult.  If you have been able to fully recover from the error, I'm glad to hear that.  I won't ask you to try again and see if you're able to reproduce.

Note You need to log in before you can comment on or make changes to this bug.