Bug 61745 - up2date refuses: ... providing librpm.so.0 could not be found
up2date refuses: ... providing librpm.so.0 could not be found
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-23 20:01 EST by Robert M. Riches Jr.
Modified: 2015-01-07 18:55 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-02 19:42:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of "rpm -qa | sort" (before attempting to run up2date) (17.15 KB, text/plain)
2002-03-23 20:03 EST, Robert M. Riches Jr.
no flags Details
output of "rpm -Va" (7.49 KB, text/plain)
2002-03-23 20:04 EST, Robert M. Riches Jr.
no flags Details

  None (edit)
Description Robert M. Riches Jr. 2002-03-23 20:01:56 EST
Description of Problem:
I hope I'm filing this to the right product and such)
up2date refuses to install the latest set of packages.  I don't know whether the
problem
is an error in the RPMs, a bug in up2date, or something else.  My RH7.1 Alpha
system
was fully updated as of March 16.  On March 23, I tried to install all the new
packages,
but I got the following:

    There was a package dependency problem.  The message was:
    A package providing librpmio.so.0 could not be found.
    A package providing librpm.so could not be found.

Version-Release number of selected component (if applicable):
presently using rpm-4.0.2-8

How Reproducible:
tried it three or four times, same results every time

Steps to Reproduce:
1. start up2date
2. choose both RH7.1 Linux and Powertools channels (the default)
3. select all packages, click on "next", wait for message

Actual Results:
got the above error message

Expected Results:
up2date should have installed the packages

Additional Information:
	I will try to add the results of "rpm -qa | sort" and "rpm -Va" as attachments.
Comment 1 Robert M. Riches Jr. 2002-03-23 20:03:34 EST
Created attachment 49884 [details]
output of "rpm -qa | sort" (before attempting to run up2date)
Comment 2 Robert M. Riches Jr. 2002-03-23 20:04:30 EST
Created attachment 49885 [details]
output of "rpm -Va"
Comment 3 Peter Verthez 2002-03-24 13:38:04 EST
Same thing happens for me.

The updates for imlib and php apply fine when tried separately, it's only the 
rpm update that gives problems.  Except for this rpm update, my system is up
to date (this is a RH7.1 system on i386).
Comment 4 David M. Cook 2002-03-27 15:32:17 EST
Some of these problems are caused by perl-Perl-RPM, which was renamed to
rpm-perl.  Try removing it:

  rpm -e perl-Perl-RPM

I haven't been able to track down the dependency problems when this doesn't work
for people.
Comment 5 Peter Verthez 2002-03-28 12:39:59 EST
This is indeed a working workaround: the update goes fine without the
perl-Perl-RPM package installed.  Since I don't have a need (anymore)
for this package, it solves the problem for me, but of course this doesn't
solve the basic problem of the disappeared 'provide' in rpm...
Comment 6 Robert M. Riches Jr. 2002-03-30 16:25:15 EST
It appears removing the perl-Perl-RPM package allowed up2date to do its job
with the new packages.  However, I got the following warnings:

warning: /var/lib/rpm/Basenames created as /var/lib/rpm/Basenames.rpmnew
warning: /var/lib/rpm/Conflictname created as /var/lib/rpm/Conflictname.rpmnew
warning: /var/lib/rpm/Group created as /var/lib/rpm/Group.rpmnew
warning: /var/lib/rpm/Name created as /var/lib/rpm/Name.rpmnew
warning: /var/lib/rpm/Packages created as /var/lib/rpm/Packages.rpmnew
warning: /var/lib/rpm/Providename created as /var/lib/rpm/Providename.rpmnew
warning: /var/lib/rpm/Requirename created as /var/lib/rpm/Requirename.rpmnew
warning: /var/lib/rpm/Triggername created as /var/lib/rpm/Triggername.rpmnew

A post-check of /var/lib/rpm shows the .rpmnew suffixes have apparently been
resolved.

I tried to reinstall perl-Perl-RPM-0.291-2 from the original CD, but rpm refused
to install it.

If possible, could you please answer the following questions:

    Are the warnings benign?

    Is there any reason to be concerned about not having perl-Perl-RPM?

Thanks.
Comment 7 Bob Weaver 2002-04-02 19:41:59 EST
Trying to use up2date to update gnorpm gets the message:
  There was a package dependency problem.  The message was:
  A package providing librpmdb-4.0.3.so could not be found.
  A package providing librpm-4.0.3.so could not be found.
  A package providing librpmio-4.0.3.so could not be found.
  A package providing librpmbuild-4.0.3.so could not be found.
  ...
So where do we find these guys?  They do NOT appear in the
Available Packages Updates list.
Comment 8 David M. Cook 2002-04-17 17:34:27 EDT
The current release of up2date should solve any remaining problems with rpm and
dependent packages.  The perl-Perl-RPM problem is a separate packaging bug.

Note You need to log in before you can comment on or make changes to this bug.