Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 617457 - 8139cp network unreachable after hibernate
8139cp network unreachable after hibernate
Status: CLOSED DUPLICATE of bug 665515
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
medium Severity high
: rc
: ---
Assigned To: John Feeney
Caspar Zhang
: RHELNAK
Depends On:
Blocks: 767187
  Show dependency treegraph
 
Reported: 2010-07-23 01:56 EDT by Qian Cai
Modified: 2013-07-03 03:24 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-10 02:32:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg after hibernate (21.74 KB, text/plain)
2010-07-23 01:56 EDT, Qian Cai
no flags Details
guest xml (2.08 KB, application/xml)
2010-07-23 02:06 EDT, Qian Cai
no flags Details

  None (edit)
Description Qian Cai 2010-07-23 01:56:56 EDT
Created attachment 433874 [details]
dmesg after hibernate

Description of problem:
After resumed from a hibernated guest, it could be not pingable.

$ ping 10.66.65.12
PING 10.66.65.12 (10.66.65.12) 56(84) bytes of data.
From 10.66.65.141 icmp_seq=2 Destination Host Unreachable
...

although ifconfig out remained the same,
# ifconfig 
eth0      Link encap:Ethernet  HWaddr 52:54:00:6E:8A:61  
          inet addr:10.66.65.12  Bcast:10.66.65.255  Mask:255.255.254.0
          inet6 addr: fe80::5054:ff:fe6e:8a61/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:193 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:21148 (20.6 KiB)  TX bytes:820 (820.0 b)
          Interrupt:11 Base address:0xc000

Version-Release number of selected component (if applicable):
Host: X200
kernel-2.6.32-52.el6.x86_64
RHEL6.0-20100722.0

Guest:
kernel-2.6.32-52.el6.x86_64
RHEL6.0-20100722.0

How reproducible:
always

Steps to Reproduce:
1. pm-hibernate inside the guest
2. virsh start <guest>
  
Actual results:
Guest network is unreachable.

Expected results:
Guest network resumed.
Comment 1 Qian Cai 2010-07-23 02:06:07 EDT
Created attachment 433878 [details]
guest xml
Comment 2 Qian Cai 2010-07-24 04:05:06 EDT
NAT has the same problem. 2.6.35-rc5 is working fine.
Comment 3 Qian Cai 2010-07-24 04:06:03 EDT
(In reply to comment #2)
> 2.6.35-rc5 is working fine.    
Correction - 2.6.35-rc6.
Comment 4 Qian Cai 2010-07-26 04:34:42 EDT
This is happened only using 8139cp in the guest. The workaround is to do "network restart". RHEL5.5 guest has the same problem.
Comment 5 Dor Laor 2010-07-26 05:11:39 EDT
Clearing the blocker since it is not a requirement for kvm in 6.0
Comment 6 Qian Cai 2010-07-26 05:21:47 EDT
During the resuming of the hibernated guest, qemu-kvm was crashed once,
Jul 26 17:13:38 localhost kernel: qemu-kvm[3227]: segfault at c5fea0 ip 00000000004e09be sp 00007ffd0a0dfad8 error 4 in qemu-kvm[400000+242000]
Jul 26 17:16:13 localhost kernel: INFO: task qemu-kvm:3222 blocked for more than 120 seconds.
Jul 26 17:16:13 localhost kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
Jul 26 17:16:13 localhost kernel: qemu-kvm      D ffff880099a34080     0  3222      1 0x00000000
Jul 26 17:16:13 localhost kernel: ffff8801033bfc98 0000000000000082 ffffffff81b058b8 ffff880099a34080
Jul 26 17:16:13 localhost kernel: ffff8801033bfc68 ffffffff810a34e0 ffff8801033bfca0 ffff880099a34080
Jul 26 17:16:13 localhost kernel: ffff880099a34638 ffff8801033bffd8 0000000000010518 ffff880099a34638
Jul 26 17:16:13 localhost kernel: Call Trace:
Jul 26 17:16:13 localhost kernel: [<ffffffff810a34e0>] ? exit_robust_list+0x90/0x160
Jul 26 17:16:13 localhost kernel: [<ffffffff8106fa35>] exit_mm+0x95/0x150
Jul 26 17:16:13 localhost kernel: [<ffffffff8106fe47>] do_exit+0x157/0x840
Jul 26 17:16:13 localhost kernel: [<ffffffff8117fed0>] ? pollwake+0x0/0x60
Jul 26 17:16:13 localhost kernel: [<ffffffff81070588>] do_group_exit+0x58/0xd0
Jul 26 17:16:13 localhost kernel: [<ffffffff810853c6>] get_signal_to_deliver+0x1f6/0x460
Jul 26 17:16:13 localhost kernel: [<ffffffff81012365>] do_signal+0x75/0x800
Jul 26 17:16:13 localhost kernel: [<ffffffff8117f368>] ? poll_select_copy_remaining+0xf8/0x150
Jul 26 17:16:13 localhost kernel: [<ffffffff810a5cfb>] ? sys_futex+0x7b/0x170
Jul 26 17:16:13 localhost kernel: [<ffffffff81012b80>] do_notify_resume+0x90/0xc0
Jul 26 17:16:13 localhost kernel: [<ffffffff8101343e>] int_signal+0x12/0x17
Jul 26 17:16:13 localhost kernel: INFO: task qemu-kvm:3229 blocked for more than 120 seconds.
Jul 26 17:16:13 localhost kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
Jul 26 17:16:13 localhost kernel: qemu-kvm      D ffff880127db1520     0  3229      1 0x00000000
Jul 26 17:16:13 localhost kernel: ffff8801033b5c98 0000000000000082 ffffffff81b058b8 ffff880127db1520
Jul 26 17:16:13 localhost kernel: ffff8801033b5c68 ffffffff810a34e0 ffff8801033b5c38 ffff8801033b5c98
Jul 26 17:16:13 localhost kernel: ffff880127db1ad8 ffff8801033b5fd8 0000000000010518 ffff880127db1ad8
Jul 26 17:16:13 localhost kernel: Call Trace:
Jul 26 17:16:13 localhost kernel: [<ffffffff810a34e0>] ? exit_robust_list+0x90/0x160
Jul 26 17:16:13 localhost kernel: [<ffffffff8106fa35>] exit_mm+0x95/0x150
Jul 26 17:16:13 localhost kernel: [<ffffffff8106fe47>] do_exit+0x157/0x840
Jul 26 17:16:13 localhost kernel: [<ffffffff81070588>] do_group_exit+0x58/0xd0
Jul 26 17:16:13 localhost kernel: [<ffffffff810853c6>] get_signal_to_deliver+0x1f6/0x460
Jul 26 17:16:13 localhost kernel: [<ffffffff81012365>] do_signal+0x75/0x800
Jul 26 17:16:13 localhost kernel: [<ffffffff8117dbfa>] ? do_vfs_ioctl+0x3aa/0x580
Jul 26 17:16:13 localhost kernel: [<ffffffff810a5cfb>] ? sys_futex+0x7b/0x170
Jul 26 17:16:13 localhost kernel: [<ffffffff81012b80>] do_notify_resume+0x90/0xc0
Jul 26 17:16:13 localhost kernel: [<ffffffff8101343e>] int_signal+0x12/0x17
Comment 8 RHEL Product and Program Management 2010-07-26 05:37:35 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 11 Matthew Garrett 2010-10-27 10:52:34 EDT
No relevant changes in 8139cp, as far as I can tell.
Comment 12 RHEL Product and Program Management 2011-01-06 22:53:22 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 13 Suzanne Yeghiayan 2011-01-07 11:08:51 EST
This request was erroneously denied for the current release of Red Hat
Enterprise Linux.  The error has been fixed and this request has been
re-proposed for the current release.
Comment 14 RHEL Product and Program Management 2011-02-01 00:31:03 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 17 Caspar Zhang 2011-04-19 05:26:33 EDT
8139cp and virtio failed with 2.6.32-131.0.1.el6.x86_64 (both host and guest) e1000, ne2k_pci, pcnet no problem.

no qemu-kvm crash found during testing.
Comment 18 RHEL Product and Program Management 2011-10-07 11:09:07 EDT
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 20 jason wang 2012-02-10 02:32:14 EST

*** This bug has been marked as a duplicate of bug 665515 ***

Note You need to log in before you can comment on or make changes to this bug.