Bug 61752 - Old Card Service (3.1.22) used in Kernel 2.4.9-18
Old Card Service (3.1.22) used in Kernel 2.4.9-18
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-24 00:57 EST by Alan Tam
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 16:17:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Tam 2002-03-24 00:57:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; T312461)

Description of problem:
Red Hat is packaging a kernel rpm with old Card Service 3.1.22
This raises problem to my laptop which has 3 PCMCIA slots, where only 2 are 
found and watched by the above kernel card service.

The old service is found in both kernel-2.4.9-31.i386.rpm (RedHat 7.2 update) 
and kernel-2.4.18-0.4.i386.rpm (compiled from rawhide)

I know Card Service >=3.1.24 can solve the problem but RedHat is just sticking 
to the old 3.1.22 even for updated kernels (why?)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.reboot
2.grep atching /var/log/messages
3.
	

Actual Results:  "Watching 2 sockets"

Expected Results:  "Watching 3 sockets"

Additional info:

In a problematic situation:
----------------------------
Mar 24 21:10:15 noriko kernel: Linux Kernel Card Services 3.1.22
Mar 24 21:10:15 noriko kernel:   options:  [pci] [cardbus] [pm]
Mar 24 21:10:15 noriko kernel: PCI: Enabling device 00:02.0 (0000 -> 0002)
Mar 24 21:10:15 noriko kernel: PCI: Found IRQ 10 for device 00:02.0
Mar 24 21:10:15 noriko kernel: PCI: Enabling device 00:02.1 (0000 -> 0002)
Mar 24 21:10:15 noriko kernel: PCI: Found IRQ 10 for device 00:02.1
Mar 24 21:10:15 noriko kernel: Yenta IRQ list 0a98, PCI irq10
Mar 24 21:10:15 noriko kernel: Socket status: 30000456
Mar 24 21:10:15 noriko kernel: Yenta IRQ list 0a98, PCI irq10
Mar 24 21:10:15 noriko kernel: Socket status: 30000860
Mar 24 21:10:16 noriko kernel: cs: cb_alloc(bus 2): vendor 0x115d, device 0x0003
Mar 24 21:10:16 noriko kernel: PCI: Enabling device 02:00.0 (0000 -> 0003)
Mar 24 21:10:16 noriko kernel: PCI: Enabling device 02:00.1 (0000 -> 0003)
Mar 24 21:10:16 noriko kernel: ttyS04 at port 0x4880 (irq = 10) is a 16550A
Mar 24 21:10:16 noriko pcmcia:  cardmgr.
Mar 24 21:10:16 noriko rc: Starting pcmcia:  succeeded
Mar 24 21:10:16 noriko cardmgr[835]: starting, version is 3.1.31
Mar 24 21:10:17 noriko cardmgr[835]: config error, file './config.opts' line 8: 
no function bindings
Mar 24 21:10:17 noriko cardmgr[835]: watching 2 sockets

In a correct situation:
----------------------------
Mar 23 18:24:39 noriko kernel: Linux PCMCIA Card Services 3.1.24 
Mar 23 18:24:39 noriko kernel:   kernel build: 2.2.19-6.2.1 #1 Mon Apr 9 
21:59:11 EDT 2001 
Mar 23 18:24:40 noriko kernel:   options:  [pci] [cardbus] [apm] 
Mar 23 18:24:40 noriko kernel: PCI routing table version 1.0 at 0xf5840 
Mar 23 18:24:40 noriko kernel:   00:02.0 -> irq 10 
Mar 23 18:24:40 noriko kernel:   00:02.1 -> irq 10 
Mar 23 18:24:40 noriko kernel: Intel PCIC probe:  
Mar 23 18:24:40 noriko kernel:   Ricoh RL5C476 rev 02 PCI-to-CardBus at slot 
00:02, mem 0x68000000 
Mar 23 18:24:40 noriko kernel:     host opts [0]: [isa irq] [io 3/6/1] [mem 
3/6/1] [pci irq 10] [lat 32/32] [bus 1/1] 
Mar 23 18:24:40 noriko kernel:     host opts [1]: [isa irq] [io 3/6/1] [mem 
3/6/1] [pci irq 10] [lat 32/32] [bus 2/2] 
Mar 23 18:24:40 noriko kernel:     ISA irqs (default) = 9,11 PCI status changes 
Mar 23 18:24:40 noriko kernel:   Intel i82365sl B step rev 00 ISA-to-PCMCIA at 
port 0x3e0 ofs 0x00 
Mar 23 18:24:40 noriko kernel:     host opts [0]: none 
Mar 23 18:24:40 noriko kernel:     ISA irqs (default) = 9,11 polling interval = 
1000 ms 
Mar 23 18:24:40 noriko kernel: cs: cb_alloc(bus 2): vendor 0x115d, device 
0x0003 
Mar 23 18:24:38 noriko rc: Starting pcmcia succeeded
Mar 23 18:24:38 noriko cardmgr[375]: starting, version is 3.1.24
Mar 23 18:24:41 noriko cardmgr[375]: watching 3 sockets

***Note 1***
Line 8 of the config.opts in the above two situation is the same.

***Note 2***
In the problematic situation, I even upgraded the card manager to the newest 
version 3.1.31 - still no help.
Comment 1 Arjan van de Ven 2002-03-24 05:21:21 EST
The version 3.1.22 is meaningless since it just is some random number to keep
cardmgr happy. The kernel side in 2.4 is long since moved on. Now I can believe
that it doesn't (yet) support your hardhare and I'll have a look if I can find
something simple....

Note You need to log in before you can comment on or make changes to this bug.