Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 617569 - Post string freeze anaconda string change
Post string freeze anaconda string change
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Hans de Goede
Release Test Team
: RHELNAK, Translation
Depends On:
Blocks: 527925
  Show dependency treegraph
 
Reported: 2010-07-23 09:00 EDT by Hans de Goede
Modified: 2010-11-11 10:25 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 10:25:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated anaconda.pot (129.03 KB, text/plain)
2010-07-23 09:00 EDT, Hans de Goede
no flags Details

  None (edit)
Description Hans de Goede 2010-07-23 09:00:55 EDT
Created attachment 433949 [details]
Updated anaconda.pot

Hi,

As discussed by email because of bug 605544 we've had to make a small string change to anaconda post string freeze, to be precise the storage type selection screen saw the following change:

Current:

-----------------------------------------------------------------------------
|                                                                           |
|          What type of devices will your installation involve?             |
|                                                                           |
|          * Basic Storage Devices                                          |
|                                                                           |
|            Installs or upgrades to typical types of storage devices.      |
|            If you're not sure which option is right for you, this is      |
|            probably it.                                                   |
|                                                                           |
|          * Specialized Storage Devices                                    |
|                                                                           |
|            Installs or upgrades to devices such as Storage Area Networks  |
|            (SANs) or mainframe attached disks (DASD), usually in an       |
|            enterprise environment                                         |
|                                                                           |
-----------------------------------------------------------------------------

New:

-----------------------------------------------------------------------------
|                                                                           |
|          What type of devices will your installation involve?             |
|                                                                           |
|          * Basic Storage Devices                                          |
|                                                                           |
|            Installs or upgrades to typical types of storage devices.      |
|            If you're not sure which option is right for you, this is      |
|            probably it.                                                   |
|                                                                           |
|          * Specialized Storage Devices                                    |
|                                                                           |
|            Installs or upgrades to devices such as Storage Area Networks  |
|            (SANs). This option will allow you to add FCoE / iSCSI / zFCP  |
|            disks and to filter out LUNs the installer should ignore.      |
|                                                                           |
-----------------------------------------------------------------------------

Note that only the text below "Specialized Storage Devices" is changed.

I've attached an updated anaconda.pot file which includes this change (which will be included in the next anaconda build).
Comment 2 RHEL Product and Program Management 2010-07-23 09:17:40 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 Ankit Patel 2010-07-26 10:36:31 EDT
Hi Hans,

Please update POT file and merge all PO files with the updated POT file on upstream transifex branch rhel-6.

https://translate.fedoraproject.org/projects/p/anaconda/c/rhel6-branch/

Please let me know, as soon as you are done. So that I can ask translation team to complete and submit translations there.

Thanks!
Ankit
Comment 4 Hans de Goede 2010-07-27 09:19:17 EDT
(In reply to comment #3)
> Hi Hans,
> 
> Please update POT file and merge all PO files with the updated POT file on
> upstream transifex branch rhel-6.
> 
> https://translate.fedoraproject.org/projects/p/anaconda/c/rhel6-branch/
> 
> Please let me know, as soon as you are done. So that I can ask translation team
> to complete and submit translations there.
> 
> Thanks!
> Ankit    


Hi,

The string change has landed in the git rhel-6 branch of anaconda, and has been automatically picked up by transifex (I just checked). Is there anything more that needs doing, or can this bug be put in modified ?

Regards,

Hans
Comment 5 Ankit Patel 2010-07-27 09:30:34 EDT
(In reply to comment #4)
> Hi,
> 
> The string change has landed in the git rhel-6 branch of anaconda, and has been
> automatically picked up by transifex (I just checked). Is there anything more
> that needs doing, or can this bug be put in modified ?
> 
> Regards,
> 
> Hans    

Hi,

Could you please also make sure all messages that appears in anaconda installation screen are marked for translation extraction?

Because when I have tried "intltool-update -P" in po directory it has thrown many warning messages, perhaps some of the messages are not properly marked for translation extraction (guess not i18nized or gettextized properly).

[root@ankit-test po]# intltool-update -P
xgettext: warning: file `./../anaconda' extension `' is unknown; will try C
./../anaconda:41: warning: unterminated character constant
./../anaconda:301: warning: unterminated character constant
./../anaconda:328: warning: unterminated character constant
./../anaconda:442: warning: unterminated string literal
./../anaconda:445: warning: unterminated string literal
./../anaconda:499: warning: unterminated character constant
./../anaconda:500: warning: unterminated character constant
./../anaconda:543: warning: unterminated character constant
./../anaconda:651: warning: unterminated character constant
./../anaconda:652: warning: unterminated character constant
./../anaconda:658: warning: unterminated character constant
./../anaconda:676: warning: unterminated character constant
./../anaconda:707: warning: unterminated character constant
./../anaconda:860: warning: unterminated character constant
./../anaconda:929: warning: unterminated character constant
./../anaconda:937: warning: unterminated character constant
./../anaconda:954: warning: unterminated character constant
./../anaconda:961: warning: unterminated character constant
./../anaconda:1085: warning: unterminated character constant
./../installinterfacebase.py:47: warning: 'msgid' format string with unnamed arguments cannot be properly localized:
                                          The translator cannot reorder the arguments.
                                          Please consider using a format string with named arguments,
                                          and a mapping instead of a tuple for the arguments.
./../installinterfacebase.py:51: warning: 'msgid_plural' format string with unnamed arguments cannot be properly localized:
                                          The translator cannot reorder the arguments.
                                          Please consider using a format string with named arguments,
                                          and a mapping instead of a tuple for the arguments.
./../platform.py:246: warning: 'msgid' format string with unnamed arguments cannot be properly localized:
                               The translator cannot reorder the arguments.
                               Please consider using a format string with named arguments,
                               and a mapping instead of a tuple for the arguments.
./../iw/filter_gui.py:151: warning: 'msgid' format string with unnamed arguments cannot be properly localized:
                                    The translator cannot reorder the arguments.
                                    Please consider using a format string with named arguments,
                                    and a mapping instead of a tuple for the arguments.
./../iw/partition_gui.py:478: warning: 'msgid' format string with unnamed arguments cannot be properly localized:
                                       The translator cannot reorder the arguments.
                                       Please consider using a format string with named arguments,
                                       and a mapping instead of a tuple for the arguments.
./../iw/partition_gui.py:544: warning: 'msgid' format string with unnamed arguments cannot be properly localized:
                                       The translator cannot reorder the arguments.
                                       Please consider using a format string with named arguments,
                                       and a mapping instead of a tuple for the arguments.
./../storage/devices.py:2472: warning: 'msgid' format string with unnamed arguments cannot be properly localized:
                                       The translator cannot reorder the arguments.
                                       Please consider using a format string with named arguments,
                                       and a mapping instead of a tuple for the arguments.
./../storage/formats/fs.py:355: warning: 'msgid' format string with unnamed arguments cannot be properly localized:
                                         The translator cannot reorder the arguments.
                                         Please consider using a format string with named arguments,
                                         and a mapping instead of a tuple for the arguments.
./../storage/formats/lvmpv.py:104: warning: 'msgid' format string with unnamed arguments cannot be properly localized:
                                            The translator cannot reorder the arguments.
                                            Please consider using a format string with named arguments,
                                            and a mapping instead of a tuple for the arguments.
./../storage/formats/swap.py:162: warning: 'msgid' format string with unnamed arguments cannot be properly localized:
                                           The translator cannot reorder the arguments.
                                           Please consider using a format string with named arguments,
                                           and a mapping instead of a tuple for the arguments.
xgettext: error while opening "./../liveinst/liveinst.desktop.in.h" for reading: No such file or directory
ERROR: xgettext failed to generate PO template file. Please consult
       error message above if there is any.
[root@ankit-test po]# 

Please check them as well.

Thanks!
Ankit
Comment 6 Hans de Goede 2010-07-27 09:47:33 EDT
Hi,

Some of our strings are deliberately not marked for translation as they are only written to logfiles, which are only needed for debugging when something goes wrong.

As for "Please consider using a formatstring with named arguments," warnings, those could very well be valid, but fixing those falls outside the scope of this bug, can you please file a new bug against anaconda for those ?

Thanks,

Hans
Comment 7 Ankit Patel 2010-07-28 05:11:15 EDT
(In reply to comment #6)
> As for "Please consider using a formatstring with named arguments," warnings,
> those could very well be valid, but fixing those falls outside the scope of
> this bug, can you please file a new bug against anaconda for those ?

Filed bug #618979
Comment 8 Ankit Patel 2010-07-28 05:29:21 EDT
(In reply to comment #4)
> Hi,
> 
> The string change has landed in the git rhel-6 branch of anaconda, and has been
> automatically picked up by transifex (I just checked). Is there anything more
> that needs doing, or can this bug be put in modified ?

Could you please also ensure you merge all PO files with latest POT file and commit them back to git repo?

Thanks!
Ankit
Comment 9 Ankit Patel 2010-08-03 09:18:36 EDT
Since the proposed changes have already landed into the REPO: https://translate.fedoraproject.org/projects/p/anaconda/c/rhel6-branch/view/po/anaconda.pot this bug can be considered as FIXED and VERIFIED.
Comment 10 releng-rhel@redhat.com 2010-11-11 10:25:39 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.