Bug 617633 - The latest Test suite is not working in RHEL4.8
Summary: The latest Test suite is not working in RHEL4.8
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness)   
(Show other bugs)
Version: 5.3
Hardware: s390x
OS: All
high
urgent
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact: chen yuwen
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-23 15:31 UTC by IBM Bug Proxy
Modified: 2018-10-27 10:37 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-18 21:32:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 66186 None None None Never

Description IBM Bug Proxy 2010-07-23 15:31:14 UTC
=Comment: #0=================================================
KAMALESH BABULAL <> - 

Hi,
I have used the latest available test suite ( v7-1.1-24.el5.noarch.rpm ) for
Hardware certification on RHEL 4.8, the installation went fine but once I started using the v7 
commands its giving some script errors.

Not able to run any v7 commands.
LOG:
# uname -a
Linux xxxxxxx 2.6.9-89.EL #1 SMP Mon Apr 20 10:33:26 EDT 2009 s390x s390x s390x
GNU/Linux
[root@xxxxx Hwcert]# v7 plan
Traceback (most recent call last):
  File "/usr/bin/v7", line 24, in ?
    from v7.hardwaretest import HardwareTestHarness
  File "/usr/share/v7/lib/v7/hardwaretest.py", line 36, in ?
    from v7.report import Report 
  File "/usr/share/v7/lib/v7/report.py", line 24, in ?
    from v7.command import Command, V7CommandException
  File "/usr/share/v7/lib/v7/command.py", line 22, in ?
    import os,re, commands, subprocess, string, sys
ImportError: No module named subprocess

[root@xxxxxx Hwcert]# v7 server start
Traceback (most recent call last):
  File "/usr/bin/v7", line 24, in ?
    from v7.hardwaretest import HardwareTestHarness
  File "/usr/share/v7/lib/v7/hardwaretest.py", line 36, in ?
    from v7.report import Report 
  File "/usr/share/v7/lib/v7/report.py", line 24, in ?
    from v7.command import Command, V7CommandException
  File "/usr/share/v7/lib/v7/command.py", line 22, in ?
    import os,re, commands, subprocess, string, sys
ImportError: No module named subprocess

[root@xxxxxx Hwcert]# v7 --help
Traceback (most recent call last):
  File "/usr/bin/v7", line 24, in ?
    from v7.hardwaretest import HardwareTestHarness
  File "/usr/share/v7/lib/v7/hardwaretest.py", line 36, in ?
    from v7.report import Report 
  File "/usr/share/v7/lib/v7/report.py", line 24, in ?
    from v7.command import Command, V7CommandException
  File "/usr/share/v7/lib/v7/command.py", line 22, in ?
    import os,re, commands, subprocess, string, sys
ImportError: No module named subprocess

The same test kit worked fine on RHEL5.5. RHEL 4.8 ships python-2.3.4-14.7.el4 and  
subprocess module is supported from python 2.4

Comment 1 Greg Nichols 2010-07-23 15:49:16 UTC
Please try the RHEL4 rpm for v7 (v7-1.1-24.el4.noarch.rpm).

- Thanks!

Comment 2 IBM Bug Proxy 2010-07-23 17:30:42 UTC
------- Comment From mgrf@de.ibm.com 2010-07-23 13:26 EDT-------
(In reply to comment #4)
> --- Comment From gnichols@redhat.com 2010-07-23 11:49:16 EDT---
> Please try the RHEL4 rpm for v7 (v7-1.1-24.el4.noarch.rpm).
> - Thanks!

Yes have been used as per initial bug description
- used the latest available test suite ( v7-1.1-24.el5.noarch.rpm )

Comment 3 IBM Bug Proxy 2010-07-23 17:40:53 UTC
------- Comment From mgrf@de.ibm.com 2010-07-23 13:32 EDT-------
*** Bug 66161 has been marked as a duplicate of this bug. ***

Comment 4 Greg Nichols 2010-07-23 21:28:55 UTC
You need the RHEL4 version or v7 - note the "el4" in the rpm name:

v7-1.1-24.el4.noarch.rpm is for RHEL4 <- use this one.

v7-1.1-24.el5.noarch.rpm is for RHEL5 - will not work on RHEL4.8

Thanks!

Comment 5 IBM Bug Proxy 2010-07-27 07:00:54 UTC
------- Comment From rajduddu@linux.vnet.ibm.com 2010-07-27 02:57 EDT-------
Hi I have used "v7-1.1-24.el4.noarch.rpm" for RHEL4.8, but still the same problem exists.

[root@r3515044 ~]# rpm -qa | grep v7
v7-1.1-24.el4
[root@r3515044 ~]# v7 plan
File "/usr/bin/v7", line 23, in <module>
from v7.test import Test
File "/usr/share/v7/lib/v7/test.py", line 21, in <module>
from v7.hal import Hal
File "/usr/share/v7/lib/v7/hal.py", line 10, in <module>
import dbus
ImportError: No module named dbus
[root@r3515044 ~]# v7 --help
File "/usr/bin/v7", line 23, in <module>
from v7.test import Test
File "/usr/share/v7/lib/v7/test.py", line 21, in <module>
from v7.hal import Hal
File "/usr/share/v7/lib/v7/hal.py", line 10, in <module>
import dbus
ImportError: No module named dbus

Comment 6 IBM Bug Proxy 2010-08-23 07:31:22 UTC
------- Comment From  2010-08-23 03:27 EDT-------
Hello RedHat,

Any updates on the bug ?
Thanks.

Comment 7 IBM Bug Proxy 2010-08-26 11:00:48 UTC
------- Comment From mgrf@de.ibm.com 2010-08-26 06:51 EDT-------
Hello Red Hat,

the previous version of the hts  works fine !

The only one failing is the one delivered in June, "v7-1.1-24.el4.noarch.rpm"


Note You need to log in before you can comment on or make changes to this bug.