This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 617669 - nfsstat names some values wrong
nfsstat names some values wrong
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nfs-utils (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Steve Dickson
yanfu,wang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-23 13:26 EDT by Issue Tracker
Modified: 2011-07-21 07:35 EDT (History)
5 users (show)

See Also:
Fixed In Version: nfs-utils-1.0.9-52.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 890146 (view as bug list)
Environment:
Last Closed: 2011-07-21 07:35:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Issue Tracker 2010-07-23 13:26:54 EDT
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2010-07-23 13:26:56 EDT
Event posted on 07-22-2010 03:47pm EDT by alfw

Hi,

When I issue the command "nfsstat -s -o rpc" it prints out

alfw@pssrv102 > nfsstat -s -o rpc
Server rpc stats:
calls      badcalls   badauth    badclnt    xdrcall
3003528135   5198       5198       0          0       

but the kernel source (kernel-2.6.18/linux-2.6.18.x86_64/net/sunrpc/stats.c,
lines 92-98) say:

        seq_printf(seq,
                "rpc %u %u %u %u %u\n",
                        statp->rpccnt,
                        statp->rpcbadfmt+statp->rpcbadauth+statp->rpcbadclnt,
                        statp->rpcbadfmt,
                        statp->rpcbadauth,
                        statp->rpcbadclnt);

which looks like the 3rd, 4th, and 5th field in the nfsstat output
are named wrong.

Here are some more details about the machine:

alfw@pssrv102 > uname -a
Linux pssrv102 2.6.18-164.15.1.el5 #1 SMP Mon Mar 1 10:56:08 EST 2010 x86_64 x86_64 x86_64 GNU/Linux

alfw@pssrv102 > cat /etc/redhat-release 
Red Hat Enterprise Linux Client release 5.4 (Tikanga)

alfw@pssrv102 > rpm -qvf /usr/sbin/nfsstat
nfs-utils-1.0.9-42.el5

Many thanks,
                    Alf.
		    

This event sent from IssueTracker by tgummels  [SLAC]
 issue 1175783
Comment 2 Issue Tracker 2010-07-23 13:26:58 EDT
Event posted on 07-22-2010 07:27pm EDT by tgummels

Alf,

I agree, it doesn't look right.  Not sure of the 4th argument to
print_numbers yet.  

nfsstat.c 1.0.9 (in the RHEL5 sources)

		if (opt_prt & PRNT_RPC) {
			print_numbers(
			"Server rpc stats:\n"
			"calls      badcalls   badauth    badclnt    xdrcall\n",
			svcrpcinfo, 5
			);
			printf("\n");
		}

static unsigned int	svcrpcinfo[6];	/* 0  total # of RPC calls
					 * 1  total # of bad calls
					 * 2  bad format
					 * 3  authentication failed
					 * 4  unknown client
					 */



This event sent from IssueTracker by tgummels  [SLAC]
 issue 1175783
Comment 4 yanfu,wang 2011-06-12 23:12:05 EDT
reproduced on rhel5.4:
# rpm -qa|grep nfs-utils
nfs-utils-lib-1.0.8-7.6.el5.x86_64
nfs-utils-lib-1.0.8-7.6.el5.i386
nfs-utils-1.0.9-42.el5.x86_64
nfs-utils-lib-devel-1.0.8-7.6.el5.x86_64
nfs-utils-lib-devel-1.0.8-7.6.el5.i386
# nfsstat -s -o rpc
Server rpc stats:
calls      badcalls   badauth    badclnt    xdrcall
0          0          0          0          0       


verified on RHEL5.7-Server-20110608.1:
# rpm -qa|grep nfs-utils
nfs-utils-1.0.9-53.el5
nfs-utils-lib-1.0.8-7.6.el5

# cat SOURCES/nfs-utils-1.0.9-nfsstat-hdrs.patch
--- nfs-utils-1.0.9/utils/nfsstat/nfsstat.c.orig        2011-04-26 11:25:41.329050000 -0400
+++ nfs-utils-1.0.9/utils/nfsstat/nfsstat.c     2011-04-26 13:29:47.340420000 -0400
@@ -343,7 +343,7 @@ main(int argc, char **argv)
                if (opt_prt & PRNT_RPC) {
                        print_numbers(
                        "Server rpc stats:\n"
-                       "calls      badcalls   badauth    badclnt    xdrcall\n",
+                       "calls      badcalls   badclnt    badauth    xdrcall\n",
                        svcrpcinfo, 5
                        );
                        printf("\n");

# nfsstat -s -o rpc
Server rpc stats:
calls      badcalls   badclnt    badauth    xdrcall
8          0          0          0          0
Comment 5 yanfu,wang 2011-06-12 23:27:20 EDT
customer report the 5th field in the nfsstat output is also named wrong, and I think the patch just fix the 3rd, 4th field. So could I ask customer to confirm if it's enough for them?
Comment 6 yanfu,wang 2011-06-13 21:57:43 EDT
pls help get feedback of comment #5, thanks.
Comment 7 Chris Ward 2011-06-14 04:43:16 EDT
@tgummels, See comment #5 please.
Comment 9 errata-xmlrpc 2011-07-21 07:35:36 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1048.html

Note You need to log in before you can comment on or make changes to this bug.