Bug 61769 - ttmkfdir choke on FIRSTINDEX in XF86 font enc. files
Summary: ttmkfdir choke on FIRSTINDEX in XF86 font enc. files
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: ttmkfdir (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Yu Shao
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On: 54087
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-24 10:20 UTC by Jungshik Shin
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-31 23:35:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a patch to ttmkfdir2 (392 bytes, patch)
2002-03-24 10:22 UTC, Jungshik Shin
no flags Details | Diff

Description Jungshik Shin 2002-03-24 10:20:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8+) Gecko/20020222

Description of problem:
ttmkfdir cannot process font encodings with FIRSTINDEX
entry. To work around this problem, encoding files
with FIRSTINDEX were modified by commenting out
lines with FIRSTINDEX. I think this should be the
other way around. That is, ttmkfdir should be fixed
not to choke on FIRSTINDEX. At the moment, ttmkfdir
does not do anything with FIRSTINDEX. Then, it can
just ignore FIRSTINDEX line instead of refusing
to process font encoding files with FIRSTINDEX. 



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Put the original ksc5601.1992-3.enc.gz file(with FIRSTINDEX)
  in /usr/X11R6/lib/X11/fonts/encodings/large 
2.run ttmkfdir in ttfonts-ko directory

	

Actual Results:  ttfonts-ko emits warning and refuses to work on ksc5601.1992-3.

Expected Results:  It should produce ksc5601.1992-3 entries for three Korean
truetype fonts in addition to iso10646-1 and ksc5601.1987-0
entries. 


Additional info:

Comment 1 Jungshik Shin 2002-03-24 10:22:07 UTC
Created attachment 49929 [details]
a patch to ttmkfdir2

Comment 2 Jungshik Shin 2002-03-24 10:24:21 UTC
My patch modifies encoding.l in ttmkfdir2 to make it ignore
FIRSTINDEX line in encoding files. The reason I'd like
to keep FIRSTINDEX line in encoding files is that
other parts of XFree86(freetype,X-tt or luit) may need it. 


Comment 3 Jungshik Shin 2002-03-24 10:29:08 UTC
ksc5601.1992-3 entries wouldn't be produced unless
my patch to ksc5601.1992-3.enc(described in
my comment to bug 54087) is applied.

Comment 4 Mike A. Harris 2002-05-22 10:32:21 UTC
Changing component to XFree86 where ttmkfdir currently resides in RHL 7.3

Comment 5 Mike A. Harris 2002-12-19 09:19:16 UTC
This somehow fell between the cracks, since we've had a hack workaround
in place.  Reassigning to ttmkfdir component for attention.

Comment 6 Yu Shao 2003-08-31 23:35:46 UTC
fixed ages ago, forgot to update here.


Note You need to log in before you can comment on or make changes to this bug.