Bug 617735 - [abrt] nautilus-2.31.5-2.fc14: Process /usr/bin/nautilus was killed by signal 11 (SIGSEGV)
[abrt] nautilus-2.31.5-2.fc14: Process /usr/bin/nautilus was killed by signal...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libjpeg-turbo (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
abrt_hash:13b62d75e4865d940780e4f0f20...
:
: 617736 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-23 16:11 EDT by Matt Hooper
Modified: 2013-04-30 19:46 EDT (History)
4 users (show)

See Also:
Fixed In Version: libjpeg-turbo-1.0.0-3.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-25 23:24:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (30.57 KB, text/plain)
2010-07-23 16:11 EDT, Matt Hooper
no flags Details

  None (edit)
Description Matt Hooper 2010-07-23 16:11:47 EDT
abrt version: 1.1.5
architecture: x86_64
Attached file: backtrace
cmdline: nautilus --sm-client-id 109eeca0200bf7321263427927846000000027090031 --sm-client-state-file /home/matt/.config/session-state/nautilus-1279838155.state
comment: Attempted to view a folder containing 8732 recovered files, believed to be JPG's, that may be corrupt. Nautilus was in "List View".
component: nautilus
executable: /usr/bin/nautilus
global_uuid: 13b62d75e4865d940780e4f0f20be656facb5de8
kernel: 2.6.35-0.49.rc5.git2.fc14.x86_64
package: nautilus-2.31.5-2.fc14
rating: 0
reason: Process /usr/bin/nautilus was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Rawhide)
time: 1279915544
uid: 500

How to reproduce
-----
1. 
2.
3.
Comment 1 Matt Hooper 2010-07-23 16:11:51 EDT
Created attachment 434055 [details]
File: backtrace
Comment 2 Bug Zapper 2010-07-30 08:48:06 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Matthias Clasen 2010-08-17 10:39:42 EDT
*** Bug 617736 has been marked as a duplicate of this bug. ***
Comment 4 Matthias Clasen 2010-08-17 10:40:43 EDT
This is a crash inside libjpeg. 
It would be very helpful if you could identify the image that causes the crash and attach it.
Comment 5 Adam Tkac 2010-08-17 10:54:06 EDT
I'm sure this is same issue as bug #617469.
Comment 6 Fedora Update System 2010-08-17 10:55:34 EDT
libjpeg-turbo-1.0.0-3.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/libjpeg-turbo-1.0.0-3.fc14
Comment 7 Fedora Update System 2010-08-17 15:35:45 EDT
libjpeg-turbo-1.0.0-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libjpeg-turbo'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/libjpeg-turbo-1.0.0-3.fc14
Comment 8 Matt Hooper 2010-08-18 16:59:00 EDT
(In reply to comment #7)
> libjpeg-turbo-1.0.0-3.fc14 has been pushed to the Fedora 14 testing repository.
>  If problems still persist, please make note of it in this bug report.
>  If you want to test the update, you can install it with 
>  su -c 'yum --enablerepo=updates-testing update libjpeg-turbo'.  You can
> provide feedback for this update here:
> http://admin.fedoraproject.org/updates/libjpeg-turbo-1.0.0-3.fc14

This update to libjpeg has resolved the issue. The images that caused crashes before can now be rendered, albeit as corrupt images.
Comment 9 Fedora Update System 2010-08-25 23:24:55 EDT
libjpeg-turbo-1.0.0-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.