Bug 617780 - Crashes everytime I click on an album cover
Summary: Crashes everytime I click on an album cover
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: banshee (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Christian Krause
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-23 23:04 UTC by Julian Aloofi
Modified: 2010-11-08 21:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-08 21:49:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of "banshee-1 --debug" (70.27 KB, text/plain)
2010-07-23 23:04 UTC, Julian Aloofi
no flags Details
Output of "banshee-1 --debug" (11.80 KB, text/plain)
2010-07-23 23:07 UTC, Julian Aloofi
no flags Details

Description Julian Aloofi 2010-07-23 23:04:17 UTC
Created attachment 434083 [details]
Output of "banshee-1 --debug"

Description of problem:
Everytime I click on an album cover in the music browser, Banshee crashes.
Sometimes I need to make a double-click, but often a single click is enough.
It always crashes the program and throws the same exception.
This problem occurs with and without the community-extensions.

Version-Release number of selected component (if applicable):
banshee-1.6.1-3.fc13.i686
banshee-community-extensions-1.6.0-1.fc13.i686

How reproducible:
Just start the program and click or double-click on an album cover in the music browser.

Steps to Reproduce:
1. Start Banshee
2. Double or single click on an album cover.
  
Actual results:
Program crash

Expected results:
View album songs or start playing the album.

Additional info:
abrt does not notice this crash, and doesn't pop up or offers me to generate a backtrace.

Attached is the output of "banshee-1 --debug" when doing nothing else but selecting an artist and then double-clicking on one of his albums.

Comment 1 Julian Aloofi 2010-07-23 23:07:00 UTC
Created attachment 434084 [details]
Output of "banshee-1 --debug"

Sorry, that other file was the wrong log.txt...
This is the right backtrace.

Comment 2 Christian Krause 2010-07-24 16:49:38 UTC
The problem seems to be related to some accessibility feature. I'm not sure yet what's the root cause, but if you don't need it you can turn off the accessibility features in System -> Assistive Technologies -> Enable assistive technologies. This workaround should prevent the problem. Please note that you have to logout and login again to get it de-activated.

Comment 3 Julian Aloofi 2010-07-24 17:42:38 UTC
(In reply to comment #2)
> The problem seems to be related to some accessibility feature. I'm not sure yet
> what's the root cause, but if you don't need it you can turn off the
> accessibility features in System -> Assistive Technologies -> Enable assistive
> technologies. This workaround should prevent the problem. Please note that you
> have to logout and login again to get it de-activated.    

Yup, that solved the problem for me, thanks! :)

Comment 4 Nathaniel McCallum 2010-10-11 00:51:49 UTC
I am not able to reproduce this on Banshee 1.8.0 in F14.  Are you able to test this version?

Comment 5 Julian Aloofi 2010-10-11 10:48:34 UTC
(In reply to comment #4)
> I am not able to reproduce this on Banshee 1.8.0 in F14.  Are you able to test
> this version?

Shouldn't be a problem. Is it urgent or can it wait until F14 is released? Otherwise I can just as well try it on the live CD.

Comment 6 Christian Krause 2010-11-08 21:49:59 UTC
I have re-tested the issue in F14 and I can confirm that even with enabled Assistive Technologies it can't be reproduced anymore.

I'll close the bug - if it happens for you in F14 again, feel free to re-open it.


Note You need to log in before you can comment on or make changes to this bug.