Bug 617874 - [abrt] can't allocate 33064 bytes
Summary: [abrt] can't allocate 33064 bytes
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gdb (Show other bugs)
(Show other bugs)
Version: 13
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: Jan Kratochvil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:1a2b2e125fa136b14f054a9a6a4...
Keywords:
: 617872 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-24 15:41 UTC by Rob Wills
Modified: 2010-07-24 16:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-24 16:42:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (11.79 KB, text/plain)
2010-07-24 15:41 UTC, Rob Wills
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Sourceware 11838 None None None Never

Description Rob Wills 2010-07-24 15:41:23 UTC
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/gdb -ex 'attach 3035' --ex 'info threads' --ex 'thread apply all bt' --batch
component: gdb
crash_function: raise
executable: /usr/bin/gdb
global_uuid: 1a2b2e125fa136b14f054a9a6a4f4002cfd1e98e
kernel: 2.6.33.6-147.fc13.x86_64
package: gdb-7.1-30.fc13
rating: 4
reason: Process /usr/bin/gdb was killed by signal 6 (SIGABRT)
release: Fedora release 13 (Goddard)

Comment 1 Rob Wills 2010-07-24 15:41:25 UTC
Created attachment 434158 [details]
File: backtrace

Comment 2 Jan Kratochvil 2010-07-24 16:02:27 UTC
*** Bug 617872 has been marked as a duplicate of this bug. ***

Comment 3 Jan Kratochvil 2010-07-24 16:05:40 UTC
You seem to have some low ulimit, allocating 33064 bytes must normally succeed.

Keeping the bug open as gcc debug producer has some problem there:
0x0000000000455171 in internal_error (file=0xbe3 <Address 0xbe3 out of bounds>

Comment 4 Jan Kratochvil 2010-07-24 16:42:55 UTC
Upstream the backtrace.

But I do not understand why GDB crashed for you, IMO its caller sets its environment somehow wrong.


Note You need to log in before you can comment on or make changes to this bug.