Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 617967 - perl-Compress-Raw-Zlib-2.030 is available
perl-Compress-Raw-Zlib-2.030 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-Compress-Raw-Zlib (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Petr Šabata
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-25 06:20 EDT by Upstream Release Monitoring
Modified: 2010-07-28 04:58 EDT (History)
4 users (show)

See Also:
Fixed In Version: perl-Compress-Raw-Zlib-2.030-1.fc13
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-28 04:58:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2010-07-25 06:20:27 EDT
Latest upstream release: 2.030
Current version in Fedora Rawhide: 2.027
URL: http://search.cpan.org/dist/Compress-Raw-Zlib/

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_Release_Monitoring
Comment 1 Paul Howarth 2010-07-26 05:58:50 EDT
Petr, are you going to update IO::Compress to 2.030 too? I'll need that before I can update Compress::Raw::Lzma and IO::Compress::Lzma to 2.030.

And since you're preparing an update for F-13 too, those packages should probably be grouped together in a big update of the IO::Compress stack.
Comment 2 Petr Šabata 2010-07-26 07:04:57 EDT
(In reply to comment #1)
> Petr, are you going to update IO::Compress to 2.030 too? I'll need that before
> I can update Compress::Raw::Lzma and IO::Compress::Lzma to 2.030.

I'm on it.

> And since you're preparing an update for F-13 too, those packages should
> probably be grouped together in a big update of the IO::Compress stack.    

I don't think it's needed since IO::Compress depends on the same or newer versions of Compress::Raw::Bzip2 and Zlib. I'm not sure how to group that with Lzma, though.
Comment 3 Paul Howarth 2010-07-26 07:14:53 EDT
IO::Compress doesn't need IO::Compress::Lzma but IO::Compress::Lzma does need IO::Compress, so it would be nice to group the stack together as a single update.

The dependency hierarchy is:

IO::Compress::Lzma
 |
 +-- Compress::Raw::Lzma
 |
 +-- IO::Compress
       |
       +-- Compress::Raw::Bzip2
       |
       +-- Compress::Raw::Zlib
Comment 4 Petr Šabata 2010-07-26 08:54:40 EDT
Yes, that sounds reasonable. I have removed the Bzip2 & Zlib updates from Bodhi for the moment.

I'm currently waiting for the dist-f13 koji buildroot regeneration to build IO::Compres 2.030.

Rawhide build is here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2351193
Comment 5 Paul Howarth 2010-07-26 09:34:59 EDT
perl-Compress-Raw-Lzma is built for F-13 and Rawhide now so I now need to wait on perl-IO-Compress before I can build perl-IO-Compress-Lzma.

The F-13 buildroot won't include the new Compress-*-Raw packages until either they're pushed to stable or a get a buildroot override from rel-eng. Since we want to push everything together, we'll need a buildroot override.

I've requested that at https://fedorahosted.org/rel-eng/ticket/3904 and CC-ed you on the ticket.
Comment 6 Petr Šabata 2010-07-27 04:24:25 EDT
IO::Compress 2.030 built.
Comment 7 Paul Howarth 2010-07-27 14:17:13 EDT
IO::Compress::Lzma now built; you can now prepare the update in bodhi (or I can do it if you like).
Comment 8 Petr Šabata 2010-07-28 03:43:08 EDT
Bodhi won't let me submit the update since I don't have commit access to the Lzma packages.

If you don't mind, I'd co-maintain those packages of yours. I've already requested the access rights.

Note You need to log in before you can comment on or make changes to this bug.