Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 618140 - rpmlint issues on rpm
rpmlint issues on rpm
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: icu4j (Show other bugs)
6.0
All Linux
low Severity low
: rc
: ---
Assigned To: Chris Aniszczyk
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-26 05:09 EDT by Jan Hutař
Modified: 2010-12-01 16:04 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-01 16:04:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2010-07-26 05:09:23 EDT
Description of problem:
rpmlint reports some issues on icu4j "binary" package.


Version-Release number of selected component (if applicable):
icu4j-4.0.1-3.3.el6.i686
rpmlint-0.94-2.el6.noarch


How reproducible:
always


Steps to Reproduce:
1. # rpmlint icu4j-4.0.1-3.3.el6.i686.rpm


Actual results:
# rpmlint icu4j-4.0.1-3.3.el6.i686.rpm
icu4j.i686: I: enchant-dictionary-not-found en_US
icu4j.i686: E: no-binary
icu4j.i686: E: unknown-key (MD5
1 packages and 0 specfiles checked; 2 errors, 0 warnings.


Expected results:
No errors or warnings should be there.
Comment 1 Andrew Overholt 2010-07-26 08:35:08 EDT
> icu4j.i686: E: no-binary

False positive due to it being an arch-specific package but having only noarch content.  This is due to needing to have the files in %{_libdir} because of timestamp differences in javadocs that cause multilib conflicts.
Comment 2 Alexander Kurtakov 2010-12-01 15:56:56 EST
> icu4j.i686: E: unknown-key (MD5

Rpmliint gives this error for using unknown key for signing the rpm:
'''The package was signed, but with an unknown key. See the rpm --import option for more information.'''
I guess that this is caused by some temporary brew problem when icu4j was build.

Additionally there is planned rebase for icu4j https://bugzilla.redhat.com/show_bug.cgi?id=656342 so this error should be gone with the next rebuild.

Note You need to log in before you can comment on or make changes to this bug.