Bug 618144 - Fail to install Rhel6 from boot.iso file
Fail to install Rhel6 from boot.iso file
Status: CLOSED DUPLICATE of bug 611154
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
high Severity high
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
: Regression, Reopened, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-26 05:23 EDT by XinSun
Modified: 2010-07-27 09:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-27 09:56:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description XinSun 2010-07-26 05:23:16 EDT
Description of problem:
When using rhel6 beta2 snapshot8 boot.iso to install OS, there is no installation method to choose NFS/URL/DVD media.But installation will continue if you click "next" button, then will fail  with error "Unable to read group information from repositories".


Version-Release number of selected component (if applicable):
RHEL6 Beta2 snapshot8 (RHEL6.0-20100722.0)


How reproducible:
Always
It's very easy to reproduce.

Steps to Reproduce:
1.Write boot.iso file into CD
2.Boot from CDROM to install Rhel6 OS
3.Ignore the disk media checking
4.Click "next" button to configure language,keyboard,hostname, time zone and ext4 filesystem
  
Actual results:
In step3, there is no installation method to choose NFS/URL/DVD media.
After step4, installation will fail with "Unable to read group information from repositories"

Expected results:
In step2, there will installation method as the same as before build done.
After step3, installation can be finished.

Additional info:
The old rhel6-20100715.0 cam be installed successfully from boot.iso file. 
If we add "askmethod" at boot command line, the installation method will be shown in snapshot8, but then you will meet network configuration error.
Comment 1 Chris Lumens 2010-07-26 09:56:57 EDT
We need to fix the original problem, not hack around it with askmethod.  I won't be adding that back as a default parameter.
Comment 2 XinSun 2010-07-26 23:33:56 EDT
(In reply to comment #1)
> We need to fix the original problem, not hack around it with askmethod.  I
> won't be adding that back as a default parameter.    

I don't think this is not a bug. In fact, installation will fail when using rhel6 beta2 snapshot8 boot.iso.  

As you said, askmethod was the work round for the original problem, can you tell how we can input the http url to do installation ? 

In the snapshot8, installation will fail with error "Unable to read group
information from repositories".
Comment 4 XinSun 2010-07-27 06:32:22 EDT
I retry this installation from boot.iso, 

1.If I add "askmethod" at boot command by myself, then I can input URL to complete installation.

2.But now in rhel6 snapshot8 , there isn't URL inputting choice in default, so user will meet installation failure with "Unable to read group
information from repositories".
Comment 5 Chris Lumens 2010-07-27 09:56:58 EDT
The proper fix for this is to make it so you are given the askmethod screen if you use boot.iso without having to specify the askmethod parameter yourself.  This will be fixed as part of 611154.

*** This bug has been marked as a duplicate of bug 611154 ***

Note You need to log in before you can comment on or make changes to this bug.