Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 618191 - Xorg 100% cpu usage
Xorg 100% cpu usage
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-26 07:42 EDT by ritz
Modified: 2018-04-11 08:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-30 11:25:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log (83.67 KB, text/plain)
2010-07-26 07:42 EDT, ritz
no flags Details
Xorg.0.log when Xorg is consuming 100% of CPU (121.31 KB, text/plain)
2010-07-27 12:00 EDT, Tom London
no flags Details

  None (edit)
Description ritz 2010-07-26 07:42:36 EDT
Created attachment 434396 [details]
xorg log

Description of problem:
100% cpu usage from Xorg

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.8.99.905-2.20100716.fc14.x86_64


How reproducible:
always

Steps to Reproduce:
n/a

Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2010-07-27 12:00:28 EDT
Created attachment 434737 [details]
Xorg.0.log when Xorg is consuming 100% of CPU

I'm seeing this as well.

System is Thinkpad X200, Intel graphics.

No xorg.conf.
Comment 2 Tom London 2010-07-27 12:29:37 EDT
A bit more information on this.

I downgraded back to 

xorg-x11-server-common-1.8.99.904-6.20100702.fc14.x86_64.rpm
xorg-x11-server-debuginfo-1.8.99.904-6.20100702.fc14.x86_64.rpm
xorg-x11-server-devel-1.8.99.904-6.20100702.fc14.x86_64.rpm
xorg-x11-server-Xorg-1.8.99.904-6.20100702.fc14.x86_64.rpm

And the problem remained: 100% Xorg cpu utilization.

I then noticed this in /var/log/messages:

Jul 27 09:17:05 tlondon /sbin/mingetty[1691]: tty1: invalid character 0x1c in login name
Jul 27 09:17:10 tlondon systemd[1]: getty@tty1.service holdoff time over, scheduling restart.
Jul 27 09:17:10 tlondon kernel: systemd[1]: getty@tty1.service holdoff time over, scheduling restart.
Jul 27 09:17:10 tlondon systemd[1]: Unit getty@tty1.service entered maintenance state.
Jul 27 09:17:10 tlondon kernel: systemd[1]: Unit getty@tty1.service entered maintenance state.
Jul 27 09:17:10 tlondon systemd[1]: getty@tty1.service holdoff time over, scheduling restart.
Jul 27 09:17:10 tlondon kernel: systemd[1]: getty@tty1.service holdoff time over, scheduling restart.
Jul 27 09:17:11 tlondon systemd[1]: getty@tty1.service holdoff time over, scheduling restart.
Jul 27 09:17:11 tlondon systemd[1]: Unit getty@tty1.service entered maintenance state.
Jul 27 09:17:11 tlondon kernel: systemd[1]: getty@tty1.service holdoff time over, scheduling restart.
<<<SNIP>>>

etc.

So, two things:
1. logging off and logging back in (not shutting down and rebooting) seems to "fix this for me".

2. Could this be an issue with systemd?  I haven't tried this with upstart.
Comment 3 Matěj Cepl 2010-07-27 17:39:03 EDT
(In reply to comment #0)
> Created an attachment (id=434396) [details]
> xorg log
> 
> Description of problem:
> 100% cpu usage from Xorg

How did you achieve this interesting result?

Also, please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 Tom London 2010-07-28 10:55:54 EDT
For me, this seems to be a systemd issue. 

Following the workaround in https://bugzilla.redhat.com/show_bug.cgi?id=614454#c7 appears to "make this work for me".

Not sure this is the same issue as originally posted.
Comment 5 Matěj Cepl 2010-07-29 04:27:36 EDT
Reporter, does the workaround in bug 614454 comment 7 work for you?
Comment 6 ritz 2010-07-29 11:20:29 EDT
@Matej

  Seems to work. I need to pay more attention to syslog. 

Cheers,
Ritesh
Comment 7 Bug Zapper 2010-07-30 08:51:20 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Matěj Cepl 2010-07-30 11:25:56 EDT
Thank you for letting us know.

Note You need to log in before you can comment on or make changes to this bug.