Bug 618248 - Sony BRAVIA 32" via VGA
Sony BRAVIA 32" via VGA
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-26 09:49 EDT by Jayrome
Modified: 2010-08-10 21:42 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-03 09:49:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg.7z (12.65 KB, application/x-7z-compressed)
2010-07-27 00:51 EDT, Jayrome
no flags Details
uncompressed contents of dmesg (105.57 KB, text/plain)
2010-08-01 12:17 EDT, Chuck Ebbert
no flags Details
Manual page (2.47 MB, image/jpeg)
2010-08-02 22:26 EDT, Jayrome
no flags Details

  None (edit)
Description Jayrome 2010-07-26 09:49:14 EDT
Sony KDL-32P3000 TV set (1366x768) is detected as a different device with wrong screen resolution.

Linux mini 2.6.32.16-141.fc12.i686 #1 SMP Wed Jul 7 04:47:25 UTC 2010 i686 i686 i386 GNU/Linux

This is always reproducible.

How to Reproduce:
1. Connect Sony BRAVIA 32" (KDL-32P3000) TV to Dell mini 10v notebook with VGA cable.
  
The TV set shows up in gnome-display-properties as Sony 70", the resolution 1024x768 is set by default. The UI does not allow setting resolution above 1280x800, the picture is blurry.

Correct would be Sony 32" at 1366x768.

Additional info: the resolution changes I make in gnome-display-properties are not saved upon re-connecting the TV.

Thank you.
Comment 1 Chuck Ebbert 2010-07-26 14:58:19 EDT
Please boot with the kernel option drm.debug=15 and attach the contents of /var/log/dmesg after booting.

Also, look in the setup menus for the TV and see if there is an option to change the way the VGA picture is displayed. This can be difficult to do; for example on a Toshiba TV you have to switch to the VGA input first (because the settings are per-input), then go into the menus and select "theater settings". Toshiba calls the modes "natural", "full" and "dot by dot". Only "dot by dot" works correctly.
Comment 2 Jayrome 2010-07-27 00:51:06 EDT
Created attachment 434593 [details]
dmesg.7z
Comment 3 Jayrome 2010-07-27 01:08:42 EDT
There is no setting for the picture mode except the two "Fullscreen" modes:
1. Fullscreen 1 — center the image (leaving black stripes on the sides when it's 1280x768 on the 1366x768 display);
2. Fullscreen 2 — stretch the image to fit the screen (introduces distortion with the current limit of 1280x768).

So the rest is up to the device being the source.
Comment 4 Chuck Ebbert 2010-08-01 12:17:21 EDT
Created attachment 435884 [details]
uncompressed contents of dmesg

Please don't attach compressed files. Someone has to download, decompress and re-upload them when you do that.
Comment 5 Chuck Ebbert 2010-08-01 12:22:16 EDT
Looks like the TV doesn't advertise a full-resolution mode at all?
Comment 6 Jayrome 2010-08-02 22:23:35 EDT
(In reply to comment #4)
> Please don't attach compressed files. Someone has to download, decompress and
> re-upload them when you do that.    

Sorry, I'll remember that.
Comment 7 Jayrome 2010-08-02 22:26:44 EDT
Created attachment 436171 [details]
Manual page

I tried to figure this ine out, here's what I have in the manual.
Comment 8 Chuck Ebbert 2010-08-03 09:49:22 EDT
It looks like that TV only supports full resolution via the HDMI input. The maximum resolution using the VGA connector is only 1280x768.
Comment 9 Jayrome 2010-08-03 23:48:05 EDT
I see.

But still, the graphic mode 1024x768 is set when the TV is hot-plugged, which is wrong. I have to go to settings and set the mode 1280x768 each time I connect the set, which is not very convenient for me.

As I wrote when opening this bug,
> Sony KDL-32P3000 TV set (1366x768, skip this part now) is detected as a different device with wrong
> screen resolution.
> 
> The TV set shows up in gnome-display-properties as Sony 70", the resolution
> 1024x768 is set by default.

> Additional info: the resolution changes I make in gnome-display-properties are
> not saved upon re-connecting the TV.
> 
> Thank you.
Comment 10 Jayrome 2010-08-10 21:42:46 EDT
Shall I create a new bug report?

Note You need to log in before you can comment on or make changes to this bug.