Bug 618263 - HornetQ plugin's descriptor incorrectly lists JBossAS 4.x server as parent type
Summary: HornetQ plugin's descriptor incorrectly lists JBossAS 4.x server as parent type
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
(Show other bugs)
Version: 3.0.0
Hardware: All All
medium
medium vote
Target Milestone: ---
: ---
Assignee: Ian Springer
QA Contact: Corey Welton
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 725852
TreeView+ depends on / blocked
 
Reported: 2010-07-26 14:10 UTC by Ian Springer
Modified: 2013-08-06 00:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-28 16:18:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker HORNETQ-454 None None None Never

Description Ian Springer 2010-07-26 14:10:40 UTC
This causes errors  like the following to appear in the Agent log whenever a runtime discovery scan is executed:

2010-07-23 00:46:04,424 WARN  [InventoryManager.discovery-1] (rhq.core.pc.inventory.InventoryManager)- Failure during discovery for [JMS Manager] Resources - failed after 0 ms.
java.lang.Exception: Discovery component invocation failed.
	at org.rhq.core.pc.util.DiscoveryComponentProxyFactory$ComponentInvocationThread.call(DiscoveryComponentProxyFactory.java:283)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:636)
Caused by: java.lang.NoSuchMethodException: org.rhq.plugins.jbossas.JBossASServerComponent.getConnection()
	at java.lang.Class.getMethod(Class.java:1622)
	at org.jboss.as.integration.hornetq.jopr.JMSManagerDiscoveryComponent.getProfileService(JMSManagerDiscoveryComponent.java:65)
	at org.jboss.as.integration.hornetq.jopr.JMSManagerDiscoveryComponent.discoverResources(JMSManagerDiscoveryComponent.java:44)
	at sun.reflect.GeneratedMethodAccessor37.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at org.rhq.core.pc.util.DiscoveryComponentProxyFactory$ComponentInvocationThread.call(DiscoveryComponentProxyFactory.java:279)
	... 5 more


The messages are harmless but could be alarming to users. We're also spawning an unnecessary discovery component thread, which will only fail.

The fix for this is very simple. In the hornetq plugin descriptor, change:

   <service name="JMS Manager" ...>

      <runs-inside>
         <parent-resource-type name="JBossAS Server" plugin="JBossAS"/>
         <parent-resource-type name="JBossAS Server" plugin="JBossAS5"/>
      </runs-inside>

to:

   <service name="JMS Manager" ...>

      <runs-inside>
         <parent-resource-type name="JBossAS Server" plugin="JBossAS5"/>
      </runs-inside>

This is correct because the HornetQ plugin currently is coded to assume it's running inside AS 5.x/6.x.

Comment 1 Charles Crouch 2010-07-26 14:19:10 UTC
Since these are only log messages and have no functional impact I don't see this as blocker for 2.4

Comment 2 Charles Crouch 2010-07-26 14:30:28 UTC
Ian please raise a jira for the hornetQ team to fix this.

Comment 3 Ian Springer 2010-07-26 21:28:29 UTC
I've raised https://jira.jboss.org/jira/browse/HORNETQ-454.

Comment 4 Corey Welton 2010-09-28 12:14:26 UTC
 ips - should we close this tracker?

Comment 5 Ian Springer 2010-09-28 16:18:57 UTC
Yes, closing, as HORNETQ-454 is fixed in v1.0.0.Final of the hornetq plugin.


Note You need to log in before you can comment on or make changes to this bug.