Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 618328 - installing new package attempts install of all versions of dependencies with up2date-4.8.1-33.el4_8.8
installing new package attempts install of all versions of dependencies with ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.8
All Linux
urgent Severity high
: rc
: ---
Assigned To: Miroslav Suchý
Garik Khachikyan
: Regression, ZStream
: 617181 (view as bug list)
Depends On:
Blocks: 629632
  Show dependency treegraph
 
Reported: 2010-07-26 12:55 EDT by Issue Tracker
Modified: 2015-01-04 16:57 EST (History)
14 users (show)

See Also:
Fixed In Version: up2date-4.9.1-28.el4
Doc Type: Bug Fix
Doc Text:
Due to incorrect handling of package dependencies, up2date may have been unable to install certain packages. This error has been fixed, and all packages are now installed as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-16 09:18:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0240 normal SHIPPED_LIVE up2date bug fix update 2011-02-15 11:34:59 EST

  None (edit)
Description Issue Tracker 2010-07-26 12:55:38 EDT
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2010-07-26 12:55:40 EDT
Event posted on 2010-07-22 13:00 BST by pmutha

Indicate the platform(s) (architectures) the problem is being reported against.
- RHEL 4 U8 x86_64 platform.

Provide clear and concise problem description as it is understood at the time of escalation
- up2date fails to install certain packages which are having depenency on other packages. Trying to install compat-libstdc++-296 fails with :

package libgcc-3.4.6-11 (which is newer than libgcc-3.4.6-9) is already installed
file /lib/libgcc_s-3.4.6-20060404.so.1 conflicts between attempted installs of libgcc-3.4.6-11.el4_8.1 and libgcc-3.4.6-9

This happens only with the latest up2date package. If we install the old up2date package then it works fine.

How Reproducible
- Always

Steps to Reproduce
- Ensure up2date-4.8.1-33.el4_8.8 is installed
- up2date compat-libstdc++-296

Observed Behavior
- fails with error :

# up2date compat-libstdc++-296 --dry-run

Fetching Obsoletes list for channel: rhel-x86_64-as-4...
########################################

Fetching Obsoletes list for channel: rhn-tools-rhel-4-as-x86_64...
########################################

Fetching rpm headers...
########################################

Name                                    Version              Rel               Arch
----------------------------------------------------------------------------------------
compat-libstdc++-296                    2.96                132.7.2             i386  


Testing package set / solving RPM inter-dependencies...
warning: package libgcc = 3.4.3-22.1 was already added, replacing with libgcc <= 3.4.4-2
warning: package libgcc = 3.4.4-2 was already added, replacing with libgcc <= 3.4.5-2
warning: package libgcc = 3.4.5-2 was already added, replacing with libgcc <= 3.4.6-10
warning: package libgcc = 3.4.6-10 was already added, replacing with libgcc <= 3.4.6-11
warning: package libgcc = 3.4.6-11 was already added, replacing with libgcc <= 3.4.6-11.el4_8.1
warning: package libgcc = 3.4.3-9.EL4 was already added, replacing with libgcc <= 3.4.6-3
warning: package libgcc = 3.4.6-3 was already added, replacing with libgcc <= 3.4.6-3.1
warning: package libgcc = 3.4.6-3.1 was already added, replacing with libgcc <= 3.4.6-8
warning: package libgcc = 3.4.6-8 was already added, replacing with libgcc <= 3.4.6-9
########################################
RPM package conflict error.  The message was:
Test install failed because of package conflicts:
The following packages were added to your selection to satisfy dependencies:
Name                                    Version        Release
--------------------------------------------------------------
libgcc                                  3.4.3          22.1                
libgcc                                  3.4.3          9.EL4                
libgcc                                  3.4.4          2                    
libgcc                                  3.4.5          2                    
libgcc                                  3.4.6          10                  
libgcc                                  3.4.6          11                  
libgcc                                  3.4.6          11.el4_8.1          
libgcc                                  3.4.6          3                    
libgcc                                  3.4.6          3.1                  
libgcc                                  3.4.6          8                    
libgcc                                  3.4.6          9                    

package libgcc-3.4.6-11 (which is newer than libgcc-3.4.6-9) is already installed
file /lib/libgcc_s-3.4.6-20060404.so.1 conflicts between attempted installs of libgcc-3.4.6-11.el4_8.1 and libgcc-3.4.6-9

Expected Behavior
- Package should be installed successfully.

Action Required from SEG 
- Looks to be a bug with up2date-4.8.1-33.el4_8.8. If we install up2date-4.6.2-7.el4_6.1.x86_64.rpm and then try to install the same package it works fine.

Regards,
Paresh
This event sent from IssueTracker by mpoole  [SEG - RHN]
 issue 1172723
Comment 2 Issue Tracker 2010-07-26 12:55:42 EDT
Event posted on 2010-07-22 13:07 BST by pmutha

Investigating this further here is what I see :

/usr/share/rhn/up2date_client/depSolver.py

    def solveDep(self, unknowns, availList,
                 msgCallback = None,
                 progressCallback = None,
                 refreshCallback = None):
        for source_key in self.source_list:
            source = self.metainfo[source_key]
            (ret, depToPkg) = source.solveDep(unknowns, availList,
                                  refreshCallback = refreshCallback,
                                  progressCallback = progressCallback,
                                  msgCallback = msgCallback)
            if ret != []:
                self.log.log_debug("Dep %s Fetched via: %s" % (
                    unknowns, ret))
                #self.fetchType[pkg] = source['name']
                return (ret, depToPkg)
        return ([], {})


So checking /usr/share/rhn/up2date_client/repoBackends/up2dateRepo.py I
see :

class RhnSolveDep(genericSolveDep.GenericSolveDep):
    def __init__(self):
        genericSolveDep.GenericSolveDep.__init__(self)

    def getSolutions(self, unknowns, progressCallback = None, msgCallback
= None):
        s = rpcServer.getServer(refreshCallback=self.refreshCallback)
        print unknowns
        try:
            if len(unknowns) > 0 and type(unknowns[0]) in (ListType,
TupleType):
                tmpRetList = {}
                for dep in unknowns:
                        tmpRetList =
rpcServer.doCall(s.up2date.solveDependencies_with_limits,
                                            up2dateAuth.getSystemId(),
                                            [dep[0]], 2, 1)


So comparing the getSolutions in the current (latest up2date) and older
version I see the difference.
Latest up2date calls s.up2date.solveDependencies_with_limits whereas old
up2date calls s.up2date.solveDependencies

Also checking the value of unknowns and tmpRetList I see that :
With old up2date package :

unknowns = ['libgcc_s.so.1', 'libgcc_s.so.1(GLIBC_2.0)']

tmpRetList = {'libgcc_s.so.1': [['libgcc', '3.4.6', '11.el4_8.1',
'']], 'libgcc_s.so.1(GLIBC_2.0)': [['libgcc', '3.4.6',
'11.el4_8.1', '']]}

unknowns =  [('libgcc_s.so.1', None), ('libgcc_s.so.1(GLIBC_2.0)',
None)]

Whereas with new up2date package :
tmpRetList = {'libgcc_s.so.1': [['libgcc', '3.4.6', '11.el4_8.1',
'', 'i386'], ['libgcc', '3.4.6', '11', '', 'i386'],
['libgcc', '3.4.6', '10', '', 'i386'], ['libgcc', '3.4.6',
'9', '', 'i386'], ['libgcc', '3.4.6', '8', '', 'i386'],
['libgcc', '3.4.6', '3.1', '', 'i386'], ['libgcc', '3.4.6',
'3', '', 'i386'], ['libgcc', '3.4.5', '2', '', 'i386'],
['libgcc', '3.4.4', '2', '', 'i386'], ['libgcc', '3.4.3',
'22.1', '', 'i386'], ['libgcc', '3.4.3', '9.EL4', '',
'i386']]}

So I see this is the call which is making the difference in the list of
libgcc packages and various versions.



This event sent from IssueTracker by mpoole  [SEG - RHN]
 issue 1172723
Comment 3 Martin Poole 2010-07-26 12:58:47 EDT
My own tests show this regression occured between up2date-4.8.1-33.el4_8.1  and  up2date-4.8.1-33.el4_8.8
Comment 4 Miroslav Suchý 2010-08-19 04:26:08 EDT
Negative. Could not reproduce it.

[root@vmware123 ~]# rpm -q libgcc
libgcc-3.4.6-11
[root@vmware123 ~]# rpm -q compat-libstdc++-296
package compat-libstdc++-296 is not installed
[root@vmware123 ~]# rpm -q up2date
up2date-4.8.1-33.el4_8.8
[root@vmware123 ~]# up2date compat-libstdc++-296

Fetching Obsoletes list for channel: rhel-i386-as-4...

Fetching Obsoletes list for channel: rhn-tools-rhel-4-as-i386...

Fetching rpm headers...
########################################

Name                                    Version              Rel               Arch
----------------------------------------------------------------------------------------
compat-libstdc++-296                    2.96                132.7.2             i386


Testing package set / solving RPM inter-dependencies...
########################################
compat-libstdc++-296-2.96-1 ########################## Done.
Preparing              ########################################### [100%]

Installing...
   1:compat-libstdc++-296   ########################################### [100%]


This was against Satellite 5.3 with latest updates. 
May I ask - this system in question was registred against hosted or Satellite. And which version of satellite?
Comment 5 Jessica Sterling 2010-08-19 09:39:53 EDT
The system in question is registered against RHN Hosted.  Sorry for not making that distinction!

Jessica Sterling, RHCE
Red Hat GSS
Comment 8 Ivan Pablo Anauati 2010-08-25 12:03:12 EDT
I have the same issue in up2date-4.8.1-33.el4_8.9-x86_64, but with another package.

Fri Aug 20 14:07:10 2010] up2date solving dep for: [('libibverbs.so.1', None), ('libibverbs.so.1(IBVERBS_1.0)', None), ('libibverbs.so.1(IBVERBS_1.1)', None), ('librdmacm.so.1', None), ('librdmacm.so.1(RDMACM_1.0)', None), ('evolution28-cairo', None), ('evolution28-gtk2', None), ('evolution28-pango', None), ('gstreamer-tools', None), ('libieee1284.so.3()(64bit)', None), ('libsane.so.1()(64bit)', None), ('kdenetwork', '7:3.3.1-4.el4'), ('kdepim', '6:3.3.1-2.2'), ('libkcal.so.2()(64bit)', None), ('libkdepim.so.1()(64bit)', None), ('libkonnector.so.0()(64bit)', None), ('libksync2.so.0()(64bit)', None), ('beecrypt-devel', None), ('elfutils-libelf-devel', None), ('systemtap-runtime', '0.6.2-2.el4_8.1')]
[Fri Aug 20 14:07:30 2010] up2date solving dep for: [('libibverbs.so.1', None), ('libibverbs.so.1(IBVERBS_1.0)', None), ('libibverbs.so.1(IBVERBS_1.1)', None), ('librdmacm.so.1', None), ('librdmacm.so.1(RDMACM_1.0)', None), ('evolution28-cairo', None), ('evolution28-gtk2', None), ('evolution28-pango', None), ('gstreamer-tools', None), ('libieee1284.so.3()(64bit)', None), ('libsane.so.1()(64bit)', None), ('kdenetwork', '7:3.3.1-4.el4'), ('kdepim', '6:3.3.1-2.2'), ('libkcal.so.2()(64bit)', None), ('libkdepim.so.1()(64bit)', None), ('libkonnector.so.0()(64bit)', None), ('libksync2.so.0()(64bit)', None), ('beecrypt-devel', None), ('elfutils-libelf-devel', None)]
[Fri Aug 20 14:07:52 2010] up2date solving dep for: [('libibverbs.so.1', None), ('libibverbs.so.1(IBVERBS_1.0)', None), ('libibverbs.so.1(IBVERBS_1.1)', None), ('librdmacm.so.1', None), ('librdmacm.so.1(RDMACM_1.0)', None), ('elfutils-libelf', '0.97-5'), ('evolution28-cairo', None), ('evolution28-gtk2', None), ('evolution28-pango', None), ('gstreamer-tools', None), ('libieee1284.so.3()(64bit)', None), ('libsane.so.1()(64bit)', None), ('kdenetwork', '7:3.3.1-4.el4'), ('kdepim', '6:3.3.1-2.2'), ('libkcal.so.2()(64bit)', None), ('libkdepim.so.1()(64bit)', None), ('libkonnector.so.0()(64bit)', None), ('libksync2.so.0()(64bit)', None), ('beecrypt-devel', None)]
[Fri Aug 20 14:08:14 2010] up2date solving dep for: [('libibverbs.so.1', None), ('libibverbs.so.1(IBVERBS_1.0)', None), ('libibverbs.so.1(IBVERBS_1.1)', None), ('librdmacm.so.1', None), ('librdmacm.so.1(RDMACM_1.0)', None), ('elfutils-libelf', '0.97-5'), ('evolution28-cairo', None), ('evolution28-gtk2', None), ('evolution28-pango', None), ('gstreamer-tools', None), ('libieee1284.so.3()(64bit)', None), ('libsane.so.1()(64bit)', None), ('kdenetwork', '7:3.3.1-4.el4'), ('kdepim', '6:3.3.1-2.2'), ('libkcal.so.2()(64bit)', None), ('libkdepim.so.1()(64bit)', None), ('libkonnector.so.0()(64bit)', None), ('libksync2.so.0()(64bit)', None)]
[Fri Aug 20 14:08:36 2010] up2date solving dep for: [('libibverbs.so.1', None), ('libibverbs.so.1(IBVERBS_1.0)', None), ('libibverbs.so.1(IBVERBS_1.1)', None), ('librdmacm.so.1', None), ('librdmacm.so.1(RDMACM_1.0)', None), ('elfutils-libelf', '0.97-5'), ('evolution28-cairo', None), ('evolution28-gtk2', None), ('evolution28-pango', None), ('gstreamer-tools', None), ('libieee1284.so.3()(64bit)', None), ('libsane.so.1()(64bit)', None), ('kdenetwork', '7:3.3.1-4.el4'), ('kdepim', '6:3.3.1-2.2')]
[Fri Aug 20 14:08:50 2010] up2date solving dep for: [('libibverbs.so.1', None), ('libibverbs.so.1(IBVERBS_1.0)', None), ('libibverbs.so.1(IBVERBS_1.1)', None), ('librdmacm.so.1', None), ('librdmacm.so.1(RDMACM_1.0)', None), ('elfutils-libelf', '0.97-5'), ('evolution28-cairo', None), ('evolution28-gtk2', None), ('evolution28-pango', None), ('gstreamer-tools', None), ('libieee1284.so.3()(64bit)', None), ('libsane.so.1()(64bit)', None), ('kdenetwork', '7:3.3.1-4.el4')]
[Fri Aug 20 14:09:11 2010] up2date solving dep for: [('libibverbs.so.1', None), ('libibverbs.so.1(IBVERBS_1.0)', None), ('libibverbs.so.1(IBVERBS_1.1)', None), ('librdmacm.so.1', None), ('librdmacm.so.1(RDMACM_1.0)', None), ('elfutils-libelf', '0.97-5'), ('evolution28-cairo', None), ('evolution28-gtk2', None), ('evolution28-pango', None), ('gstreamer-tools', None), ('libieee1284.so.3()(64bit)', None), ('libsane.so.1()(64bit)', None), ('kdenetwork', '7:3.3.1-4.el4')]
[Fri Aug 20 14:09:24 2010] up2date solving dep for: [('libibverbs.so.1', None), ('libibverbs.so.1(IBVERBS_1.0)', None), ('libibverbs.so.1(IBVERBS_1.1)', None), ('librdmacm.so.1', None), ('librdmacm.so.1(RDMACM_1.0)', None), ('elfutils-libelf', '0.97-5'), ('evolution28-cairo', None), ('evolution28-gtk2', None), ('evolution28-pango', None), ('gstreamer-tools', None), ('libieee1284.so.3()(64bit)', None), ('libsane.so.1()(64bit)', None)]
[Fri Aug 20 14:09:43 2010] up2date solving dep for: [('libibverbs.so.1', None), ('libibverbs.so.1(IBVERBS_1.0)', None), ('libibverbs.so.1(IBVERBS_1.1)', None), ('librdmacm.so.1', None), ('librdmacm.so.1(RDMACM_1.0)', None), ('elfutils-libelf', '0.97-5'), ('evolution28-cairo', None), ('evolution28-gtk2', None), ('evolution28-pango', None), ('gstreamer-tools', None), ('libieee1284.so.3()(64bit)', None), ('libieee1284.so.3()(64bit)', None)]
[Fri Aug 20 14:09:57 2010] up2date solving dep for: [('libibverbs.so.1', None), ('libibverbs.so.1(IBVERBS_1.0)', None), ('libibverbs.so.1(IBVERBS_1.1)', None), ('librdmacm.so.1', None), ('librdmacm.so.1(RDMACM_1.0)', None), ('elfutils-libelf', '0.97-5'), ('evolution28-cairo', None), ('evolution28-gtk2', None), ('evolution28-pango', None), ('gstreamer-tools', None)]
[Fri Aug 20 14:10:09 2010] up2date solving dep for: [('libibverbs.so.1', None), ('libibverbs.so.1(IBVERBS_1.0)', None), ('libibverbs.so.1(IBVERBS_1.1)', None), ('librdmacm.so.1', None), ('librdmacm.so.1(RDMACM_1.0)', None), ('elfutils-libelf', '0.97-5'), ('evolution28-cairo', None), ('evolution28-gtk2', None), ('evolution28-pango', None)]
[Fri Aug 20 14:10:22 2010] up2date solving dep for: [('libibverbs.so.1', None), ('libibverbs.so.1(IBVERBS_1.0)', None), ('libibverbs.so.1(IBVERBS_1.1)', None), ('librdmacm.so.1', None), ('librdmacm.so.1(RDMACM_1.0)', None), ('elfutils-libelf', '0.97-5'), ('evolution28-cairo', None), ('evolution28-cairo', '1.2.2'), ('evolution28-glib2', None), ('evolution28-glib2', '2.12.0-1'), ('evolution28-cairo', None), ('evolution28-gtk2', None)]
[Fri Aug 20 14:10:40 2010] up2date solving dep for: [('libibverbs.so.1', None), ('libibverbs.so.1(IBVERBS_1.0)', None), ('libibverbs.so.1(IBVERBS_1.1)', None), ('librdmacm.so.1', None), ('librdmacm.so.1(RDMACM_1.0)', None), ('elfutils-libelf', '0.97-5'), ('evolution28-atk', '1.9.0-1'), ('evolution28-cairo', '1.2.0-1'), ('evolution28-glib2', '2.12.0-1'), ('evolution28-cairo', None), ('evolution28-cairo', '1.2.2'), ('evolution28-glib2', None), ('evolution28-glib2', '2.12.0-1'), ('evolution28-cairo', None)]
[Fri Aug 20 14:10:55 2010] up2date solving dep for: [('libibverbs.so.1', None), ('libibverbs.so.1(IBVERBS_1.0)', None), ('libibverbs.so.1(IBVERBS_1.1)', None), ('librdmacm.so.1', None), ('librdmacm.so.1(RDMACM_1.0)', None), ('elfutils-libelf', '0.97-5'), ('evolution28-atk', '1.9.0-1'), ('evolution28-glib2', '2.12.0-1'), ('evolution28-glib2', None), ('evolution28-glib2', '2.12.0-1')]
[Fri Aug 20 14:11:07 2010] up2date solving dep for: [('libibverbs.so.1', None), ('libibverbs.so.1(IBVERBS_1.0)', None), ('libibverbs.so.1(IBVERBS_1.1)', None), ('librdmacm.so.1', None), ('librdmacm.so.1(RDMACM_1.0)', None), ('elfutils-libelf', '0.97-5'), ('evolution28-atk', '1.9.0-1')]
[Fri Aug 20 14:11:16 2010] up2date solving dep for: [('libibverbs.so.1', None), ('libibverbs.so.1(IBVERBS_1.0)', None), ('libibverbs.so.1(IBVERBS_1.1)', None), ('librdmacm.so.1', None), ('librdmacm.so.1(RDMACM_1.0)', None), ('elfutils-libelf', '0.97-5')]
[Fri Aug 20 14:11:26 2010] up2date solving dep for: [('libibverbs.so.1', None), ('libibverbs.so.1(IBVERBS_1.0)', None), ('libibverbs.so.1(IBVERBS_1.1)', None), ('librdmacm.so.1', None), ('librdmacm.so.1(RDMACM_1.0)', None)]
[Fri Aug 20 14:11:38 2010] up2date solving dep for: [('libibverbs.so.1', None), ('libibverbs.so.1(IBVERBS_1.0)', None), ('libibverbs.so.1(IBVERBS_1.1)', None), ('libibverbs.so.1', None), ('libibverbs.so.1(IBVERBS_1.0)', None), ('libibverbs.so.1(IBVERBS_1.1)', None)]
[Fri Aug 20 14:12:50 2010] up2date RPM package conflict error.  The message was:
Test install failed because of package conflicts:
The following packages were added to your selection to satisfy dependencies:
Name                                    Version        Release
--------------------------------------------------------------
beecrypt-devel                          3.1.0          6                   
elfutils-libelf                         0.97           5                   
elfutils-libelf                         0.97           5                   
elfutils-libelf-devel                   0.97           5                   
evolution28-atk                         1.12.2         4.el4               
evolution28-cairo                       1.2.4          6.el4               
evolution28-glib2                       2.12.3         6.el4               
evolution28-gtk2                        2.10.4         21.el4              
evolution28-pango                       1.14.9         7.el4               
gstreamer-tools                         0.8.7          4.EL.0              
kdenetwork                              3.3.1          2                   
kdenetwork                              3.3.1          4.el4               
kdepim                                  3.3.1          2.1                 
kdepim                                  3.3.1          2.2                 
libieee1284                             0.2.8          4                   
librdmacm                               0.9.1          7                   
librdmacm                               1.0.1          7                   
librdmacm                               1.0.7          1.el4               
librdmacm                               1.0.8          1.el4               
sane-backends                           1.0.14         6                   
sane-backends                           1.0.14         6.el4.1             
sane-backends                           1.0.14         6.el4.4             
systemtap-runtime                       0.6.2          2.el4_8.1           
libibverbs                              1.1.1          7                   
libibverbs                              1.1.1          9.el4               
libibverbs                              1.1.2          1.el4               

package elfutils-libelf-0.97.1-3 (which is newer than elfutils-libelf-0.97-5) is already installed
package elfutils-libelf-0.97.1-3 (which is newer than elfutils-libelf-0.97-5) is already installed
package elfutils-libelf-0.97.1-3 (which is newer than elfutils-libelf-0.97-5) is already installed
package elfutils-libelf-0.97.1-3 (which is newer than elfutils-libelf-0.97-5) is already installed

This one is a RHEL4.4, registered within RHN.
Comment 14 Miroslav Suchý 2010-09-02 09:52:58 EDT
This problem was introduced during work on BZ 607908. It happens when there is mix of requires with version-release and only version.
Fixed in rev. 195757
Comment 16 Miroslav Suchý 2010-09-03 03:25:48 EDT
:( This fix works on that test case
 up2date -i gcc-c++
but does not work on test case of
 up2date -i xorg-x11-devel
Comment 17 Miroslav Suchý 2010-09-06 08:05:20 EDT
Fixed in rev. 195834.
Both cases (and bunch of others) now works correctly.
Comment 18 Jaromir Hradilek 2010-09-07 08:56:26 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Due to incorrect handling of package dependencies, up2date may have been unable to install certain packages. This error has been fixed, and all packages are now installed as expected.
Comment 19 Issue Tracker 2010-09-17 08:41:43 EDT
Event posted on 09-17-2010 06:17am EDT by brian.s.maher

[root@compute2 ~]# tar xvf up2date-4.8.1-33.el4_8.11.tar
x86_64/
x86_64/up2date-gnome-4.8.1-33.el4_8.11.x86_64.rpm
x86_64/up2date-debuginfo-4.8.1-33.el4_8.11.x86_64.rpm
x86_64/up2date-4.8.1-33.el4_8.11.x86_64.rpm
i386/
i386/up2date-4.8.1-33.el4_8.11.i386.rpm
i386/up2date-debuginfo-4.8.1-33.el4_8.11.i386.rpm
i386/up2date-gnome-4.8.1-33.el4_8.11.i386.rpm
[root@compute2 ~]# cd x86_64
[root@compute2 x86_64]# ll
total 2032
-rw-r--r--  1 apache apache 1929044 Sep  6 13:11
up2date-4.8.1-33.el4_8.11.x86_64.rpm
-rw-r--r--  1 apache apache   20549 Sep  6 13:11
up2date-debuginfo-4.8.1-33.el4_8.11.x86_64.rpm
-rw-r--r--  1 apache apache  114735 Sep  6 13:11
up2date-gnome-4.8.1-33.el4_8.11.x86_64.rpm
[root@compute2 x86_64]# rpm -Uifv up*
Preparing packages for installation...
up2date-4.8.1-33.el4_8.11
up2date-debuginfo-4.8.1-33.el4_8.11
up2date-gnome-4.8.1-33.el4_8.11
[root@compute2 x86_64]# up2date -uf

Fetching Obsoletes list for channel: rhel-x86_64-as-4...

Fetching Obsoletes list for channel: tpc-as-rhel4-x86-64...

Name                                    Version              Rel          
    Arch
----------------------------------------------------------------------------------------
ImageMagick                             6.0.7.1             20.el4_8.1    
     x86_64
ImageMagick-c++                         6.0.7.1             20.el4_8.1    
     x86_64
ImageMagick-c++-devel                   6.0.7.1             20.el4_8.1    
     x86_64
ImageMagick-devel                       6.0.7.1             20.el4_8.1    
     x86_64
ImageMagick-perl                        6.0.7.1             20.el4_8.1    
     x86_64
iputils                                 20020927            22.el4_8.2    
     x86_64
libxml2-devel                           2.6.16              12.8          
     x86_64
libxml2-python                          2.6.16              12.8          
     x86_64
openoffice.org                          1.1.5               10.6.0.7.EL4.5
     i386  
openoffice.org-i18n                     1.1.5               10.6.0.7.EL4.5
     i386  
openoffice.org-libs                     1.1.5               10.6.0.7.EL4.5
     i386  


Testing package set / solving RPM inter-dependencies...
warning: package freetype = 2.1.9-1 was already added, replacing with
freetype <= 2.1.9-1.rhel4.4
warning: package freetype = 2.1.9-1.rhel4.4 was already added, replacing
with freetype <= 2.1.9-10.el4.7
warning: package freetype = 2.1.9-10.el4.7 was already added, replacing
with freetype <= 2.1.9-14.el4.8
warning: package freetype = 2.1.9-14.el4.8 was already added, replacing
with freetype <= 2.1.9-15.el4.8
warning: package freetype = 2.1.9-4.el4 was already added, replacing with
freetype <= 2.1.9-5.el4
warning: package freetype = 2.1.9-5.el4 was already added, replacing with
freetype <= 2.1.9-6.el4
warning: package freetype = 2.1.9-6.el4 was already added, replacing with
freetype <= 2.1.9-7.el4.6
warning: package freetype = 2.1.9-7.el4.6 was already added, replacing
with freetype <= 2.1.9-8.el4.6
########################################
RPM package conflict error.  The message was:
Test install failed because of package conflicts:
The following packages were added to your selection to satisfy
dependencies:
Name                                    Version        Release
--------------------------------------------------------------
freetype                                2.1.9          1                  

freetype                                2.1.9          1.rhel4.4          

freetype                                2.1.9          10.el4.7           

freetype                                2.1.9          14.el4.8           

freetype                                2.1.9          15.el4.8           

freetype                                2.1.9          4.el4              

freetype                                2.1.9          5.el4              

freetype                                2.1.9          6.el4              

freetype                                2.1.9          7.el4.6            

freetype                                2.1.9          8.el4.6            

freetype-devel                          2.1.9          1                  

freetype                                2.1.9          1                  


package freetype-2.1.9-15.el4.8 (which is newer than freetype-2.1.9-1) is
already installed
package freetype-2.1.9-15.el4.8 (which is newer than
freetype-2.1.9-8.el4.6) is already installed
file /usr/lib/libfreetype.so.6.3.7 conflicts between attempted installs of
freetype-2.1.9-15.el4.8 and freetype-2.1.9-8.el4.6
file /usr/lib/libttf.so.2.3.0 conflicts between attempted installs of
freetype-2.1.9-15.el4.8 and freetype-2.1.9-8.el4.6

[root@compute2 x86_64]# 



This event sent from IssueTracker by kabbott 
 issue 1308093
Comment 20 Karl Abbott 2010-09-17 08:43:23 EDT
Covering for Rich today, the customer installed the latest version of the fix and it still didn't work for them. Their output can be seen in comment #19.

Karl
Comment 21 Martin Poole 2010-09-17 11:45:12 EDT
# rpm -Uvh up2date-4.9.1-16.el4.x86_64.rpm 
Preparing...                ########################################### [100%]
   1:up2date                warning: /etc/sysconfig/rhn/up2date created as /etc/sysconfig/rhn/up2date.rpmnew
########################################### [100%]
[root@host-126 ~]# up2date compat-libstdc++-296 --dry-run

Fetching Obsoletes list for channel: rhel-x86_64-as-4...

Fetching Obsoletes list for channel: rhn-tools-rhel-4-as-x86_64...

Fetching rpm headers...
########################################

Name                                    Version              Rel               Arch
----------------------------------------------------------------------------------------
compat-libstdc++-296                    2.96                132.7.2             i386  


Testing package set / solving RPM inter-dependencies...
warning: package libgcc = 3.4.3-22.1 was already added, replacing with libgcc <= 3.4.4-2
warning: package libgcc = 3.4.4-2 was already added, replacing with libgcc <= 3.4.5-2
warning: package libgcc = 3.4.5-2 was already added, replacing with libgcc <= 3.4.6-10
warning: package libgcc = 3.4.6-10 was already added, replacing with libgcc <= 3.4.6-11
warning: package libgcc = 3.4.6-11 was already added, replacing with libgcc <= 3.4.6-11.el4_8.1
warning: package libgcc = 3.4.3-9.EL4 was already added, replacing with libgcc <= 3.4.6-3
warning: package libgcc = 3.4.6-3 was already added, replacing with libgcc <= 3.4.6-3.1
warning: package libgcc = 3.4.6-3.1 was already added, replacing with libgcc <= 3.4.6-8
warning: package libgcc = 3.4.6-8 was already added, replacing with libgcc <= 3.4.6-9
########################################
RPM package conflict error.  The message was:
Test install failed because of package conflicts:
The following packages were added to your selection to satisfy dependencies:
Name                                    Version        Release
--------------------------------------------------------------
libgcc                                  3.4.3          22.1                
libgcc                                  3.4.3          9.EL4               
libgcc                                  3.4.4          2                   
libgcc                                  3.4.5          2                   
libgcc                                  3.4.6          10                  
libgcc                                  3.4.6          11                  
libgcc                                  3.4.6          11.el4_8.1          
libgcc                                  3.4.6          3                   
libgcc                                  3.4.6          3.1                 
libgcc                                  3.4.6          8                   
libgcc                                  3.4.6          9                   

package libgcc-3.4.6-10 (which is newer than libgcc-3.4.6-9) is already installed
file /lib/libgcc_s-3.4.6-20060404.so.1 conflicts between attempted installs of libgcc-3.4.6-11.el4_8.1 and libgcc-3.4.6-9
Comment 27 Miroslav Suchý 2010-10-06 06:11:16 EDT
*** Bug 617181 has been marked as a duplicate of this bug. ***
Comment 35 Garik Khachikyan 2010-11-08 08:07:25 EST
# REOPEN

the version: up2date-4.9.1-17.el4.x86_64.rpm seems not fixes the issue (but the version: up2date-4.8.1-33.el4_8.13.x86_64.rpm does).
Comment 38 Garik Khachikyan 2010-11-12 08:31:13 EST
# VERIFIED

I was able to reproduce the issue with (up2date-4.8.1-33.el4_8.8)

The current package: up2date-4.9.1-28.el4 fixes the all issues described with package installation examples in the bug comments.

---
up2date compat-libstdc++-296 --dry-run
up2date gcc-c++ --dry-run
up2date xorg-x11-devel --dry-run
up2date openldap-clients --dry-run
---

all are passed with correct determination of dependencies - all is fine.
Comment 39 errata-xmlrpc 2011-02-16 09:18:17 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0240.html

Note You need to log in before you can comment on or make changes to this bug.