Bug 61835 - screen doesn't run in CJK locales
Summary: screen doesn't run in CJK locales
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: screen (Show other bugs)
(Show other bugs)
Version: skipjack-beta1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Phil Copeland
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 61590
TreeView+ depends on / blocked
 
Reported: 2002-03-25 03:12 UTC by Jens Petersen
Modified: 2007-04-18 16:41 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-19 03:23:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jens Petersen 2002-03-25 03:12:48 UTC
Description of problem:
screen fails to run when started from the default Japanese, Korean or Chinese
locale.

Version-Release number of selected component (if applicable):
screen-3.9.11-1

How reproducible:
Always

Steps to Reproduce:
1.LC_MESSAGES=C LANG=ja_JP.eucjp screen
or 
2.LC_MESSAGES=C LANG=ko_KR.euckr screen
or
3.LC_MESSAGES=C LANG=zh_TW.Big5 screen
	

Actual Results:  setreuid: Operation not permitted


Expected Results:  should run without any problem

Additional info:

The problem doesn't occur with screen-3.9.10-1 and earlier packages.

Comment 1 Jens Petersen 2002-03-27 07:32:18 UTC
doesn't happen with debian's current screen-3.9.11 either.
So it seems to be a Red Hat specific problem.

Comment 2 Phil Copeland 2002-03-27 07:37:44 UTC
Yes,... Florian rebuilt screen over the top of the working screen  <expletives
deleted>
I'll be tackling this issue shortly but in the meantime I'll be reverting the
package to 3.9.10-1

consider 3.9.11 a dead duck for the moment

Phil
=--=

Comment 3 Bill Nottingham 2002-04-02 17:24:40 UTC
This works for me with 3.9.10-1, which should be in current rawhide. Please
re-open if it persists with that version.

Comment 4 Jens Petersen 2002-04-19 03:23:06 UTC
It's back in screen-3.9.11-2 AFAICT! :-(

Comment 5 Jens Petersen 2002-04-19 04:15:27 UTC
notting fixed it in screen-3.9.11-3.

Comment 6 Phil Copeland 2002-04-19 05:01:22 UTC
Bugger, I completely misread this bug. Sorry.



Note You need to log in before you can comment on or make changes to this bug.