Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 618358 - v7 server - fencing test requires fence-agents rpm
v7 server - fencing test requires fence-agents rpm
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
1.2
All Linux
low Severity medium
: ---
: ---
Assigned To: Greg Nichols
Guangze Bai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-26 14:38 EDT by Greg Nichols
Modified: 2015-02-08 16:36 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
fence-agents rpm package is needed by server side for fencing test. In v7 1.2, fencing test may fail because of mising fence-agents rpm package in server. This issue has been fixed in v7 1.3, now fence-agents rpm package is added as a dependency when running v7 on server side.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-09 12:15:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hardwaretest.py patch adding fence-agents to server startup rpm installation (608 bytes, patch)
2011-03-30 11:41 EDT, Greg Nichols
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0497 normal SHIPPED_LIVE v7 bug fix and enhancement update 2011-05-09 12:11:16 EDT

  None (edit)
Description Greg Nichols 2010-07-26 14:38:04 EDT
Description of problem:

Systems that are to run the v7 server in support of SUT's running the new fencing test must install the fence-agents rpm.   v7's rpm does not have fence-agents on its list of required rpms, and v7's plan-time mechanism for installing test-required rpms does not run on the server side.


Version-Release number of selected component (if applicable):

v7 1.2 R12
Comment 1 Rob Landry 2010-07-29 13:34:11 EDT
So would it be better to do a -server package or better to do a run time requires for "v7 server start"?
Comment 2 Greg Nichols 2011-03-30 11:39:05 EDT
We've added "server start" rpm checking for python-lxml, we can add fence-agents also.
Comment 3 Greg Nichols 2011-03-30 11:41:19 EDT
Created attachment 488806 [details]
hardwaretest.py patch adding fence-agents to server startup rpm installation
Comment 7 Caspar Zhang 2011-04-30 04:28:28 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
fence-agents rpm package is needed by server side for fencing test. In v7 1.2, fencing test may fail because of mising fence-agents rpm package in server. This issue has been fixed in v7 1.3, now fence-agents rpm package is added as a dependency when running v7 on server side.
Comment 8 errata-xmlrpc 2011-05-09 12:15:33 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0497.html

Note You need to log in before you can comment on or make changes to this bug.