Bug 61844 - RFE: create/use degraded RAID1 partitions
Summary: RFE: create/use degraded RAID1 partitions
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: FutureFeature
: 70063 1129300 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-25 06:42 UTC by Alexandre Oliva
Modified: 2014-08-13 14:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-28 22:55:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexandre Oliva 2002-03-25 06:42:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020310

Description of problem:
It would be nice if it were possible to create and/or use degraded RAID1
partitions with Anaconda.  Currently, there's no way to add /dev/null as some of
the replicas, as it is possible to do in /etc/inittab, and it refuses to create
a perfectly-valid RAID1 device out of a single partition.

The reason for me to want such a set up is that I like to keep root and boot
partitions replicated across my disks, but when I want to try a new release, I
like to install it from scratch, and then, when I'm confident I can switch to
it, I remove the old RAID devices and spread the new ones such that the space
that would be otherwise unused until the next release can actually be used for
something useful, namely, speeding up access to the root partition.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create a single RAID partition
2.Try to create a RAID1 device out of it


Actual Results:  Disk druid refuses to create a 1-disk RAID1 device, and doesn't
offer any way to add more `failed' partitions to the array.

Expected Results:  I'd love to be able to create a RAID1 with say 1 failed
replica, such that I could just raidhotadd my old system partition whenever I
figured I wouldn't need the old root partition any more.

Additional info:

Comment 1 Matt Wilson 2002-03-25 20:11:09 UTC
This is a very specialized and confusing case.  I may find some way to implement
it when all other work is done...

Comment 2 Jeremy Katz 2002-07-30 04:41:15 UTC
*** Bug 70063 has been marked as a duplicate of this bug. ***

Comment 3 Jeremy Katz 2003-07-28 22:55:16 UTC
Deferring

Comment 4 Chris Lumens 2014-08-13 14:38:46 UTC
*** Bug 1129300 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.