Bug 61846 - Installer will not install device driver on P4
Installer will not install device driver on P4
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-25 02:23 EST by Stephen Collier
Modified: 2008-01-17 12:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Collier 2002-03-25 02:23:13 EST
Description of Problem:Installer gives a "Failed to mount driver disk" after the driver disk is 
inserted at the appropriate point. This occurs with RH7.1, RH7.2, pensicola and skipjack on Asus 
P4T-E Motherboards (intel 850 chipset). This failed on 3 different systems with this type of 
motherboard. I installed 7.2 using a i686 motherboard and changing to  the P4T-E after 
installation. Everything worked, including floppy, just a very painfulway to 
install.


Version-Release number of selected component (if applicable):


How 
Reproducible:Every Time


Steps to Reproduce:
1.boot: linux dd 
2.insert dd floppy at 
appropriate time
3."Failed to mount driver disk"

Actual Results: couldn't install 
driver


Expected Results: Install Driver


Additional Information:
Comment 1 Jay Turner 2002-03-25 08:57:34 EST
Which driver disk are you attempting to use.  Trying to replicate here in the lab.
Comment 2 Stephen Collier 2002-03-25 19:29:47 EST
I am using an Adaptec 2400 driver disk. The particular driver is not the problem. The combination 
of motherboard (chipset) and installer seems to be not able to even access the floppy at the driver 
install stage. No access led even blinks on the floppy even though it is the same floppy as the 
install is taking place from.  The problem was solved on RH7.2 by using a P3 computer to install and 
move the disks and controller to P4 after installation. Is there any way to log the install 
proceedure as it all scrolls too fast during the hardware recognition phase before driver 
install.

Regards
Stephen
Comment 3 Jeremy Katz 2002-04-10 14:48:43 EDT
You should see a message saying what device is being used for the driver disk on
tty3.  If we can't access the floppy drive, that's probably a kernel bug though
Comment 4 Stephen Collier 2002-04-18 23:47:52 EDT
The F3 screen shows

515256 kB are available 
modules to insert cramfs vfat
module(s) 
cramfs vfat not found
load module set done
modules to insert ide-cd
module(s) to insert ide-
cd not found
load module set done
modules to insert scsi_mod sd_mod sr_mod
inserted 
/tmp/scsi_mod.o
inserted /tmp/sd_mod.o
inserted /tmp/sr_mod.o
load module set 
done
looking for usb controllers
found USB controller usb-uhci
modules to insert usb-
uhci
module(s) to insert usb-uhci not found
load module set done
failed to insert usb 
module
modules to insert hid keybdev usb-storage
module(s) hid keybdev not found
inserted 
/tmp/usb-storage.o
load module set done
probing for floppy devices
no floppy devices 
found
trying to mount device /tmp/fd0
Comment 5 Jeremy Katz 2002-04-25 17:53:58 EDT
The floppy drive isn't being found.  So either kudzu's probe is failing or the
kernel is having problems... from the installed system, what does
`/usr/sbin/kudzu -p -c FLOPPY` give?
Comment 6 Michael Fulbright 2002-05-23 12:52:24 EDT
Closing due to inactivity - please reopen if you have additional comments to add
to this bug.
Comment 7 Red Hat Bugzilla 2006-02-21 13:48:37 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.