Bug 618520 - boost-mpi{,-python} not obsoleted by rawhide boost
Summary: boost-mpi{,-python} not obsoleted by rawhide boost
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: boost (Show other bugs)
(Show other bugs)
Version: 14
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Benjamin Kosnik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-27 07:22 UTC by Mamoru TASAKA
Modified: 2013-08-09 05:49 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-04 22:15:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mamoru TASAKA 2010-07-27 07:22:34 UTC
Description of problem:
Currently my system has:
-------------------------------------------------------
# grep ^boost /var/log/rpmpkgs | sort
boost-1.41.0-12.fc14.i686.rpm
boost-date-time-1.41.0-12.fc14.i686.rpm
boost-devel-1.41.0-12.fc14.i686.rpm
boost-filesystem-1.41.0-12.fc14.i686.rpm
boost-graph-1.41.0-12.fc14.i686.rpm
boost-iostreams-1.41.0-12.fc14.i686.rpm
boost-math-1.41.0-12.fc14.i686.rpm
boost-mpi-1.41.0-4.fc13.i686.rpm
boost-mpi-python-1.41.0-4.fc13.i686.rpm
boost-program-options-1.41.0-12.fc14.i686.rpm
boost-python-1.41.0-12.fc14.i686.rpm
boost-regex-1.41.0-12.fc14.i686.rpm
boost-serialization-1.41.0-12.fc14.i686.rpm
boost-signals-1.41.0-12.fc14.i686.rpm
boost-system-1.41.0-12.fc14.i686.rpm
boost-test-1.41.0-12.fc14.i686.rpm
boost-thread-1.41.0-12.fc14.i686.rpm
boost-wave-1.41.0-12.fc14.i686.rpm
-------------------------------------------------------

It seems F-13 boost creats -mpi{,-python} subpackages,
while rawhide boost does not.
This causes upgrade path breakage when python27 rebuilt packages
is to be imported into rawhide tree:
-------------------------------------------------------
# env LANG=C yum --enablerepo=koji-py27 upgrade python
Error: Package: boost-mpi-python-1.41.0-4.fc13.i686 (installed)
           Requires: libpython2.6.so.1.0
           Removing: python-libs-2.6.5-17.fc14.i686 (installed)
               libpython2.6.so.1.0
           Updated By: python-libs-2.7-7.fc14.i686 (koji-py27)
               Not found
           Available: python-libs-2.6.4-27.fc13.i686 (koji-13)
               libpython2.6.so.1.0

So boost-mpi{-python} packages must be obsoleted by some rawhide
boost related packages.

Comment 1 Denis Arnaud 2010-07-28 13:46:04 UTC
(In reply to comment #0)
> boost-mpi-1.41.0-4.fc13.i686.rpm
> boost-mpi-python-1.41.0-4.fc13.i686.rpm
> -------------------------------------------------------
> 
> It seems F-13 boost creates -mpi{,-python} sub-packages,
> while rawhide boost does not.

The following links give the lists of sub-packages produced for Boost:
- on Rawhide/F14: http://koji.fedoraproject.org/koji/buildinfo?buildID=186705
- on Fedora 13: http://koji.fedoraproject.org/koji/buildinfo?buildID=176643

So, on both the distributions, no -mpi{,-python} sub-package is produced.

However, in an alpha version of the Boost RPM specification file (1.41.0-4, which you seem to have used), such sub-packages were produced: http://koji.fedoraproject.org/koji/buildinfo?buildID=152830
But (the final version of) Fedora 13 has shipped with Boost 1.41.0-7 (ftp://ftp.free.fr/mirrors/fedora.redhat.com/fedora/linux/releases/13/Fedora/i386/os/repoview/ for a quick view and http://download.fedoraproject.org/pub/fedora/linux/releases/13/Everything/i386/os for more details), in which no -mpi{,-python} sub-package has been produced.

So, your issue seems to come from the fact that you use(d) an early beta version of Fedora 13.

Comment 2 Mamoru TASAKA 2010-07-28 14:02:52 UTC
Well, actually I use(d)
rawhide -> rawhide ->  F-13 development branch -> rawhide (now)
( -> F-14 development branch )
Anyway I think adding Obsoletes is preferable.

Comment 3 Bug Zapper 2010-07-30 12:52:39 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Denis Arnaud 2010-07-31 10:14:57 UTC
(In reply to comment #2)
> Well, actually I use(d)
> rawhide -> rawhide ->  F-13 development branch -> rawhide (now)
> ( -> F-14 development branch )
> Anyway I think adding Obsoletes is preferable.

I am not an expert, but since the draft Boost package (with -mpi{,-python} sub-packages) never made it to a stable Fedora distribution, it means that the Obsoletes concerns only early testers of Rawhide. And since Rawhide is clearly meant to be used by "adventurous" testers, with some good knowledge on how to repair broken dependencies during upgrades, I do not see why all the users of stable Fedora distributions should inherit from that Obsoletes directive.

But I may have missed something.


Note You need to log in before you can comment on or make changes to this bug.