Bug 618588 - failed to parse type name `boolean'
Summary: failed to parse type name `boolean'
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tomáš Bžatek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
: 623585 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-27 10:23 UTC by Ralf Corsepius
Modified: 2015-03-03 22:51 UTC (History)
5 users (show)

Fixed In Version: nautilus-2.30.1-5.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-05 14:45:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ralf Corsepius 2010-07-27 10:23:33 UTC
Description of problem:

During today's yum update I encountered this:

...
  Updating       : nautilus-2.30.1-4.fc13.x86_64                                                                              15/108 
WARNING: failed to parse type name `boolean'
WARNING: invalid or missing type for schema (/schemas/apps/nautilus/preferences/navigation_window_saved_maximized)
...

No idea which effects this might have.

Comment 1 Rui Matos 2010-07-27 10:55:52 UTC
+1. I also tried the latest version from koji and still:

  Updating       : nautilus-2.30.1-6.fc13.i686                                2/4 
WARNING: failed to parse type name `boolean'
WARNING: invalid or missing type for schema (/schemas/apps/nautilus/preferences/navigation_window_saved_maximized)

Comment 2 Tomáš Bžatek 2010-07-27 13:31:48 UTC
Already fixed in nautilus-2.30.1-5.fc13

Comment 3 Ralf Corsepius 2010-07-27 14:59:15 UTC
(In reply to comment #2)
> Already fixed in nautilus-2.30.1-5.fc13    

Are you sure?


# yum update --enablerepo=updates-testing nautilus
...
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating       : nautilus-extensions-2.30.1-6.fc13.x86_64                                                                                                    1/4 
  Updating       : nautilus-2.30.1-6.fc13.x86_64                                                                                                               2/4 
WARNING: failed to parse type name `boolean'
WARNING: invalid or missing type for schema (/schemas/apps/nautilus/preferences/navigation_window_saved_maximized)
  Cleanup        : nautilus-extensions-2.30.1-4.fc13.x86_64                                                                                                    3/4 
  Cleanup        : nautilus-2.30.1-4.fc13.x86_64                                                                                                               4/4 

Updated:
  nautilus.x86_64 0:2.30.1-6.fc13                                                                                                                                  

Dependency Updated:
  nautilus-extensions.x86_64 0:2.30.1-6.fc13                                                                                                                       
=> Reopening.

Comment 4 Tomáš Bžatek 2010-07-27 15:09:45 UTC
I am sure - try this: `grep boolean /etc/gconf/schemas/apps_nautilus_preferences.schemas`. And try manually installing the rpm packages again, you won't see the message again. This is due to pre- and post- hooks, modifying gconf database.

Please confirm :-)

Comment 5 Ralf Corsepius 2010-07-27 15:21:33 UTC
(In reply to comment #4)
> I am sure - try this: `grep boolean
> /etc/gconf/schemas/apps_nautilus_preferences.schemas`.

with *-6 installed:
# grep boolean /etc/gconf/schemas/apps_nautilus_preferences.schemas
[nothing]

> And try manually
> installing the rpm packages again, you won't see the message again. 

I can confirm that "yum updating"

* nautilus-2.30.1-3 -> nautilus-2.30.1-6
(i.e. Fedora GA -> current updates-testing)
does not exhibit the warnings.

* nautilus-2.30.1-3 -> nautilus-2.30.1-4
(i.e. Fedora GA -> current updates)
does exhibit the warnings.

* nautilus-2.30.1-4 -> nautilus-2.30.1-6
(i.e. Fedora w/ updates applied -> current updates-testing)
does exhibit the warnings.

> This is due
> to pre- and post- hooks, modifying gconf database.
OK, this explains my observation above ;) 

This also demonstrates that gconf handling is far from being perfect in Fedora rpms (No surprize, because stateful databases are close to impossible to handle with rpm in general)

Comment 6 Tomáš Bžatek 2010-07-27 15:33:26 UTC
(In reply to comment #5)
> This also demonstrates that gconf handling is far from being perfect in Fedora
> rpms (No surprize, because stateful databases are close to impossible to handle
> with rpm in general)    

Soon there will be no gconf in most rawhide/F14 packages, we're porting to GSettings.

Comment 7 Piscium 2010-08-03 23:21:41 UTC
I also got this issue:

-----------
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating       : nautilus-2.30.1-6.fc13.i686                                                                                      1/37 
WARNING: failed to parse type name `boolean'
WARNING: invalid or missing type for schema (/schemas/apps/nautilus/preferences/navigation_window_saved_maximized)
  Updating       : nautilus-extensions-2.30.1-6.fc13.i686                                                                           2/37 
------------------

Interestingly if I look at file /etc/gconf/schemas/apps_nautilus_preferences.schemas, the type for navigation_window_saved_maximized is "bool" rather than "boolean". I am not sure if this is meaningful or not.

---------------------------
    <schema>
      <key>/schemas/apps/nautilus/preferences/navigation_window_saved_maximized</key>
      <applyto>/apps/nautilus/preferences/navigation_window_saved_maximized</applyto>
      <owner>nautilus</owner>
      <type>bool</type>
      <default>false</default>
      <gettext_domain>nautilus</gettext_domain>
      <locale name="C">
         <short>Whether the navigation window should be maximized.</short>
         <long>Whether the navigation window should be maximized by default.</long>
      </locale>
    </schema>
---------------------------

Comment 8 Tomáš Bžatek 2010-08-05 14:45:23 UTC
(In reply to comment #7)
> Interestingly if I look at file
> /etc/gconf/schemas/apps_nautilus_preferences.schemas, the type for
> navigation_window_saved_maximized is "bool" rather than "boolean". I am not
> sure if this is meaningful or not.

Yes, please see comment #4.

Closing as this is not an issue.

Comment 9 Tomáš Bžatek 2010-08-12 12:00:49 UTC
*** Bug 623585 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.