Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 618681 - Apache is failing to start pulp on port 443
Apache is failing to start pulp on port 443
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Retired
Component: z_other (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Sayli Karmarkar
Preethi Thomas
: QA-Closed
: 625462 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-27 10:30 EDT by Preethi Thomas
Modified: 2015-03-22 21:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-20 12:11:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2010-07-27 10:30:28 EDT
Description of problem:

[root@preethi ~]# /etc/init.d/httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd: [Tue Jul 27 10:27:06 2010] [warn] module ssl_module is already loaded, skipping
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
[Tue Jul 27 10:27:06 2010] [warn] _default_ VirtualHost overlap on port 443, the first has precedence
(98)Address already in use: make_sock: could not bind to address [::]:443
                                                           [  OK  ]


Now if I edit 
[root@preethi ~]# vi /etc/httpd/conf.d/pulp.conf
and change the port from 443 to 8443 it starts up

[root@preethi ~]# /etc/init.d/httpd restart
Stopping httpd:                                            [FAILED]
Starting httpd: [Tue Jul 27 10:28:11 2010] [warn] module ssl_module is already loaded, skipping
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
                                                           [  OK  ]
Comment 1 Sayli Karmarkar 2010-08-12 16:58:33 EDT
Not able to reproduce.

I have 443 port in my /etc/httpd/conf.d/pulp.conf and apache seems to start correctly.
Comment 2 Preethi Thomas 2010-08-17 12:21:56 EDT
[root@preethi pulp]# /etc/init.d/httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd: [Tue Aug 17 12:27:33 2010] [warn] module ssl_module is already loaded, skipping
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
[Tue Aug 17 12:27:33 2010] [warn] _default_ VirtualHost overlap on port 443, the first has precedence
(98)Address already in use: make_sock: could not bind to address [::]:443
                                                           [  OK  ]
Comment 3 Preethi Thomas 2010-08-18 15:24:03 EDT
verified.

[root@preethi ~]# hostname
preethi.usersys.redhat.com


Looks like my issue with 443 port has been resolved once I had the hostname assigned to my dyndns

[root@preethi ~]# /etc/init.d/httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd:
Comment 4 Preethi Thomas 2010-08-18 15:24:31 EDT
[root@preethi ~]# /etc/init.d/httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd:                                            [  OK  ]
[root@preethi ~]#
Comment 5 Preethi Thomas 2010-08-19 14:29:51 EDT
also moving the ssl.conf off of /etc/httpd/conf.d/
Comment 6 Preethi Thomas 2010-08-19 14:31:26 EDT
leaving it open as its still an issue.
Comment 7 John Matthews 2010-08-19 14:38:58 EDT
Saw this on 0.52 build.  If /etc/httpd/conf.d/ssl.conf is present (comes from mod_ssl RPM), then we can not start pulp.

There is a conflict since pulp.conf and ssl.conf both claim 443 under /etc/httpd/conf.d/

We don't see this in a dev setup because, pulp-dev.py moves /etc/httpd/conf.d/ssl.conf for us.
Comment 8 Preethi Thomas 2010-08-19 14:40:52 EDT
*** Bug 625462 has been marked as a duplicate of this bug. ***
Comment 9 Sayli Karmarkar 2010-09-08 11:10:52 EDT
This should be fixed. Moving to on_qa. Haven't hit the issue with recent builds.
Comment 10 Preethi Thomas 2010-09-10 09:56:56 EDT
[root@localhost rhn]# rpm -qa |grep pulp
pulp-0.0.60-1.fc12.noarch
pulp-common-0.0.60-1.fc12.noarch
pulp-client-0.0.60-1.fc12.noarch


[root@localhost rhn]# /etc/init.d/httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd: httpd: Could not reliably determine the server's fully qualified domain name, using localhost.localdomain for ServerName
                                                           [  OK  ]
Comment 11 Preethi Thomas 2010-10-20 12:11:22 EDT
Closed after review.

Note You need to log in before you can comment on or make changes to this bug.