Bug 618690 - KDE crashes at login [NEEDINFO]
KDE crashes at login
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-openchrome (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-27 10:43 EDT by Zenon Panoussis
Modified: 2017-12-06 07:44 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 07:44:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mcepl: needinfo? (redhatbugs)


Attachments (Terms of Use)
Comment #5 logs (136.97 KB, text/plain)
2010-07-29 09:14 EDT, Zenon Panoussis
no flags Details

  None (edit)
Description Zenon Panoussis 2010-07-27 10:43:11 EDT
I was unable to log in to KDE using kdm. Logging in to gnome works fine. Some more details can be found at 
https://bugzilla.redhat.com/show_bug.cgi?id=598358#c8 . 
Logs and configs at 
https://bugzilla.redhat.com/show_bug.cgi?id=598358#c9 , 
https://bugzilla.redhat.com/show_bug.cgi?id=598358#c10 and 
https://bugzilla.redhat.com/show_bug.cgi?id=598358#c11 . 

Following up on https://bugzilla.redhat.com/show_bug.cgi?id=598358#c12 I tried commenting out the synaptics section and all references to it in xorg.conf, got the same problem. I also tried commenting out the Videocard0 section, to no avail.

Substituting vesa for via in the Videocard0 section did work and I'm now logged in on KDE.

My xorg.conf comes from a previous centos5 installation on the same machine. Without it, a resolution of 1600xsomething is used and most graphics end up outside the screen. 

lspci |grep VGA
01:00.0 VGA compatible controller: VIA Technologies, Inc. CN400/PM800/PM880/PN800/PN880 [S3 UniChrome Pro] (rev 02)

I believe this should use the openchrome driver. However, substituting openchrome for vesa in xorg.conf brings back the KDE crashing problem. 

Any tests you want me to run, just holler.
Comment 2 RHEL Product and Program Management 2010-07-27 11:18:20 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 Matěj Cepl 2010-07-27 18:07:08 EDT
From kdm.log:

(EE) AlpsPS/2 ALPS GlidePoint Unable to query/initialize Synaptics hardware.
(EE) PreInit failed for input device "AlpsPS/2 ALPS GlidePoint"
(EE) config/hal: NewInputDeviceRequest failed (8)

--------------------------

Reporter, could you actually try to start Xorg without any xorg.conf whatsoever? What does happen? Could you attach the same logs from such test, please?

Thank you
Comment 4 Peter Hutterer 2010-07-28 02:13:21 EDT
(In reply to comment #3)
> (EE) AlpsPS/2 ALPS GlidePoint Unable to query/initialize Synaptics hardware.
> (EE) PreInit failed for input device "AlpsPS/2 ALPS GlidePoint"
> (EE) config/hal: NewInputDeviceRequest failed (8)

this looks more like a kernel issue. what's the evtest output for this device?
either way, this only means you can't use the touchpad but it's not crashing the server.

(In reply to comment #0)
> Substituting vesa for via in the Videocard0 section did work and I'm now logged
> in on KDE.

vesa/xserver issue then.
Comment 5 Zenon Panoussis 2010-07-29 09:12:36 EDT
(In reply to comment #3)

> Reporter, could you actually try to start Xorg without any xorg.conf
> whatsoever? What does happen? Could you attach the same logs from such test,
> please?

Starting without xorg.conf brings up the kde greeter in a way too big resolution (1600x1200 probably), which on the 1024x768 LCD monitor leaves a big part of the screen outside the monitor. The login dialogue is visible though, so I could test. After login, the KDE splash screen was shown for a few seconds, the KDE crashed and kdm brought the greeter back up. 

Logs attached. 

No abrt trace was created this time for some reason.
Comment 6 Zenon Panoussis 2010-07-29 09:14:12 EDT
Created attachment 435276 [details]
Comment #5 logs
Comment 7 Zenon Panoussis 2010-07-29 09:16:33 EDT
Oh, I should add that the mousepad has been working all along, with or without xorg.conf and KDE crashes.
Comment 10 Matěj Cepl 2010-08-19 16:52:46 EDT
We ommited one more interesting part of /var/log/messages

Jul 27 01:07:39 kon abrt[2543]: saved core dump of pid 2171 (/usr/bin/Xorg) to /var/spool/abrt/ccpp-1280185659-2171.new/coredump (2158592 bytes)

if you run abrt-gui manually ... do you still have there Xorg backtrace? Could we get it here?

Thank you
Comment 11 Zenon Panoussis 2010-08-24 21:54:38 EDT
(In reply to comment #10)

Will do, but need a few days. My delay is not lack of interest.
Comment 12 RHEL Product and Program Management 2011-01-07 11:00:37 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 13 RHEL Product and Program Management 2011-10-07 12:18:16 EDT
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 14 Jan Kurik 2017-12-06 07:44:23 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.