Bug 618694 - Desktop background cannot be changed
Desktop background cannot be changed
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-desktop (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-27 10:47 EDT by Felix Möller
Modified: 2010-08-30 14:15 EDT (History)
2 users (show)

See Also:
Fixed In Version: gnome-panel-2.31.6-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-18 21:20:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felix Möller 2010-07-27 10:47:07 EDT
I just updated from F13 to Rawhide (F14) and cannot change my desktop background anymore. The context menu on the desktop still has an entry to change the background. But no window whatsoever appears...
Comment 1 Bug Zapper 2010-07-30 08:53:36 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Fedora Update System 2010-08-13 14:19:31 EDT
brasero-2.31.5-4.fc14,dconf-0.5-2.fc14,devhelp-2.31.6-3.fc14,epiphany-2.30.2-3.fc14,evince-2.31.6.1-1.fc14,file-roller-2.31.5-2.fc14,gedit-2.30.2-2.fc14,glib2-2.25.13-2.fc14,gnome-bluetooth-2.31.6-3.fc14,gnome-user-share-2.30.0-7.fc14,gobject-introspection-0.9.3-1.fc14,nautilus-sendto-2.31.6-3.fc14,seahorse-plugins-2.30.1-3.fc14,totem-2.31.6-2.fc14,yelp-2.30.1-4.fc14,rhythmbox-0.13.0-5.fc14,sound-juicer-2.31.6-1.fc14,gnome-media-2.31.6-1.fc14,gnome-panel-2.31.6-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/brasero-2.31.5-4.fc14,dconf-0.5-2.fc14,devhelp-2.31.6-3.fc14,epiphany-2.30.2-3.fc14,evince-2.31.6.1-1.fc14,file-roller-2.31.5-2.fc14,gedit-2.30.2-2.fc14,glib2-2.25.13-2.fc14,gnome-bluetooth-2.31.6-3.fc14,gnome-user-share-2.30.0-7.fc14,gobject-introspection-0.9.3-1.fc14,nautilus-sendto-2.31.6-3.fc14,seahorse-plugins-2.30.1-3.fc14,totem-2.31.6-2.fc14,yelp-2.30.1-4.fc14,rhythmbox-0.13.0-5.fc14,sound-juicer-2.31.6-1.fc14,gnome-media-2.31.6-1.fc14,gnome-panel-2.31.6-1.fc14
Comment 3 Fedora Update System 2010-08-16 12:05:07 EDT
gnome-panel-2.31.6-1.fc14, totem-pl-parser-2.30.2-1.fc14, brasero-2.31.5-4.fc14, dconf-0.5-2.fc14, devhelp-2.31.6-3.fc14, epiphany-2.30.2-3.fc14, evince-2.31.6.1-1.fc14, file-roller-2.31.5-2.fc14, gedit-2.30.2-2.fc14, glib2-2.25.13-2.fc14, gnome-bluetooth-2.31.6-3.fc14, gnome-user-share-2.30.0-7.fc14, gobject-introspection-0.9.3-1.fc14, nautilus-sendto-2.31.6-3.fc14, seahorse-plugins-2.30.1-3.fc14, totem-2.31.6-2.fc14, rhythmbox-0.13.0-5.fc14, sound-juicer-2.31.6-1.fc14, yelp-2.30.1-4.fc14, gnome-media-2.31.6-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-panel totem-pl-parser brasero dconf devhelp epiphany evince file-roller gedit glib2 gnome-bluetooth gnome-user-share gobject-introspection nautilus-sendto seahorse-plugins totem rhythmbox sound-juicer yelp gnome-media'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/brasero-2.31.5-4.fc14,dconf-0.5-2.fc14,devhelp-2.31.6-3.fc14,epiphany-2.30.2-3.fc14,evince-2.31.6.1-1.fc14,file-roller-2.31.5-2.fc14,gedit-2.30.2-2.fc14,glib2-2.25.13-2.fc14,gnome-bluetooth-2.31.6-3.fc14,gnome-user-share-2.30.0-7.fc14,gobject-introspection-0.9.3-1.fc14,nautilus-sendto-2.31.6-3.fc14,seahorse-plugins-2.30.1-3.fc14,totem-2.31.6-2.fc14,yelp-2.30.1-4.fc14,rhythmbox-0.13.0-5.fc14,sound-juicer-2.31.6-1.fc14,gnome-media-2.31.6-1.fc14,gnome-panel-2.31.6-1.fc14,totem-pl-parser-2.30.2-1.fc14
Comment 4 Fedora Update System 2010-08-18 21:20:00 EDT
gnome-panel-2.31.6-1.fc14, totem-pl-parser-2.30.2-1.fc14, brasero-2.31.5-4.fc14, dconf-0.5-2.fc14, devhelp-2.31.6-3.fc14, epiphany-2.30.2-3.fc14, evince-2.31.6.1-1.fc14, gedit-2.30.2-2.fc14, glib2-2.25.13-2.fc14, gnome-bluetooth-2.31.6-3.fc14, gnome-user-share-2.30.0-7.fc14, gobject-introspection-0.9.3-1.fc14, nautilus-sendto-2.31.6-3.fc14, seahorse-plugins-2.30.1-3.fc14, totem-2.31.6-2.fc14, rhythmbox-0.13.0-5.fc14, sound-juicer-2.31.6-1.fc14, file-roller-2.31.90-1.fc14, yelp-2.30.1-4.fc14, gnome-media-2.31.6-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Winston Lee 2010-08-30 14:15:48 EDT
when I attempt to run the solution proposed in Comment 3, the problem is NOT resolved and I get the following output:

********************************************************
[winston@g71-wel ~]$ su -c 'yum --enablerepo=updates-testing update gnome-panel totem-pl-parser
> brasero dconf devhelp epiphany evince file-roller gedit glib2 gnome-bluetooth
> gnome-user-share gobject-introspection nautilus-sendto seahorse-plugins totem
> rhythmbox sound-juicer yelp gnome-media'
Password: 
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
fedora/metalink                                                                                              |  12 kB     00:00     
fedora                                                                                                       | 4.3 kB     00:00     
fedora/primary_db                                                                                            |  13 MB     01:27     
updates-testing/metalink                                                                                     |  15 kB     00:00     
updates-testing                                                                                              | 4.5 kB     00:00     
updates-testing/primary_db                                                                                   | 1.5 MB     00:09     
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package gnome-panel.x86_64 0:2.31.90-1.fc14 set to be updated
--> Processing Dependency: gnome-panel-libs = 2.31.90-1.fc14 for package: gnome-panel-2.31.90-1.fc14.x86_64
---> Package totem-pl-parser.x86_64 0:2.30.2-1.fc14 set to be updated
--> Running transaction check
--> Processing Dependency: gnome-panel-libs = 2.31.4-3.fc14 for package: gnome-panel-devel-2.31.4-3.fc14.x86_64
---> Package gnome-panel-libs.x86_64 0:2.31.90-1.fc14 set to be updated
--> Running transaction check
---> Package gnome-panel-devel.x86_64 0:2.31.90-1.fc14 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

====================================================================================================================================
 Package                              Arch                      Version                             Repository                 Size
====================================================================================================================================
Updating:
 gnome-panel                          x86_64                    2.31.90-1.fc14                      fedora                    2.1 M
 totem-pl-parser                      x86_64                    2.30.2-1.fc14                       fedora                    204 k
Updating for dependencies:
 gnome-panel-devel                    x86_64                    2.31.90-1.fc14                      fedora                     93 k
 gnome-panel-libs                     x86_64                    2.31.90-1.fc14                      fedora                     76 k

Transaction Summary
====================================================================================================================================
Upgrade       4 Package(s)

Total download size: 2.5 M
Is this ok [y/N]: y
Downloading Packages:
Setting up and reading Presto delta metadata
fedora/prestodelta                                                                                           |  532 B     00:00     
Processing delta metadata
Package(s) data still to download: 2.5 M
(1/4): gnome-panel-2.31.90-1.fc14.x86_64.rpm                                                                 | 2.1 MB     00:13     
(2/4): gnome-panel-devel-2.31.90-1.fc14.x86_64.rpm                                                           |  93 kB     00:00     
(3/4): gnome-panel-libs-2.31.90-1.fc14.x86_64.rpm                                                            |  76 kB     00:00     
(4/4): totem-pl-parser-2.30.2-1.fc14.x86_64.rpm                                                              | 204 kB     00:01     
------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                               152 kB/s | 2.5 MB     00:16     
warning: rpmts_HdrFromFdno: Header V3 RSA/SHA256 Signature, key ID 97a1071f: NOKEY
fedora/gpgkey                                                                                                | 3.2 kB     00:00 ... 
Importing GPG key 0x97A1071F:
 Userid : Fedora (14) <fedora@fedoraproject.org>
 Package: fedora-release-14-0.7.noarch (@anaconda-InstallationRepo-201008122237.x86_64/14-Alpha)
 From   : /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-x86_64
Is this ok [y/N]: y
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating       : gnome-panel-libs-2.31.90-1.fc14.x86_64                                                                       1/8 
  Updating       : gnome-panel-devel-2.31.90-1.fc14.x86_64                                                                      2/8 
  Updating       : gnome-panel-2.31.90-1.fc14.x86_64                                                                            3/8 
I/O warning : failed to load external entity "/etc/gconf/schemas/notification_area_applet.schemas"
Failed to open `/etc/gconf/schemas/notification_area_applet.schemas': No such file or directory
  Updating       : totem-pl-parser-2.30.2-1.fc14.x86_64                                                                         4/8 
  Cleanup        : gnome-panel-2.31.4-3.fc14.x86_64                                                                             5/8 
  Cleanup        : gnome-panel-devel-2.31.4-3.fc14.x86_64                                                                       6/8 
  Cleanup        : gnome-panel-libs-2.31.4-3.fc14.x86_64                                                                        7/8 
  Cleanup        : totem-pl-parser-2.30.1-2.fc14.x86_64                                                                         8/8 

Updated:
  gnome-panel.x86_64 0:2.31.90-1.fc14                             totem-pl-parser.x86_64 0:2.30.2-1.fc14                            

Dependency Updated:
  gnome-panel-devel.x86_64 0:2.31.90-1.fc14                         gnome-panel-libs.x86_64 0:2.31.90-1.fc14                        

Complete!

** (brasero:2886): WARNING **: AT-SPI: Accessibility bus not found - Using session bus.


** ERROR **: AT-SPI: Couldn't connect to bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

aborting...
bash: line 1:  2886 Trace/breakpoint trap   (core dumped) brasero dconf devhelp epiphany evince file-roller gedit glib2 gnome-bluetooth
bash: line 2: gnome-user-share: command not found

Gtk-ERROR **: GTK+ 3 symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
aborting...
[winston@g71-wel ~]$ 
********************************************************

any ideas?

Note You need to log in before you can comment on or make changes to this bug.