Bug 618724 - Unable to publish to Facebook
Summary: Unable to publish to Facebook
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: shotwell (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-27 15:32 UTC by clifford snow
Modified: 2011-03-18 00:53 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-18 00:53:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description clifford snow 2010-07-27 15:32:57 UTC
Description of problem: Unable to publish pictures to Facebook


Version-Release number of selected component (if applicable): shotwell 0.5.2


How reproducible: Everytime


Steps to Reproduce:
1.Select photo
2.Click on Publish
3.Log in to Facebook
  
Actual results:
Shotwell reports "Publishing to Facebook can't continue because the service returned a bad response" 
Session description object has no session key

Expected results:  
Picture uploaded to Facebook

Additional info: 
Publish to Google Picasa works.  
It appears the shotwell-connector is setup correctly in Facebook with the proper permissions.

Comment 1 clifford snow 2010-08-11 16:11:20 UTC
the developer reports that this bug should be resolved in version .6.  I tried to install the rawhide .6 version but ended up with too many dependencies. I was concerned that one or more of the dependencies would break something else.  Any chance that we could get .6 released for Fedora 13?

Comment 2 clifford snow 2010-09-21 02:13:41 UTC
Problem is resolved with version 0.7.2.  I compiled version 0.7.2 from source.  I can not upload to facebook without error messages.  This version also required libgexiv2 and LibRaw that are not available from Fedora.

Comment 3 Siddhesh Poyarekar 2010-12-31 09:35:01 UTC
F-14 has shotwell 0.7.2 along with libgexiv2 and LibRaw.

Comment 4 Brian Pepple 2010-12-31 14:03:21 UTC
This works for me in F14, but I don't think it possible to upgrade the F13 version because of the necessary deps that would be needed. This should probably be closed as WONTFIX.

Comment 5 Michel Alexandre Salim 2011-03-18 00:53:03 UTC
Right; shotwell 0.7.2 requires vala >= 0.9.5; unfortunately, there are significant packaging changes introduced in 0.9.4 that we deemed it unsafe to upgrade F-13.


Note You need to log in before you can comment on or make changes to this bug.