Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 618724 - Unable to publish to Facebook
Unable to publish to Facebook
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: shotwell (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-27 11:32 EDT by clifford snow
Modified: 2011-03-17 20:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-17 20:53:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description clifford snow 2010-07-27 11:32:57 EDT
Description of problem: Unable to publish pictures to Facebook


Version-Release number of selected component (if applicable): shotwell 0.5.2


How reproducible: Everytime


Steps to Reproduce:
1.Select photo
2.Click on Publish
3.Log in to Facebook
  
Actual results:
Shotwell reports "Publishing to Facebook can't continue because the service returned a bad response" 
Session description object has no session key

Expected results:  
Picture uploaded to Facebook

Additional info: 
Publish to Google Picasa works.  
It appears the shotwell-connector is setup correctly in Facebook with the proper permissions.
Comment 1 clifford snow 2010-08-11 12:11:20 EDT
the developer reports that this bug should be resolved in version .6.  I tried to install the rawhide .6 version but ended up with too many dependencies. I was concerned that one or more of the dependencies would break something else.  Any chance that we could get .6 released for Fedora 13?
Comment 2 clifford snow 2010-09-20 22:13:41 EDT
Problem is resolved with version 0.7.2.  I compiled version 0.7.2 from source.  I can not upload to facebook without error messages.  This version also required libgexiv2 and LibRaw that are not available from Fedora.
Comment 3 Siddhesh Poyarekar 2010-12-31 04:35:01 EST
F-14 has shotwell 0.7.2 along with libgexiv2 and LibRaw.
Comment 4 Brian Pepple 2010-12-31 09:03:21 EST
This works for me in F14, but I don't think it possible to upgrade the F13 version because of the necessary deps that would be needed. This should probably be closed as WONTFIX.
Comment 5 Michel Alexandre Salim 2011-03-17 20:53:03 EDT
Right; shotwell 0.7.2 requires vala >= 0.9.5; unfortunately, there are significant packaging changes introduced in 0.9.4 that we deemed it unsafe to upgrade F-13.

Note You need to log in before you can comment on or make changes to this bug.