Bug 618777 - [Arrandale] Screen corruption using scroll wheel on application that is not in focus.
Summary: [Arrandale] Screen corruption using scroll wheel on application that is not i...
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-intel (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: x86_64 Linux
low
medium
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard: [cat:rendering]
Keywords: Triaged
Depends On:
Blocks: 842499
TreeView+ depends on / blocked
 
Reported: 2010-07-27 17:27 UTC by Bill Sanford
Modified: 2017-12-06 11:01 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 11:01:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of corruption that doesn't refresh (692.56 KB, image/png)
2010-07-27 17:27 UTC, Bill Sanford
no flags Details
/var/log/Xorg.0.log (122.76 KB, text/plain)
2010-07-27 17:28 UTC, Bill Sanford
no flags Details
/var/log/Xorg.0.log (53.35 KB, text/plain)
2010-08-31 12:09 UTC, James Laska
no flags Details
dmesg (73.21 KB, text/plain)
2010-08-31 12:10 UTC, James Laska
no flags Details
/var/log/messages (107.01 KB, text/plain)
2010-08-31 12:11 UTC, James Laska
no flags Details

Description Bill Sanford 2010-07-27 17:27:01 UTC
Created attachment 434760 [details]
Screenshot of corruption that doesn't refresh

Description of problem: 

When using a scroll wheel to move a page up and down, the screen doesn't refresh when another window is in front and has the focus.

Version-Release number of selected component (if applicable): RHEL 6.0 snap8

How reproducible: reliably

Steps to Reproduce:
1. Open up TCMS in Firefox.
2. Put the open window in front of the TCMS window.
3. Hover over TCMS window and use scroll wheel on mouse to traverse up and down.
  
Actual results: TCMS window has corrupted table rows and doesn't refresh unless you hover over them with the mouse cursor.

Expected results: Screen would refresh without corruption

Additional info:

[bsanford@dhcp70-187 Desktop]$ lspci
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)

Comment 1 Bill Sanford 2010-07-27 17:28:15 UTC
Created attachment 434762 [details]
/var/log/Xorg.0.log

Comment 2 Bill Sanford 2010-07-27 17:36:51 UTC
The only corruption that is seen with the table rows in TCMS are covered by the window that is in focus.

Comment 4 Bill Sanford 2010-07-27 17:52:26 UTC
I used TCMS as an example to a Firefox issue. You can use Bugzilla in Firefox or load a Firefox web page and the corruption will still have the same behavior.

Comment 5 RHEL Product and Program Management 2010-07-27 17:57:42 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 6 Adam Jackson 2010-07-27 18:09:55 UTC
What versions of firefox and xulrunner is this with?

Comment 7 Bill Sanford 2010-07-27 18:15:32 UTC
Firefox version I am using is 3.6.7 and Mozilla XULRunner 1.9.2.7 - 20100714041006.

Comment 8 Kevin E. Martin 2010-08-13 18:39:34 UTC
Is this still happening with the latest updates (i.e., snap11)?

Comment 9 RHEL Product and Program Management 2010-08-18 21:30:48 UTC
Thank you for your bug report. This issue was evaluated for inclusion
in the current release of Red Hat Enterprise Linux. Unfortunately, we
are unable to address this request in the current release. Because we
are in the final stage of Red Hat Enterprise Linux 6 development, only
significant, release-blocking issues involving serious regressions and
data corruption can be considered.

If you believe this issue meets the release blocking criteria as
defined and communicated to you by your Red Hat Support representative,
please ask your representative to file this issue as a blocker for the
current release. Otherwise, ask that it be evaluated for inclusion in
the next minor release of Red Hat Enterprise Linux.

Comment 10 James Laska 2010-08-26 19:34:34 UTC
(In reply to comment #8)
> Is this still happening with the latest updates (i.e., snap11)?

bsanford: I am seeing it still and I believe I have 822.0 installed - the kernel is 2.6.32-66.el6.x86_64

Comment 11 Matěj Cepl 2010-08-31 10:23:05 UTC
In the end, I think these logs would be helpful. Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 12 James Laska 2010-08-31 12:09:27 UTC
Created attachment 442164 [details]
/var/log/Xorg.0.log

(In reply to comment #11)
> In the end, I think these logs would be helpful. Please add drm.debug=0x04 to
> the kernel command line, restart computer, and attach
> 
> * your X server config file (/etc/X11/xorg.conf, if available),

None used

> * X server log file (/var/log/Xorg.*.log)

See attachment

Comment 13 James Laska 2010-08-31 12:10:40 UTC
Created attachment 442165 [details]
dmesg

(In reply to comment #11)
> * output of the dmesg command, and

Comment 14 James Laska 2010-08-31 12:11:08 UTC
Created attachment 442166 [details]
/var/log/messages

(In reply to comment #11)
> * system log (/var/log/messages)

Comment 15 RHEL Product and Program Management 2011-02-01 06:06:25 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 16 RHEL Product and Program Management 2011-02-01 18:30:54 UTC
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

Comment 19 Bill Sanford 2011-09-28 13:43:29 UTC
Matej, I don't have the logs of that machine anymore.

Comment 20 Adam Jackson 2011-10-12 20:12:08 UTC
Move to 6.3.

Comment 23 Suzanne Yeghiayan 2012-02-14 23:01:18 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 24 Jan Kurik 2017-12-06 11:01:25 UTC
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/


Note You need to log in before you can comment on or make changes to this bug.