Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 618829 - [RFE] More user-friendly and usable PackageKit package search (we need google search logic)
[RFE] More user-friendly and usable PackageKit package search (we need google...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-27 16:25 EDT by Valent Turkovic
Modified: 2015-05-28 16:37 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-05-28 16:37:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PackageKit GUI results for "apache" (82.09 KB, image/png)
2010-07-27 16:36 EDT, Valent Turkovic
no flags Details
pkcon search details results for "apache" (41.99 KB, application/octet-stream)
2010-07-27 16:38 EDT, Valent Turkovic
no flags Details
pkcon search name results for "apache" (70.18 KB, application/octet-stream)
2010-07-27 16:39 EDT, Valent Turkovic
no flags Details
yum search results for "apache" (35.50 KB, application/octet-stream)
2010-07-27 16:39 EDT, Valent Turkovic
no flags Details

  None (edit)
Description Valent Turkovic 2010-07-27 16:25:53 EDT
Description of problem:
Package search has been bugging me for a long time now, I as an advanced user know exactly what I want and any package is just "yum install name" away, yes I still use yum and will continue to do so because I prefer yum output than pkcon :)

<rant>
also pkcon is harder to tell somebody to type over the phone or skype, yum is easier to type even you are regular cli user, and yum is easier command to remember but never mind, back to topic at hand. 
</rant>

For new users it is too hard to install package by searching because for any general search phrase and even for searches that are unique package names users get too many search results, and too often the top result is not what they are looking for. Too much information is not a good thing. 

This has been bugging me for months but haven't written anything about this because didn't see a solution until now.

After looking at Suse Studio Screencast [1] it become obvious really fast whan needs to be done because they have done it in really elegant way.

When doing a search in SUSE studio package search results are sorted by installation frequency. So packages which are most often installed are on top.

SUSE guys have great example by searching for apache package. I repeated apache search on Fedora with yum, pkcon and with PackageKit GNOME GUI. The results are attached in this RFE, but you can see how search isn't usable if user doesn't know exactly that needs to be installed.

Regular users won't go installing apache, this is just one example, but I had lots of similar situations in real life when I told some fedora users to just type name of package and to install it, but users got too many search results and got confused. I expect that only few packages will show and that main package will be first.

We need some king of google logic that would sort package search results.

Am I making any sense? Has something like this already in the works? Am I just wasting your time?

[1] http://susestudio.com/#screencast

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Valent Turkovic 2010-07-27 16:36:37 EDT
Created attachment 434835 [details]
PackageKit GUI results for "apache"

PackageKit GUI results for "apache"
Comment 2 Valent Turkovic 2010-07-27 16:38:38 EDT
Created attachment 434837 [details]
pkcon search details results for "apache"

pkcon search details results for "apache"
Comment 3 Valent Turkovic 2010-07-27 16:39:04 EDT
Created attachment 434838 [details]
pkcon search name results for "apache"

pkcon search name results for "apache"
Comment 4 Valent Turkovic 2010-07-27 16:39:42 EDT
Created attachment 434839 [details]
yum search results for "apache"

yum search results for "apache"
Comment 5 Richard Hughes 2010-07-28 05:19:07 EDT
(In reply to comment #0)
> Am I making any sense? Has something like this already in the works? Am I just
> wasting your time?

I've written app-install which kinda-does half of what you suggest, with the API extensions in place in the future for the other half. Ubuntu and suse already use my code.

Unless the fedora infrastructure guys start caring about application installing, then there's not a lot I can do. Every time I talk to infra people I'm told my solution uses too much bandwidth, then too much CPU, then that it can't rely on the last rawhide run. I've re-written app-install about 3 times now. I'm really frustrated and am waiting for them to stop being so negative about everything.

The other solution would be for me to put the extra metadata info on my people.fedoraproject.org page, although by not being on the mirrors would be a sure way to kill the server -- and it's hardly in the spirit of "doing the right thing".

The code exists. The feature is real. We just need fedora-infra to start being a little more accommodating.
Comment 6 Valent Turkovic 2010-07-29 03:12:56 EDT
Great news Richard, keeping my fingers crossed that this happens soon.
Comment 7 Valent Turkovic 2010-07-29 03:22:59 EDT
I mean great that code already exists, not the part that you had to rewrite it three times.
Comment 8 Matthias Clasen 2015-05-28 16:37:30 EDT
I think this has been covered by gnome-software

Note You need to log in before you can comment on or make changes to this bug.