Bug 618834 - pycryptopp: bundles libs, ftbfs on py2.7
Summary: pycryptopp: bundles libs, ftbfs on py2.7
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: pycryptopp   
(Show other bugs)
Version: 14
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Ruben Kerkhof
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-27 20:37 UTC by Toshio Ernie Kuratomi
Modified: 2010-10-17 17:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-17 17:44:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Toshio Ernie Kuratomi 2010-07-27 20:37:45 UTC
Description of problem:
pycryptopp had two issues:

1) it fails to build from source with python2.7
2) it still bundles setuptools_darcs and darcsver

Additional info:

I've added a patch and spec file change to rawhide to get rid of this.  This bug is so you can decide whether to use that patch on older releases as well.  (Since it's bundling libraries, I would encourage you to do so.)

Comment 1 Ruben Kerkhof 2010-07-30 11:56:22 UTC
Hi Toshio,

Thanks for doing this! I'll update the older releases as well.

Comment 2 Bug Zapper 2010-07-30 12:54:40 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Ruben Kerkhof 2010-10-17 17:44:34 UTC
pycryptopp 0.5.25-1 has been pushed to stable for all branches. Thanks Toshio!


Note You need to log in before you can comment on or make changes to this bug.